Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 11-23-2016, 07:43 AM
93_Rarity 93_Rarity is offline
Ready For Anything
 
Join Date: Oct 2014
Posts: 211
Default Cylinder 4,5,6 Misfire, Banks 1 Lean 2 Rich

Long story short, I've been fighting a random multiple misfire the past few weeks. On a trip he started acting up, so naturally I pretended to ignore him and checked codes when I got home. Was throwing a random multiple misfire code, air temp sensor code, some EGR code, and bank 1 was lean (which I found strange, as both banks normally ran lean, not just one). Figuring those codes were causing the misfires, I cleaned the MAF, changed the air temp sensor, and fixed an emissions hose thing that was torn, and it solved those codes, but it didn't solve the random multiple misfire issue. Ok then, research.
Found a common fix is to replace the coolant temp sensor, so I did. It ran great for about thirty miles or so, then started gradually getting worse till it was back to square one. Next best thing I found was the fuel filter. Gotcha. Changed that this past weekend, and he once again ran like a top.
For about thirty miles. Then he started getting worse, like before. So I had codes run this morning, and the random multiple misfire is gone now, but it says he's got cylinders 4, 5, and 6 misfiring and that bank 1 was running lean, and bank 2 is running rich. No other codes. Also might be worth mentioning that if I sit at an idle for too long, the CEL starts flashing at me.
What else is there? Intake gaskets? Injectors? Any help would be appreciated.
__________________
"The New Guy" 1997 Ford Ranger 4x4
*4.0- Auto- Throttle Cable Mod- 3" PA Body Lift- 31s- Custom Snorkel- Custom Front Bumper- Custom Windgate- Explorer Running Boards- Midland CB w/ Firestik II Antenna- Dumped Glasspack- 6" Halogen Grill Lights-

Yuki 2003 Ford Ranger- 2.3- 302 Project (sold)
"Rarity". 1993 2.3 Ford Ranger XLT (scrapped)
Reply With Quote
  #2  
Old 11-23-2016, 04:22 PM
Jswifto Jswifto is offline
Ford Ranger Driver
 
Join Date: Dec 2013
Posts: 1,532
Default

Could be the gaskets, could be the head is cracked or a bunch of other things. First step should be to look at the plugs and wires then maybe a compression test might be in order.
__________________
1999 Ranger 4.0 and extreme Snap-on tool fetish
Reply With Quote
  #3  
Old 11-24-2016, 01:42 AM
93_Rarity 93_Rarity is offline
Ready For Anything
 
Join Date: Oct 2014
Posts: 211
Default Re: Cylinder 4,5,6 Misfire, Banks 1 Lean 2 Rich

I forgot to mention that the plugs and coil pack were replaced about two weeks ago, and the wires seem good and were replaced back in February. I can try a compression test here in a couple days.
__________________
"The New Guy" 1997 Ford Ranger 4x4
*4.0- Auto- Throttle Cable Mod- 3" PA Body Lift- 31s- Custom Snorkel- Custom Front Bumper- Custom Windgate- Explorer Running Boards- Midland CB w/ Firestik II Antenna- Dumped Glasspack- 6" Halogen Grill Lights-

Yuki 2003 Ford Ranger- 2.3- 302 Project (sold)
"Rarity". 1993 2.3 Ford Ranger XLT (scrapped)
Reply With Quote
  #4  
Old 05-20-2018, 02:05 PM
accorddude accorddude is offline
Learning to use the forums
 
Join Date: May 2018
Posts: 2
Default Re: Cylinder 4,5,6 Misfire, Banks 1 Lean 2 Rich

If you have a cat converter on both banks then I would guess one is clogged. That would kill that half of the engine.
Reply With Quote
  #5  
Old 05-21-2018, 02:32 AM
Undrstm8ed Undrstm8ed is offline
Habenae Est Dominatus
 
Join Date: Apr 2013
Posts: 1,886
Default Re: Cylinder 4,5,6 Misfire, Banks 1 Lean 2 Rich

Quote:
Originally Posted by 93_Rarity View Post
So I had codes run this morning, and the random multiple misfire is gone now, but it says he's got cylinders 4, 5, and 6 misfiring and that bank 1 was running lean, and bank 2 is running rich. No other codes. Also might be worth mentioning that if I sit at an idle for too long, the CEL starts flashing at me.
First off, if your not burning all the fuel in 3 cylinders of course your going to get a rich code. That code will go away once you determine the Misfire issue.

Start here.. http://troubleshootmyvehicle.com/for...st-a-misfire-1
__________________
_______________________

My Build Pg. Threads
+ 93' Ranger Overlanding Build
+ 94' Ranger Bed Overlanding Trailer Build
+ 12 North Industries ~ I Support

Last edited by Undrstm8ed; 05-21-2018 at 02:42 AM.
Reply With Quote
  #6  
Old 06-14-2018, 03:05 PM
Arttie53 Arttie53 is offline
Learning to use the forums
 
Join Date: Jun 2018
Posts: 6
Default Re: Cylinder 4,5,6 Misfire, Banks 1 Lean 2 Rich

I had a similar problem with my '94 4.0. After much testing and replacing of this and that the problem was that #1 cyl. had the intake valve sucked up into the head, seat and all was about 1/4" above being flush. Truck ran fine for the most part. Intermittent sluggishness, stalling, life sucked. Passed smog like a new vehicle which threw a curve to the mech. "Why does this thing pass with a dead cylinder?" Finally, it didn't pass. I pulled the head and found the problem. I was told that this is not an uncommon problem for the 4.0. I got a rebuilt head online and voila'! problem solved.
Reply With Quote
  #7  
Old 06-14-2018, 04:53 PM
Ozzie8 Ozzie8 is offline
Learning to use the forums
 
Join Date: Jun 2018
Posts: 1
Default Re: Cylinder 4,5,6 Misfire, Banks 1 Lean 2 Rich

I have issues with my 2008 4.0. In the past 3 weeks we have changed the following; mass air sensor, idle air control valve, complete fuel pump assembly, fuel filter, plug wires plugs, we also cut open the catalytice converters and emptied them,new battery, alternator checked good,disconnected battery and reconnect,also 2 other new wires not sure what they do. drive 1/2 mile fine, falls flat on it's face, rpm's drop to 400.
__________________
2008 FX4 with 4.0 six cylinder
Reply With Quote
Reply

Tags
lean, misfire, rich

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
both banks running lean tredeh General Tech 6 04-18-2016 07:24 PM
Cylinder 5 Misfire - hard misfire at highway speeds, no smoke, no overheating LoveMyTruckNBama General Tech 2 12-04-2014 04:44 AM
check eng. indicates i have banks 1&2 running lean jazzcowboy Electrical Tech 1 09-05-2012 01:54 PM
misfire and burn rich condition dmarkjohn 4.0 SOHC / 4.0 OHV Tech 1 08-08-2012 01:35 AM
03 3.0 flex fuel cylinder 5 misfire fixed now 4 misfire error Steve o 3.0 Vulcan Tech 2 10-04-2011 06:19 PM