Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 06-26-2010, 07:12 AM
Donr93 ranger 4x4 Donr93 ranger 4x4 is offline
Learning to use the forums
 
Join Date: Jun 2010
Posts: 5
Default No power to ecm

I found this forum awhile back and have lurked and drooled at some of the pics. I have never had to do any real work on my ranger before just drive it to the limits. Did a couple clutches,brakes ,ac change to r-34. Now my dilema as it started blowing mass air flow sensors all 3 of them thankfully I was getting them at the junkyard for $50 a pop. Just towed it to my local guru who was actually stumped for once. No power readings at all on his snap on scanner. None of the sensors are reading or dispalying any voltage whatsoever. He said he has no clue and referred me to one guy who is on vacation. He said hes never seen this happen before. Somehow the truck will start and drove it home stalling at every turn and downshifting and popping the clutch. It was roasting my tires scratch. Any thoughts and input are greatly apreciated.
__________________
93 ranger xlt 4x4 4.0 all stock sitting on 31" Not a mud truck but a daily driver and tow truck for my flats boat 156000 and counting. Shes never left me stranded.
Reply With Quote
  #2  
Old 06-30-2010, 03:28 AM
Coleosis Coleosis is offline
The Sickest
 
Join Date: Jun 2009
Posts: 451
Default Re: No power to ecm

check all your grounds first...maybe one came loose...Cheapest think I can think of that would cause an electrical problem.
Reply With Quote
  #3  
Old 07-01-2010, 09:43 AM
Donr93 ranger 4x4 Donr93 ranger 4x4 is offline
Learning to use the forums
 
Join Date: Jun 2010
Posts: 5
Default Re: No power to ecm

I checked the grounds I could find.I did reconnect all the grounds on the negative battery cable as I had to switch over from the stock to a clamp style. I am clueless when it comes to my engine ,for I have never had to work on it. I have changed alternator, front bearings, ac compressor ect. Checked the eec relay and all the fuses are good. Have been researching but to no avail. Could ignition control module have anything to do with this issue. I read the scanner it showed zero voltage to every sensor on this truck cant and understand how it will even start yet almost idle. It will run til it hits a constant rpm then starts to miss really bad. Any info is greatly apprecaited.
__________________
93 ranger xlt 4x4 4.0 all stock sitting on 31" Not a mud truck but a daily driver and tow truck for my flats boat 156000 and counting. Shes never left me stranded.
Reply With Quote
  #4  
Old 07-01-2010, 11:17 AM
Psychopete Psychopete is offline
Psycho Pete
 
Join Date: Jun 2009
Posts: 1,489
Default Re: No power to ecm

If you didn't have any power to your computer, your engine will not run at all. Sounds like the data link wiring is either not making a connection with the scanner, or something to that extent. It is possible for a computer to go bad, however it is not common. You are likely going to have to wait for that tech to get off of vacation to look at it, the problems you are describing may get pretty involved.
Reply With Quote
  #5  
Old 07-17-2010, 07:12 AM
Donr93 ranger 4x4 Donr93 ranger 4x4 is offline
Learning to use the forums
 
Join Date: Jun 2010
Posts: 5
Default Re: No power to ecm

update as I finally found a mechanic to tackle this issue. He went through the wiring harness and grounds looking for shorts,for he replaced the computer. He did get a new one with a warranty because the way it was blown he thinks a good possibility it will happen again. Hot spots on the computer board normally caused by jumping a another vehicle with the cables crossed. He pretty much wondered the same thing as how the truck started or even run with the shape the ecm was in. Thanks for all input. By the way it ran $450 for the job just to have a reference as to price.
__________________
93 ranger xlt 4x4 4.0 all stock sitting on 31" Not a mud truck but a daily driver and tow truck for my flats boat 156000 and counting. Shes never left me stranded.
Reply With Quote
  #6  
Old 07-17-2010, 08:04 AM
OH MY JOSH OH MY JOSH is offline
Scored with your sister
 
Join Date: Jul 2010
Posts: 89
Default Re: No power to ecm

ECM drivers melted inside the casing.
Causes a class 2 data line malfunction which throws everything off.

*edit*
Just saw you got it fixed.
Good deal
__________________
ASE / Nissan / Hyundai / GM Certified Technician.
"I make slow shit go fast, and fast shit go faster".
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why does my 93 2.3L have no power? lessiseric27 4-Cylinder Tech 29 11-09-2011 01:35 PM
Replace passenger side power rear view mirror on 2005 Ranger with power windows Theodore Viera Interior Tech 2 06-21-2010 09:39 PM
New performance parts do I need to tune the ECM? blkranger231 General Tech 0 04-18-2010 06:24 AM
power red86 8-Cylinder Tech 5 04-11-2010 09:47 PM
Want to Buy: 2000 2.5 ecm felgar_1 Engine & Drivetrain Parts 0 03-21-2010 02:50 PM