Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 02-15-2016, 10:49 AM
ledbewa1 ledbewa1 is offline
Learning to use the forums
 
Join Date: Feb 2016
Posts: 4
Default 96 Ranger 4.0- ROugh idle then cuts off

Just bought this truck for my sons' first vehicle. When I bought it, it ran with a lil skip. I put on all new wires and plugs. While i was at it, I took off inspected and/or cleaned all sensors that needed it. I also put some Sea Foam through it to rid it of the carbon build up. Since then, it has ran like CRAP!!!!!!!! Any fresh ideas as to what this could be??? Please help before I break out the TNT!!!
__________________
Ole Blue!!

96 Ranger Ext Cab, 2WD, 4.0, Automatic
Reply With Quote
  #2  
Old 02-15-2016, 02:00 PM
richarddhoward richarddhoward is offline
Road Trippin' King!
 
Join Date: Nov 2009
Posts: 5,010
Send a message via MSN to richarddhoward
Default Re: 96 Ranger 4.0- ROugh idle then cuts off

I assume you cleaned the MAF?

These trucks (93-01 4.0 V6's) are known for popping the valve seal, I just had the heads redone in mine about three years ago. Check the leak down, and compression. It will generally give you a code for a misfire.

Clean the injectors, and run some IsoHeet through it, change the fuel filter also.

What did the plugs look like when you changed them?
__________________
97 Ranger - 4.0 V6 auto, 4wd, 31x10.5x15s Wild Country XTX Sport All Terrains, Warn locking hubs, Pioneer deck with iPod attachment, Snugtop Topper, K&N filter, scan gauge II, Hella 500 Lights, More parts coming, waiting for the paycheck to get bigger!

Truck built in loving memory of Norm Howard
Outcast Racing
PNW Crew!!!
Afterhours Clan!!
Quote:
Originally Posted by aaron_ariens View Post
I think Henry just shit himself
Quote:
Originally Posted by Radness View Post
Its kind of like that carnival game "Whack A Mole" but with guns! Haha
Reply With Quote
  #3  
Old 02-15-2016, 04:19 PM
ledbewa1 ledbewa1 is offline
Learning to use the forums
 
Join Date: Feb 2016
Posts: 4
Default Re: 96 Ranger 4.0- ROugh idle then cuts off

I sure did. i cleaned all the sensors just as a precautionary thing but ever since i ran sea-foam through it, it hasn't ran right since. just a few minutes ago, i came in from work and tried to fire it up to test a few things i've read about on here, she wont even fire!!! i replaced the fuel filter when i done the plugs. The plugs were not bad looking, just old and i seen one of the wires had a rubbed spot on them. Soooo aggravated at this thing!
__________________
Ole Blue!!

96 Ranger Ext Cab, 2WD, 4.0, Automatic

Last edited by ledbewa1; 02-15-2016 at 04:22 PM.
Reply With Quote
  #4  
Old 02-15-2016, 04:39 PM
Jswifto Jswifto is offline
Ford Ranger Driver
 
Join Date: Dec 2013
Posts: 1,532
Default

You sure you got the plug wires on the coil correct?
__________________
1999 Ranger 4.0 and extreme Snap-on tool fetish
Reply With Quote
  #5  
Old 02-15-2016, 05:00 PM
ledbewa1 ledbewa1 is offline
Learning to use the forums
 
Join Date: Feb 2016
Posts: 4
Default Re: 96 Ranger 4.0- ROugh idle then cuts off

yep! checked, double and triple checked! i just dont get it!!
__________________
Ole Blue!!

96 Ranger Ext Cab, 2WD, 4.0, Automatic
Reply With Quote
  #6  
Old 02-15-2016, 05:27 PM
DangerRanger2000 DangerRanger2000 is offline
Twist It Back!
 
Join Date: Dec 2010
Posts: 772
Default

Have you changed or tried cleaning the iac valve
__________________
2000 XLT 4x4 EXT. CAB 4.0/Auto Trans/3.73 gears/
31x10.50 BFG Rugged Terrains on MB Motoring Wheels/Pioneer Head Unit/JBL 12"/Camo Interior/'03 black and grey 60/40 seats/ green LED's Under Dash/T-Bar Crank/Windows-20% on the front, 5% on the back/Mustang Dome Light/06 Tails/
Reply With Quote
  #7  
Old 02-16-2016, 03:55 PM
ledbewa1 ledbewa1 is offline
Learning to use the forums
 
Join Date: Feb 2016
Posts: 4
Default Re: 96 Ranger 4.0- ROugh idle then cuts off

I have
__________________
Ole Blue!!

96 Ranger Ext Cab, 2WD, 4.0, Automatic
Reply With Quote
  #8  
Old 03-01-2016, 02:12 PM
richarddhoward richarddhoward is offline
Road Trippin' King!
 
Join Date: Nov 2009
Posts: 5,010
Send a message via MSN to richarddhoward
Default Re: 96 Ranger 4.0- ROugh idle then cuts off

Fix it yet?
__________________
97 Ranger - 4.0 V6 auto, 4wd, 31x10.5x15s Wild Country XTX Sport All Terrains, Warn locking hubs, Pioneer deck with iPod attachment, Snugtop Topper, K&N filter, scan gauge II, Hella 500 Lights, More parts coming, waiting for the paycheck to get bigger!

Truck built in loving memory of Norm Howard
Outcast Racing
PNW Crew!!!
Afterhours Clan!!
Quote:
Originally Posted by aaron_ariens View Post
I think Henry just shit himself
Quote:
Originally Posted by Radness View Post
Its kind of like that carnival game "Whack A Mole" but with guns! Haha
Reply With Quote
  #9  
Old 03-01-2016, 07:57 PM
Cwattido Cwattido is offline
Learning to use the forums
 
Join Date: Mar 2016
Posts: 2
Default Re: 96 Ranger 4.0- ROugh idle then cuts off

I am having somewhat the same problems with my 99 4.0 V6. Today i cleaned out the fuel tank again and put new gas in and flushed the lines again and it still cranks up, revs up when i press the gas and then it starts dying down and cuts off. I have replaced the following:
IACV
MAF
TPS
EGR
Spark Plugs
Spark Wires
Coil Pack
Fuel Pump/strainer/filter
Air filter
I put a new battery in it aswell and due to it not idling like it should the alternator cant charge the battery so I had to charge it. I havent checked the fuel pressure but I am going to do that tomorrow. I havent even had any error codes. I am wondering if the exhaust has anything to do with it? I dont know what else to do besides towing it to a shop.
All help will be greatly appreciated. Thanks in advance.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
95 4.0 4x4 ranger 3k idle- rough 1k idle Brendan92298 4.0 SOHC / 4.0 OHV Tech 9 12-10-2015 07:31 PM
2003 No oil pressure/hard idle/cuts out gunshow 3.0 Vulcan Tech 12 10-25-2015 10:14 AM
2.5L 99 ranger rough idle dubv187 General Tech 1 02-29-2012 05:48 AM
2003 3.0 Ranger - rough low idle (400 rpm), bogs at 2500K, rough shift, NOW FINE Chargerondavins 3.0 Vulcan Tech 1 03-26-2011 04:54 PM
Engine Cuts Off at Idle LEPLOTT 4-Cylinder Tech 1 07-08-2010 02:55 PM