Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 06-06-2010, 07:13 PM
Mike1101 Mike1101 is offline
Liking the Ford Ranger Forum
 
Join Date: Jun 2010
Posts: 16
Default 02' edge weird problems please help!!!

So starting last week, I got in my truck and noticed a little bit of a rocking feeling as I was sitting in the parking lot. It felt like someone was rocking the truck back and fourth. I ignored it at first and started driving. Everytime I stopped at a light, it would start rocking again and it's gotten a lot worse. It feels as if the truck is trying to drive while I have the brake pressed. The check engine light has been on for awhile so I changed the oil, and replaced the air and fuel filters. When I got the codes pulled it said something about sysetem too lean or something. I put fuel injector cleaner and "HEET" moisture remover in the tank. It stopped for a day and continued the next day. WHAT COULD THIS BE!!?! I dont know much about cars so maybe a lamens term explanation could help haha. Thank you!
Reply With Quote
  #2  
Old 06-06-2010, 07:21 PM
bordum128 bordum128 is offline
Like the Forums
 
Join Date: Jun 2010
Posts: 40
Default Re: 02' edge weird problems please help!!!

Well Im not genius either but my light came on the other day as well and I got the same code "P0174 system too lean". I have been told by dozens of people that that is indictive of a vacume leak or maybe a dirty mass air flow sensor. The crappy thing is that it can be tons and tons of things related to an air leak. I was even told that it could be a bad o2 sensor. Did it say something like "bank 1" or "Bank 2'?.... as for the car rocking??? I have no clue man, sorry.
__________________
2001 Ranger 3.0 V6 Flexfuel 2-wheel drive
Reply With Quote
  #3  
Old 06-16-2010, 04:34 AM
BoomZilla BoomZilla is offline
Volcanoduck
 
Join Date: Jun 2010
Posts: 28
Default Re: 02' edge weird problems please help!!!

Was the engine revving up at all? Side to side rocking or back to front?
Reply With Quote
  #4  
Old 06-16-2010, 05:05 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: 02' edge weird problems please help!!!

Its a vacuum line leak, probably behind the top of the engine.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #5  
Old 06-17-2010, 02:01 PM
bagdranger bagdranger is offline
Ford Pickup
 
Join Date: Dec 2009
Posts: 101
Default Re: 02' edge weird problems please help!!!

+1 fireranger. Sounds like a definite vacuum related issue. I dont see how heet would fix it for a day though. When the truck is running do you hear a hissing sound when the hood is up?
__________________
89 Ranger- front and rear bagd on drop ibeams and custom 2 link.

85 Ranger- 4x4 31" tires. Soon to be V8 swapped with D35s and 8.8.
Reply With Quote
  #6  
Old 06-19-2010, 01:24 AM
Chris Chris is offline
Ford Tough
 
Join Date: Feb 2010
Posts: 257
Default Re: 02' edge weird problems please help!!!

Fuel Pump will go out in a few months. Replace it. If its not a vacuum leak. If it is a vacuum leak then that'd be your problem.

My truck was acting foul to awhile back ago, and all these guys always said vacuum leak, and it turned out it was the fuel pump.
__________________
2004 Ford F150 Automatic FX4 SuperCrew 5.4L 3V Triton V8, No Muffler, true dual straight pipes, 3.73 Gears, 18" rims with Wrangler A/T's
White 2004 Ford Ranger XL, Auto, 4.0 SOHC, 4x4 Base Model, 16" Explorer Rims. 3.73 Gears, No muffler(Sold)
White 1997 Ford Expedition XLT 3inch Suspension lift, 38 Firestone M/T's 98 4.6L Police Interceptor high flow injectors, Super 44, brand new rebuilt transmission, with 3.73 gears(Not mine no more)
Reply With Quote
  #7  
Old 06-20-2010, 06:57 AM
bagdranger bagdranger is offline
Ford Pickup
 
Join Date: Dec 2009
Posts: 101
Default Re: 02' edge weird problems please help!!!

Chris it sounds like it could be either a vacuum leak or a fuel pump issue. You could throw a fuel pump on it but theres alot of money down the drain if that doesnt fix it. ya know.
__________________
89 Ranger- front and rear bagd on drop ibeams and custom 2 link.

85 Ranger- 4x4 31" tires. Soon to be V8 swapped with D35s and 8.8.
Reply With Quote
  #8  
Old 06-20-2010, 06:58 PM
Mike1101 Mike1101 is offline
Liking the Ford Ranger Forum
 
Join Date: Jun 2010
Posts: 16
Default Re: 02' edge weird problems please help!!!

Well I went to advanced auto parts last week, and they told me new codes showed cylinder 4 misfire. I replaced 3 of the spark plugs including number 4 and all the wires. I put Bosch +4 platinum spark plugs in there. It got dark so we had to save the rest for later but I got in the truck and it was still rocking really bad. The guy said it might be a problem with the coil pack?
Reply With Quote
  #9  
Old 06-20-2010, 10:10 PM
Chris Chris is offline
Ford Tough
 
Join Date: Feb 2010
Posts: 257
Default Re: 02' edge weird problems please help!!!

I am telling you mine was reporting Cylinder mis fire to. I had just put new plugs in mine, before it all started. Slight hesitation weird idle, and rocky feeling, mine was more noticeable cus it has no muffler, and to lean is generally not enough fuel. The guy above is right, check for vacuum leaks, and do the simple thing first, CHANGE your fuel filter!
__________________
2004 Ford F150 Automatic FX4 SuperCrew 5.4L 3V Triton V8, No Muffler, true dual straight pipes, 3.73 Gears, 18" rims with Wrangler A/T's
White 2004 Ford Ranger XL, Auto, 4.0 SOHC, 4x4 Base Model, 16" Explorer Rims. 3.73 Gears, No muffler(Sold)
White 1997 Ford Expedition XLT 3inch Suspension lift, 38 Firestone M/T's 98 4.6L Police Interceptor high flow injectors, Super 44, brand new rebuilt transmission, with 3.73 gears(Not mine no more)
Reply With Quote
  #10  
Old 06-21-2010, 03:28 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: 02' edge weird problems please help!!!

Quote:
Originally Posted by Mike1101 View Post
Well I went to advanced auto parts last week, and they told me new codes showed cylinder 4 misfire. I replaced 3 of the spark plugs including number 4 and all the wires. I put Bosch +4 platinum spark plugs in there. It got dark so we had to save the rest for later but I got in the truck and it was still rocking really bad. The guy said it might be a problem with the coil pack?
You put the wrong spark plugs in. Those Bosch plugs will probably make it worse. You need to be using Motorcraft or Autolite plugs in that engine.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #11  
Old 06-21-2010, 06:51 AM
smurphy smurphy is offline
02 Ranger
 
Join Date: Apr 2009
Posts: 161
Default Re: 02' edge weird problems please help!!!

Quote:
Originally Posted by FireRanger View Post
You put the wrong spark plugs in. Those Bosch plugs will probably make it worse. You need to be using Motorcraft or Autolite plugs in that engine.
I use Bosch +2 in my engine and it runs fine, why would the Bosch plugs make it worse?
__________________
2002 Tremor 2wd 3.0 4.10 L/S
6000k HID High/Low beams
255/70R16 General Grabbers AT2
Explorer OHC
Reply With Quote
  #12  
Old 06-21-2010, 06:56 AM
smurphy smurphy is offline
02 Ranger
 
Join Date: Apr 2009
Posts: 161
Default Re: 02' edge weird problems please help!!!

Quote:
Originally Posted by Mike1101 View Post
The guy said it might be a problem with the coil pack?
I had a cylinder 3 misfire a while back and replaced the plugs and wires, still misfiring so i replaced the coil pack and it went away. The coil pack was about 90 dollars at auto zone
__________________
2002 Tremor 2wd 3.0 4.10 L/S
6000k HID High/Low beams
255/70R16 General Grabbers AT2
Explorer OHC
Reply With Quote
  #13  
Old 06-21-2010, 07:47 PM
Mike1101 Mike1101 is offline
Liking the Ford Ranger Forum
 
Join Date: Jun 2010
Posts: 16
Default Re: 02' edge weird problems please help!!!

Lol no they are not the wrong spark plugs haha.....But thanks for the advice. And to whoever was saying change the fuel filter. I already did that =(
Reply With Quote
  #14  
Old 06-21-2010, 08:12 PM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: 02' edge weird problems please help!!!

Trust me, those plugs will fail within a year if they even work at all. Just because some idiot at a parts counter's computer says they'll fit doesn't mean they're the right ones. Believe me, they are NOT.

Vac leak remains the most likely solution.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #15  
Old 06-25-2010, 03:15 PM
bagdranger bagdranger is offline
Ford Pickup
 
Join Date: Dec 2009
Posts: 101
Default Re: 02' edge weird problems please help!!!

++++++++1 fireranger. Nothing but motorcrap or autolites. Anythin will fail not long after its installed. And smurphy its just somethin about these ford motors that doesnt like any plug other than whats mentioned. My 89 is VERY temperamental to plugs. It had splitfire when i got the truck and now its got e3s (only got e3s bc i wanted to see what the truck would do. Not expecting anythin yet)
__________________
89 Ranger- front and rear bagd on drop ibeams and custom 2 link.

85 Ranger- 4x4 31" tires. Soon to be V8 swapped with D35s and 8.8.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird weird issue... Chris Drivetrain Tech 11 07-08-2010 11:54 PM
Howdy Brothers [02' 2wd Manual] T00BEEFY Introduce Yourself 9 03-31-2010 11:48 AM
Weird starting 224CHOKE General Ford Ranger Discussion 2 02-12-2010 05:11 PM
weird idle problems talkington 4.0 SOHC / 4.0 OHV Tech 4 01-28-2010 01:33 PM