Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-15-2010, 11:00 AM
RangerLuc RangerLuc is offline
yup
 
Join Date: Sep 2009
Posts: 1,407
Default no misfire, still rough idle!!!

i took it to autozone and it passed the reader test, i thought i had a misfire but i didnt. now i dont know what to do to solve my rough idle problem. already ran seafoam through everything and didnt help. any suggestions?
__________________
2001 XLT 4x4 V6 4.0L auto
SAS'd D44 and 8.8. dual lockers, 38s, 12 bolt h1's, some other odds and ends
Reply With Quote
  #2  
Old 05-15-2010, 11:04 AM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: no misfire, still rough idle!!!

Check all the vacuum hoses?

Clean the IAC
Clean the MAF
__________________
2005 Edge

Reply With Quote
  #3  
Old 05-15-2010, 11:13 AM
RangerLuc RangerLuc is offline
yup
 
Join Date: Sep 2009
Posts: 1,407
Default Re: no misfire, still rough idle!!!

Quote:
Originally Posted by STL View Post
Check all the vacuum hoses?

Clean the IAC
Clean the MAF
vacuum hoses going from brake booster?
i cleaned out the MAF about a week ago, and whats IAC?
__________________
2001 XLT 4x4 V6 4.0L auto
SAS'd D44 and 8.8. dual lockers, 38s, 12 bolt h1's, some other odds and ends
Reply With Quote
  #4  
Old 05-15-2010, 11:23 AM
AlphaRanger AlphaRanger is offline
Like the Forums
 
Join Date: Feb 2010
Posts: 40
Default Re: no misfire, still rough idle!!!

IAC valve, like my truck I would think its connected to the throttle body.
__________________
2001 Ford ranger Extended cab, Automatic with a 3.0 Vulcan V6, and 160,000 Miles
Reply With Quote
  #5  
Old 05-15-2010, 11:28 AM
AlphaRanger AlphaRanger is offline
Like the Forums
 
Join Date: Feb 2010
Posts: 40
Default Re: no misfire, still rough idle!!!

forgot I have a pic.

__________________
2001 Ford ranger Extended cab, Automatic with a 3.0 Vulcan V6, and 160,000 Miles
Reply With Quote
  #6  
Old 05-15-2010, 11:53 AM
RangerLuc RangerLuc is offline
yup
 
Join Date: Sep 2009
Posts: 1,407
Default Re: no misfire, still rough idle!!!

thanks a lot man!
__________________
2001 XLT 4x4 V6 4.0L auto
SAS'd D44 and 8.8. dual lockers, 38s, 12 bolt h1's, some other odds and ends
Reply With Quote
  #7  
Old 05-15-2010, 11:57 AM
RangerLuc RangerLuc is offline
yup
 
Join Date: Sep 2009
Posts: 1,407
Default Re: no misfire, still rough idle!!!

now how would i go about cleaning this? it seems like theres a build up of oil in it?
__________________
2001 XLT 4x4 V6 4.0L auto
SAS'd D44 and 8.8. dual lockers, 38s, 12 bolt h1's, some other odds and ends
Reply With Quote
  #8  
Old 05-15-2010, 12:02 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: no misfire, still rough idle!!!

Good info right here. Use the same stuff you used to clean the MAF

http://www.explorer4x4.com/iac.htm


There are a few vacuum hoses besides the brake booster ones
__________________
2005 Edge

Reply With Quote
  #9  
Old 05-15-2010, 12:05 PM
RangerLuc RangerLuc is offline
yup
 
Join Date: Sep 2009
Posts: 1,407
Default Re: no misfire, still rough idle!!!

Quote:
Originally Posted by STL View Post
Good info right here. Use the same stuff you used to clean the MAF

http://www.explorer4x4.com/iac.htm


There are a few vacuum hoses besides the brake booster ones
ok thanks. i was looking at that pic of the IAC and i went and looked at mine, and mine doesnt have that spring in the one chamber, is that bad?
__________________
2001 XLT 4x4 V6 4.0L auto
SAS'd D44 and 8.8. dual lockers, 38s, 12 bolt h1's, some other odds and ends

Last edited by RangerLuc; 05-15-2010 at 12:16 PM.
Reply With Quote
  #10  
Old 05-15-2010, 12:51 PM
RangerLuc RangerLuc is offline
yup
 
Join Date: Sep 2009
Posts: 1,407
Default Re: no misfire, still rough idle!!!

just got done cleaning the crap outta the IAC valve. still has rough idle so now im on to checking the vacuum hoses. when checking these am i looking for clogs?
__________________
2001 XLT 4x4 V6 4.0L auto
SAS'd D44 and 8.8. dual lockers, 38s, 12 bolt h1's, some other odds and ends
Reply With Quote
  #11  
Old 05-15-2010, 01:27 PM
bcghosttowns bcghosttowns is offline
Thats what she said.
 
Join Date: Apr 2010
Posts: 209
Default Re: no misfire, still rough idle!!!

Get a bottle of brake clean and while the truck is running spray it around any vacumm hoses as well as the intake gasket,If the idle changes while spraying you have found your leak.The intake manifold gasket will cause a rough idle as well and is pretty common.
__________________
Quote:
Originally Posted by trcothorn View Post
racing decals duh
2010 ranger sport,3 inchs and 32's
Reply With Quote
  #12  
Old 05-15-2010, 01:40 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: no misfire, still rough idle!!!

Look for cracks or holes in the hoses.

Funny you are having problems similar to my sister today. She had a rough idle and also had a misfire.

Solved the misfire problem the coil pack had a crack in it around one of the post.

Once that was fixed she still had a rough idle and it was from a hose coming off the valve cover to the air box

Cut the bad end off and still had enough to reach and connect it back

After that everything is fine now

__________________
2005 Edge

Reply With Quote
  #13  
Old 05-15-2010, 04:39 PM
RangerLuc RangerLuc is offline
yup
 
Join Date: Sep 2009
Posts: 1,407
Default Re: no misfire, still rough idle!!!

damn im gunna forsure check those. other than the brake booster hoses, where else are the other vacuum hoses?
__________________
2001 XLT 4x4 V6 4.0L auto
SAS'd D44 and 8.8. dual lockers, 38s, 12 bolt h1's, some other odds and ends
Reply With Quote
  #14  
Old 05-15-2010, 04:49 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: no misfire, still rough idle!!!

There are 2 under the big plastic cover that covers the throttle body

Those are pretty common to have holes in them
__________________
2005 Edge

Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
96 2.3 ranger rough idle goes away? 96_ranger 4-Cylinder Tech 19 03-22-2012 06:37 AM
'91 3.0 rough idle? Sal 3.0 Vulcan Tech 3 10-15-2010 07:07 AM
ROUGH Idle 1997 4.0 V-6 What to look 4 ? glarestop 4.0 SOHC / 4.0 OHV Tech 2 10-21-2009 02:03 PM
Question: rough idle amp_lee78 4.0 SOHC / 4.0 OHV Tech 3 09-06-2009 02:41 PM
Rough Idle Jimmyboiii 4-Cylinder Tech 5 08-24-2009 05:01 AM