Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-11-2010, 05:05 AM
Frez1812 Frez1812 is offline
Ford Ranger Owner
 
Join Date: Apr 2010
Posts: 71
Default Starting harder than normal?

2004 Ford Ranger XLT 4x4 4.0 with 67,000 miles.

When I start the truck it seems to crank a little longer than what is expected.

I just changed the plugs and fuel filter,oil and still the same results.

Is this normal? Maybe I should swap out the plug wires?

Thanks
Reply With Quote
  #2  
Old 05-11-2010, 06:13 PM
geezmo2001 geezmo2001 is offline
My rangexplodeneer.
 
Join Date: Aug 2009
Posts: 247
Default Re: Starting harder than normal?

Can't hurt anything. Just do them one at a time or bad things usually result.
__________________
2001 Extended cab Edge, 4x4, 4.0, 4.10 gears, 3" PA body lift, Heartthrob dual exhaust, Roush Thunderbolt signal mirrors, 8000k hid head/foglights, Mountaineer leather buckets, Xplorer shorty console, Alpine 9856 receiver, 10" type r sub in ported box, air box mod, throttle cable mod, Rancho R5000 shox, Scangauge II, plus many other things...
Reply With Quote
  #3  
Old 05-11-2010, 06:18 PM
DieHard4rd DieHard4rd is offline
The Old Guy
 
Join Date: Jul 2009
Posts: 4,824
Default Re: Starting harder than normal?

Seafoam it!!
__________________
www.1fun4rd.blogspot.com
Reply With Quote
  #4  
Old 05-11-2010, 06:38 PM
BigT8600 BigT8600 is offline
Ford Tough
 
Join Date: Feb 2010
Posts: 234
Default Re: Starting harder than normal?

I wanna seafoam mine but I'm just nervous about screwing something up. And also, I changed my plugs about 2 months ago and I heard that I'd have to change them again soon after seafoaming.
__________________
~-SOLD-~
04' Edge 6 Cyl 3.0 5 Speed Manual 107K Miles
3" Body Lift - 33" All Terrain Tires
Drop In K&N Filter - Flowmaster - XM Commander Satellite Radio
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Clunk" noise under normal acceleration Pielet Drivetrain Tech 12 12-16-2010 12:30 PM
4.0L Not starting? cwc ranger 4.0 SOHC / 4.0 OHV Tech 12 12-08-2010 09:01 PM
Starting problems calranger General Tech 6 03-15-2010 07:13 PM
Running Lean-Whats normal? RangerSteve 3.0 Vulcan Tech 9 02-28-2010 07:40 PM
Is this normal, or am I Wylie Coyote? RangerChad 4.0 SOHC / 4.0 OHV Tech 12 09-23-2009 04:43 PM