Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-10-2010, 04:47 PM
Charlie Charlie is offline
Liking the Ford Ranger Forum
 
Join Date: Apr 2010
Posts: 28
Default 94 Ranger Problems, Please Help..

I have a 94 ranger 4.0 automatic. 157,000. I purchased it a month ago from we'll say a "less than honest" individual, and I just got it back from the shop on Thursday where they replaced the manifolds, manifold gaskets, and pretty much all the exhaust. They also replaced the valve cover gasket, plugs, and rear main seal. Today was the first time I have driven it since I brought it home on Thursday. When I drove it home on Thursday it drove fine with no issues at all. It had plenty of power. Today, I drove about 3 miles up the road to the gas station, and on the way back the check engine light started flashing and it had no power in overdrive. I threw it in neutral and let it coast to the side of the road where it died. It started right back up with no problem, but it idled really rough, and if I took my foot off the gas it would just die. It also had a very strong gas smell. I had to drive it the 2 miles back to the house in low gear because when you tried to shift back into drive and overdrive the idle was so rough, it had no power. The harder you push on the gas pedal the worse it cuts out. It makes a chugging type sound like its missing. I don't think I was able to get over 15 mph all the way back home. I don't have a code reader, and its not in any condition to drive 15 miles to the nearest autozone, so I have no idea what codes it might be throwing. I was wondering if this could be either my 02 sensors, because before, the manifolds were leaking so badly I don't think the oxygen sensors were even working correctly, or the coil pack. My step brother had a coil pack go bad on his S-10, and it sounded about like mine does now. What do you guys think it could be?
__________________
94 Ford Ranger XLT 4x4
Extended Cab .
4.0 Automatic
.

Last edited by Charlie; 05-10-2010 at 05:35 PM.
Reply With Quote
  #2  
Old 05-11-2010, 05:26 AM
Charlie Charlie is offline
Liking the Ford Ranger Forum
 
Join Date: Apr 2010
Posts: 28
Default Re: 94 Ranger Problems. Please Help.

Can anyone help me figure this out? I looked in my Haynes manual, and it says I need a volt meter and some other things to get the codes off. I don't have the tools to make this happen. Could it simply be a wire that wasn't connetect properly that maybe came off? I just wonder because not a week ago they had the engine out of it.
__________________
94 Ford Ranger XLT 4x4
Extended Cab .
4.0 Automatic
.
Reply With Quote
  #3  
Old 05-11-2010, 07:11 AM
zatticus zatticus is offline
Ford Rangers
 
Join Date: Feb 2010
Posts: 221
Default Re: 94 Ranger Problems. Please Help.

Look online about how to get your codes to read.
All you really need is some Jumper Wire.
: )

I think Copper wire works as a jumper wire.



You need to get the codes, because that sounds like something major.
D:
__________________
1994 Ford Ranger Splash
3.0L Automatic. Not much but she's mine.

I dream of a better tomorrow, where chickens can cross the road and not be questioned about their motives.
Reply With Quote
  #4  
Old 05-11-2010, 07:27 AM
Charlie Charlie is offline
Liking the Ford Ranger Forum
 
Join Date: Apr 2010
Posts: 28
Default Re: 94 Ranger Problems. Please Help.

It says in the Haynes manual that the engine coolant temp. sensor sends signals to the power control module that control both the timing and the fuel air mixture, so this may be the problem. I really don't know at this point.
__________________
94 Ford Ranger XLT 4x4
Extended Cab .
4.0 Automatic
.
Reply With Quote
  #5  
Old 05-11-2010, 08:00 AM
joldtown joldtown is offline
White Trash Ballin' MFer
 
Join Date: Oct 2009
Posts: 764
Default Re: 94 Ranger Problems. Please Help.

I'd put it on a wrecker and haul it back to that shop before I did anything. Make them warranty their work. I wouldn't even mention that it ran good for a few miles.
__________________
'02 XLT ext. cab 4.0 4x4 Off Road
Usual mods
Unusual color
Only a real man can pimp DWB

Quote:
Originally Posted by Johnbaum13
What really impresses us is power, originality within reason, and a nice clean rig that makes us say "damn!"
Quote:
Originally Posted by Ranger Sport
ew, don't touch me smakes
Reply With Quote
  #6  
Old 05-11-2010, 03:55 PM
Charlie Charlie is offline
Liking the Ford Ranger Forum
 
Join Date: Apr 2010
Posts: 28
Default Re: 94 Ranger Problems. Please Help.

Thanks for the input guys. I put it on a trailor and took it back to my mechanic. It ended up being the coil pack. 2 cylinders were not firing. He put a used coil pack on it for me, and didn't even charge me anything for doing it.
__________________
94 Ford Ranger XLT 4x4
Extended Cab .
4.0 Automatic
.
Reply With Quote
  #7  
Old 03-14-2015, 08:48 AM
_Rampage _Rampage is offline
Learning to use the forums
 
Join Date: Mar 2015
Posts: 3
Default Re: 94 Ranger Problems. Please Help.

HELLO I'm new here but so happy I found you

My little 94 ranger, 2 wheel drive 4 cylinder, it's like Vapor lock<
it will start for a minuet then its like parking it against a wall in 3rd and dropping the clutch, dead! anyone have an Idea?

Please Email me too. Thanx _Rampage
Reply With Quote
  #8  
Old 03-14-2015, 09:36 AM
stateranger stateranger is offline
Mr H....A....P...P....Y👿
 
Join Date: Nov 2012
Posts: 2,896
Default Re: 94 Ranger Problems. Please Help.

Quote:
Originally Posted by _Rampage View Post
HELLO I'm new here but so happy I found you

My little 94 ranger, 2 wheel drive 4 cylinder, it's like Vapor lock<
it will start for a minuet then its like parking it against a wall in 3rd and dropping the clutch, dead! anyone have an Idea?

Please Email me too. Thanx _Rampage
You will get a lot better response if you started a thread in the 4 cylinder tech section.
http://www.fordrangerforum.com/4-cylinder-tech/
__________________
2014 F150 xl 3.7 6 speed auto.

Quote:
Originally Posted by pk9298 View Post
HELL TO THE NO!! Abort abort abort!! That's the first thing to go!!! Ewwwww! I'm not no vampire! I don't enjoy red tea
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with Ranger 2.3L - P0171 nomoredan 4-Cylinder Tech 6 02-13-2011 08:07 PM
94 ranger e-brake problems johnnyC General Tech 2 08-08-2009 12:03 PM
88 Ranger: Ignition Problems ToniErin General Tech 5 06-15-2009 07:48 AM
99 ranger brake problems jpd5036 General Tech 3 05-05-2009 08:58 PM
ford ranger problems? Bertha T General Ford Ranger Discussion 2 11-30-2008 10:47 PM