Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 04-23-2010, 07:52 PM
ninenineranger ninenineranger is offline
Yea its 4x4!!
Join Date: Oct 2009
Posts: 102
Angry Hellp please!!

Well today was a ruff day.. On my way to work my truck felt weird, kind of hesitating uphill, jerked a few times, I floored it and it felt like it wanted to shut off, RPM's fell to like 1 or 1.5k then it raised to like 4k... A few mins later i was cruising at around 20-25 mph it started jerking, bucking, boging u name it.. Then i suddenly shut off sputtering, It would restart and fire up for about 5 secs then shut off agin.. did it numerous of times. Fuel Pump was priming. So I let it cool down then it starts up like nothing ever happened. No CEL.. BTW it was hot outside like 90-95F if it matters with the issue

I searched on crankshaft sensor, seems too match the syptoms.. Please help me out guys.. Thanx..
'99 Ford Ranger 4x4, 4.sl0w, Auto, 3" BL, 2" Torsion Crank, 2" blocks, 31x10.50,
Reply With Quote
Old 04-23-2010, 08:15 PM
Vrod21 Vrod21 is offline
Ford Tough
Join Date: Dec 2009
Posts: 325
Default Re: Hellp please!!

From the sound of it you got a vacuum leak. Check all your lines, especially from air filter to TB. Hope you find the problem.
(SOLD) 2003 Ranger 4.0L V6 FX4
2001 F150 Supercrew Triton V8 (DD)
2008 Fusion 3.0L SEL V6 (my baby)
1992 Taurus SHO MTX (my toy-almost Supercharged)
2004 Nissan Murano SL AWD (Wife's car)
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search