Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 04-14-2010, 06:13 PM
nccatdoc nccatdoc is offline
Learning to use the forums
 
Join Date: Apr 2010
Posts: 9
Default 93 ranger 4.0 has gas in the oil

the other day while driving thru town at about 45 mph the truck made a thumping noise twice then died, i coasted off the road tried cranking it again, it started but was running rough had to keep foot on accelerator or it would die, when i let it cut off it would only crankover after that, next morning it started but ran kinda rough, went 5 miles up the road it died, let it sit for 4 hrs it started ran rough 5 miles back home next day it started was running rough we poured some seafoam in the big vac tube from the brake booster truck smoked for awhile then started ideling smooth drove down the road 3 miles it ran fine stopped for a min. it cut off, restarted ran rough back home. after that it cranks and only tries to start.

I have fire at the coil, at the plugs, fuel, air, and as i stated above i found the oil level overfull and smells like gas.

Any ideas would be appreciated, timing chain? gears? camshaft sensor? computer? i did put a new crankshaft sensor on and a fuel pressure regulator and used Mass air sensor.


HELPPPPPPP Thanks
__________________
CHICKEN JOE 93 Ford Ranger XLT 4X4 ext cab 4.0 OHV 5spd purty much stock. Truck has 432,000 miles engine has 133,000 on rebuild and 133,000 on reman tranny. LOVE MY TRUCK

Last edited by nccatdoc; 04-16-2010 at 01:50 PM.
Reply With Quote
  #2  
Old 04-15-2010, 07:24 PM
rangercobra 4.0l rangercobra 4.0l is offline
Ford Ranger Owner
 
Join Date: May 2009
Posts: 57
Default Re: 93 ranger 4.0 has gas in the oil

your truck run rich check the fuel regulator.
__________________
http://www.cardomain.com/id/781300


Ford Ranger 4.0l 97 aut. BBK Supercharger
8# boost, 241HP @ 270TQ, Rush muffler ss, 3.73 FR and posi, BBK header,BBK TB, aeromotive FR 1:1, walbro fuel pump 255lph HP, sniper tuning, port/pulish, comp cam 422, wiseco piston, chassis tech 3/4
Reply With Quote
  #3  
Old 04-16-2010, 01:49 PM
nccatdoc nccatdoc is offline
Learning to use the forums
 
Join Date: Apr 2010
Posts: 9
Default Re: 93 ranger 4.0 has gas in the oil

I changed the fuel pressure regulator and it had no affect
__________________
CHICKEN JOE 93 Ford Ranger XLT 4X4 ext cab 4.0 OHV 5spd purty much stock. Truck has 432,000 miles engine has 133,000 on rebuild and 133,000 on reman tranny. LOVE MY TRUCK
Reply With Quote
  #4  
Old 04-16-2010, 02:43 PM
CivicKiller-16 CivicKiller-16 is offline
Ford Ranger Owner
 
Join Date: Feb 2010
Posts: 72
Default Re: 93 ranger 4.0 has gas in the oil

you have bad rings thats my 2 cents gow many miles
__________________
2007 ranger 2.3 5 speed "civic killer" 1961 jeep cj-5 REDNECK RICER [><] "If a leave here tomorrow will you still remember me" Lynyrd Skynyrd 4 ever
Reply With Quote
  #5  
Old 04-16-2010, 04:50 PM
richarddhoward richarddhoward is offline
Road Trippin' King!
 
Join Date: Nov 2009
Posts: 5,010
Send a message via MSN to richarddhoward
Default Re: 93 ranger 4.0 has gas in the oil

Don't drive it till you know what's wrong. Have you done a compression test? If you spun a bearing you may have wasted the rings or possibly a cylinder (which would explain the thunks) which would cause fuel to get past the piston and down into your oil.
__________________
97 Ranger - 4.0 V6 auto, 4wd, 31x10.5x15s Wild Country XTX Sport All Terrains, Warn locking hubs, Pioneer deck with iPod attachment, Snugtop Topper, K&N filter, scan gauge II, Hella 500 Lights, More parts coming, waiting for the paycheck to get bigger!

Truck built in loving memory of Norm Howard
Outcast Racing
PNW Crew!!!
Afterhours Clan!!
Quote:
Originally Posted by aaron_ariens View Post
I think Henry just shit himself
Quote:
Originally Posted by Radness View Post
Its kind of like that carnival game "Whack A Mole" but with guns! Haha
Reply With Quote
  #6  
Old 04-16-2010, 04:54 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: 93 ranger 4.0 has gas in the oil

Ya sounds like the rings on a piston have gone. That is the easiest way for fuel to enter into the oil.
__________________
2005 Edge

Reply With Quote
  #7  
Old 04-17-2010, 03:34 PM
nccatdoc nccatdoc is offline
Learning to use the forums
 
Join Date: Apr 2010
Posts: 9
Default Re: 93 ranger 4.0 has gas in the oil

If it did jump time, would'nt that flood the cylinders with gas ??
__________________
CHICKEN JOE 93 Ford Ranger XLT 4X4 ext cab 4.0 OHV 5spd purty much stock. Truck has 432,000 miles engine has 133,000 on rebuild and 133,000 on reman tranny. LOVE MY TRUCK
Reply With Quote
  #8  
Old 04-17-2010, 03:42 PM
richarddhoward richarddhoward is offline
Road Trippin' King!
 
Join Date: Nov 2009
Posts: 5,010
Send a message via MSN to richarddhoward
Default Re: 93 ranger 4.0 has gas in the oil

Quote:
Originally Posted by nccatdoc View Post
If it did jump time, would'nt that flood the cylinders with gas ??
No, that would mean it would run rough though, your injectors would just shoot fuel at the wrong time. Your engine wouldn't start if you jumped time. Your cam and crank position sensors wouldn't be in alignment and so it wouldn't crank.
__________________
97 Ranger - 4.0 V6 auto, 4wd, 31x10.5x15s Wild Country XTX Sport All Terrains, Warn locking hubs, Pioneer deck with iPod attachment, Snugtop Topper, K&N filter, scan gauge II, Hella 500 Lights, More parts coming, waiting for the paycheck to get bigger!

Truck built in loving memory of Norm Howard
Outcast Racing
PNW Crew!!!
Afterhours Clan!!
Quote:
Originally Posted by aaron_ariens View Post
I think Henry just shit himself
Quote:
Originally Posted by Radness View Post
Its kind of like that carnival game "Whack A Mole" but with guns! Haha
Reply With Quote
  #9  
Old 04-20-2010, 03:10 PM
nccatdoc nccatdoc is offline
Learning to use the forums
 
Join Date: Apr 2010
Posts: 9
Default Re: 93 ranger 4.0 has gas in the oil

ok, thanks guys for all the help, here's where i'm at now. Drained the oil and strained it as it was coming out of the oil pan. there were no signs of metal pieces or shavings. Compression is good on all cylinders ( checked with compression gauge ) changed all 6 plugs, and have fire on all 6. engine is still flooding. after cranking a few turns it fires runs rough and has a strong gas smell...................... any chance a sensor is bad or maybe the computer? I changed the crankshaft position sensor, fuel pressure regulator, and tried a different mass Air sensor. oh and when you hook up the test light ( as the book shows ) to check error codes it will flash the codes . its just a little confusing reading them. ................Thanks agian
__________________
CHICKEN JOE 93 Ford Ranger XLT 4X4 ext cab 4.0 OHV 5spd purty much stock. Truck has 432,000 miles engine has 133,000 on rebuild and 133,000 on reman tranny. LOVE MY TRUCK
Reply With Quote
  #10  
Old 04-20-2010, 06:07 PM
nccatdoc nccatdoc is offline
Learning to use the forums
 
Join Date: Apr 2010
Posts: 9
Default Re: 93 ranger 4.0 has gas in the oil

I ran the codes off the self test. I hope i read them right. example 1 long flash pause 1 long flash pause 7 short flashes (4 sec pause ) code 117. then starts again for another code.
Heres what i came up with.
117 - temp. circuit below min. voltage indecates above 245 deg. F
122 - throttle position sensor below min. voltage
112 - intake air temp.sensor circuit grounded above 245 deg F
513 - internal voltage failure in PCM
565 - canister purge circuit failure
556 - primary fuel pump circuit failure

that is if the code like, 565 reads in flashes like, 5 short flashes Pause 6 short flashes Pause 5 short flashes
could this possiablly be a PCM gone bad??????????

sorry to keep bugging you guys just trying to get somwhere with this nightmare.
__________________
CHICKEN JOE 93 Ford Ranger XLT 4X4 ext cab 4.0 OHV 5spd purty much stock. Truck has 432,000 miles engine has 133,000 on rebuild and 133,000 on reman tranny. LOVE MY TRUCK

Last edited by nccatdoc; 04-20-2010 at 08:17 PM. Reason: add text
Reply With Quote
  #11  
Old 05-20-2010, 05:35 PM
superman451s superman451s is offline
Learning to use the forums
 
Join Date: May 2010
Posts: 1
Default Re: 93 ranger 4.0 has gas in the oil

Was hoping you could tell me how you resolved your issue, my truck is the exact same truck with 133k on it and doing the exact same thing. I have replace O2 sensors, mass air sensor, tps sensor and all the plugs. What did you did you do to get back on the road?
Reply With Quote
  #12  
Old 05-20-2010, 07:35 PM
mickblock mickblock is offline
Get off my lawn
 
Join Date: Apr 2010
Posts: 1,059
Default Re: 93 ranger 4.0 has gas in the oil

I just think that there are certain things that can cause a string of dtc's. Just for example; like loom damage, water/corrosion inside those big camlock connectors etc, and once you find and fix it, you solve multiple failures in one shot.
The 565 might help explain the gas in the oil though. So that kinda verifies your reading of the codes.

Two thumps eh?
__________________
08 4.0 Sport 4x4
Stock
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search