Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > Engine Tech Forum > 6-Cylinder Tech > 4.0 SOHC / 4.0 OHV Tech
Forgot Password? Join Us!


Reply
 
LinkBack Thread Tools Search this Thread

  #1  
Old 04-13-2010, 03:06 PM
Liking the Ford Ranger Forum
 
Join Date: Feb 2010
Posts: 29
Default 94 4.0L runs rough when first started

My little 94 Ranger 4.0L with around 220,000 is getting to where it runs rough when first started, especially when the engine is hot. It even dies sometimes. The idle seems kinda erratic too. After a minute or two it will usually settle out and run and drive just fine. It will also usually act right when returning to idle after driving. The idle does seem a little high and occasionally under full throttle it feels like it might miss a lick or two. Still gets consistent 21 mpg, last fill up was 18 mpg but I think that I forgot to trip the odometer or something.
Where should I start looking?
__________________
****My Pics****

1994 Ford Ranger 4.0L 5spd ext cab, stock
1999 Ford F-250SD Powerstroke 4x4, no where near stock
1969 Ford F-100 360, stock
1999 Jeep Grand Cherokee, stock
2000 John Deere 4700 4x4
1956 John Deere 60
1951 John Deere MT
1948 John Deere A
1947 John Deere A
Etc.

“Government, even in its best state, is but a necessary evil; in its worst state, an intolerable one”

The Government cannot give anyone anything that they didn’t first forcibly take from someone else!
Reply With Quote
  #2  
Old 05-07-2010, 04:41 AM
Like the Forums
 
Join Date: Oct 2009
Posts: 33
Default Re: 94 4.0L runs rough when first started

Mine did the same thing and it was the EGR valve. Also could be the IAC, Idle Air Control.
__________________
1996 Ranger XLT V6 4.0 5 Speed Manual.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
It started with one, then went from there.... cwc ranger General Ford Ranger Discussion 17 04-09-2010 08:48 AM
enigine runs rough after it cools down bigbadbiker 4.0 SOHC / 4.0 OHV Tech 1 01-25-2010 08:12 PM
runs rough/choked til warm then clicks over to proper idle khgxdctv Electrical Tech 0 11-11-2009 05:09 PM
Ranger started shaking tippy 4-Cylinder Tech 7 05-26-2009 07:48 PM
1998 Ford Ranger runs rough with sulfur smell? Michael K General Ford Ranger Discussion 1 01-01-2009 12:57 PM



Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.