Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 01-06-2014, 04:39 PM
jgroffv jgroffv is offline
Learning to use the forums
 
Join Date: Nov 2013
Posts: 8
Default 4.0 sohc misses only when cold HELP!!!

Someone please help my ranger is missing when its cold outside, once it warms up and I give it a few minutes I start it back up and it runs fine for about 10min then resrart the process over. I have put new spark plugs coil intake gaskets wires still same cylinder is missing (#2) I am about to go crazy truck has 150000 miles I mean all things I replaced to this point needed replaced.
__________________
Ohio John 01extcab 4x4 4.0
Reply With Quote
  #2  
Old 01-06-2014, 04:43 PM
bdillard77 bdillard77 is offline
Wish in one hand...
 
Join Date: Jul 2012
Posts: 4,826
Default

Could you clarify what your Ranger is missing? I'm having a hard time understanding you're trying to say.
Reply With Quote
  #3  
Old 01-06-2014, 04:45 PM
jgroffv jgroffv is offline
Learning to use the forums
 
Join Date: Nov 2013
Posts: 8
Default Re: 4.0 sohc misses only when cold HELP!!!

Its misfiring just saying didnt think that it was a question when I mentioned spark plugs and coil pack but hay I appreciated the humor
__________________
Ohio John 01extcab 4x4 4.0
Reply With Quote
  #4  
Old 01-06-2014, 04:59 PM
bdillard77 bdillard77 is offline
Wish in one hand...
 
Join Date: Jul 2012
Posts: 4,826
Default

Quote:
Originally Posted by jgroffv View Post
Its misfiring just saying didnt think that it was a question when I mentioned spark plugs and coil pack but hay I appreciated the humor
? I'm not being humerous. I'm trying to help you.
Reply With Quote
  #5  
Old 01-06-2014, 05:07 PM
jgroffv jgroffv is offline
Learning to use the forums
 
Join Date: Nov 2013
Posts: 8
Default Re: 4.0 sohc misses only when cold HELP!!!

I have been having this problem for about a week I was sitting at a light and truck just started to misfire on cylinder 2 I have changed spark plugs with motorcraft same with wires also bought a new coil pack I was talking to the local ford garage and told me to change the intake gaskets so I did no change im at a loss and not sure if I am over looking something I have also cleaned off both cam and crank sensors. Oh and I unplugged the battery to change the gaskets now I cant get a cel I would appreciate any advice bd thought yoy were trying to be funny

Sent from my SM-T217S using Tapatalk
__________________
Ohio John 01extcab 4x4 4.0
Reply With Quote
  #6  
Old 01-06-2014, 06:45 PM
bdillard77 bdillard77 is offline
Wish in one hand...
 
Join Date: Jul 2012
Posts: 4,826
Default Re: 4.0 sohc misses only when cold HELP!!!

So you can't get a CEL even though you know cylinder #2 is misfiring? Kinda sounds like what mine used to do except I had two cylinders misfiring on it and never got a CEL light.
Reply With Quote
  #7  
Old 01-07-2014, 05:12 AM
jgroffv jgroffv is offline
Learning to use the forums
 
Join Date: Nov 2013
Posts: 8
Default Re: 4.0 sohc misses only when cold HELP!!!

Im gonna guess its an injector or the pcm, no body has any answers

Sent from my SM-T217S using Tapatalk
__________________
Ohio John 01extcab 4x4 4.0
Reply With Quote
  #8  
Old 01-07-2014, 10:50 AM
cowboybilly9mile cowboybilly9mile is offline
Ford Ranger Driver
 
Join Date: Mar 2010
Posts: 4,900
Default Re: 4.0 sohc misses only when cold HELP!!!

My first reaction was injector issue (means anything that affects operation of it, not jjust the injector itself). Maybe next time it's missing go out there with a stethoscope (a piece of vac hose will do) and place it against the injector to see if it's working/not working. I wouldn't even be thinking PCM at this time.
__________________
2004 Ranger FX4 Level II, 5R55E, Sonic Blue Pearl

Proudly JAP/RICE free since March 2000
Reply With Quote
  #9  
Old 01-07-2014, 03:46 PM
jgroffv jgroffv is offline
Learning to use the forums
 
Join Date: Nov 2013
Posts: 8
Default Re: 4.0 sohc misses only when cold HELP!!!

I couldnt hear the injector fire, I have spark to the plug for sure I checked injector wires and they are good at least my multimeter says so I just have to take the intake back off to put in the new injectors. I hope this is it, it was cold as hell out there today -24 thanks guys I will update as soon as I put them in.

Sent from my SM-T217S using Tapatalk
__________________
Ohio John 01extcab 4x4 4.0
Reply With Quote
  #10  
Old 01-07-2014, 04:27 PM
cowboybilly9mile cowboybilly9mile is offline
Ford Ranger Driver
 
Join Date: Mar 2010
Posts: 4,900
Default Re: 4.0 sohc misses only when cold HELP!!!

Look up the pinpoint diagnostics for the injectors find the rated resistance and compare that against yours.
__________________
2004 Ranger FX4 Level II, 5R55E, Sonic Blue Pearl

Proudly JAP/RICE free since March 2000
Reply With Quote
  #11  
Old 01-14-2014, 02:01 PM
partshauler partshauler is offline
Learning to use the forums
 
Join Date: Jan 2014
Posts: 4
Default Re: 4.0 sohc misses only when cold HELP!!!

I have this exact same problem in my 4.0 Ranger. Bad miss when cold, now it seems to miss all the time. I changed my injectors and had a bit more power but the miss problem seemed to come back all the time now even when warmed up. My truck has 170k on it.

Going through the problems it must be caused by the cylinder not getting fuel or spark. I have switched my plugs and the problem got better once. Switched the coil pack and the problem seemed to get better. As I said the injectors were done and it seemed to get better. Each time I thought it was fixed but the problem creped back. Most likely I am experiencing more than one problem here. I am going nuts here and don't want to throw money at a truck this old without fixing the problem.
Reply With Quote
  #12  
Old 01-17-2014, 05:20 PM
jgroffv jgroffv is offline
Learning to use the forums
 
Join Date: Nov 2013
Posts: 8
Default Re: 4.0 sohc misses only when cold HELP!!!

I found the problem it was an injector. After all new gaskets and wires and plugs and fuel filter and maf cleaner and checking vacuum leaks it was an injector.
__________________
Ohio John 01extcab 4x4 4.0
Reply With Quote
Reply

Tags
misfire

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 Ranger 3.0L Engine misses and hesitates at 4000 rpms when accelerating. brandonovich 3.0 Vulcan Tech 18 06-24-2018 02:32 AM
4L SOHC Ranger and 4L Sohc Mustang differences? Rango88 4.0 SOHC / 4.0 OHV Tech 20 03-03-2014 06:01 PM
misses at low rpm mbear 3.0 Vulcan Tech 0 08-15-2012 07:27 PM
2.3 Misses after i got gas Bryan_leonard 4-Cylinder Tech 7 01-09-2010 10:21 PM
Help, I have a 3.0 that misses! Lance 3.0 Vulcan Tech 0 07-24-2009 08:08 PM