Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > Engine Tech Forum > 6-Cylinder Tech > 4.0 SOHC / 4.0 OHV Tech
Forgot Password? Join Us!


Reply
 
LinkBack Thread Tools Search this Thread

  #16  
Old 11-27-2013, 12:18 PM
Another old fart
 
Join Date: Oct 2013
Posts: 3,628
Default Re: PO1151 O2 sensor code

[QUOTE=modelageek;1838034]1151 indicates an intake manifold leak or a slow o2 sensor.

If I had an intake manifold leak with an auto in gear at a stop would I have an issue with the idle?, because it seems to be idling normally & not stalling.
__________________
2000 Ranger Extd Cab XLT, 4X4 Off Road, 4.0L, Auto, L/S 8.8 - 4.10's, PW, PL, PM, Cruise, Tilt, Bucket Seats, & Shorty Console (My DD)
Mods; Throttle cable, OHC, Bug Shield, Vent Visors, Bed Rails, Mustang dome light, Carpeted Floor Mats, radio trim panel w/dual fog light switches, 4.0L emblems, color matched Ford oval, 06 p.m., lighted visors, Step bars, 76 Cobra II hood scoop, blacked out hood, 01 f/e end swap, air box mod, grille lights, cab visor, tailgate light bar.
69 Mustang (project)
Reply With Quote
  #17  
Old 11-27-2013, 12:24 PM
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 5,527
Default Re: PO1151 O2 sensor code

[quote=Mike69;1838050]
Quote:
Originally Posted by modelageek View Post
1151 indicates an intake manifold leak or a slow o2 sensor.

If I had an intake manifold leak with an auto in gear at a stop would I have an issue with the idle?, because it seems to be idling normally & not stalling.
I would install a new sensor. They are cheap and some think of them as maintenance. Denso or MC
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 137k. (4.0 engine is out of a 2009 Ranger w/87k)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).

1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #18  
Old 11-27-2013, 01:38 PM
Another old fart
 
Join Date: Oct 2013
Posts: 3,628
Default Re: PO1151 O2 sensor code

[quote=modelageek;1838055]
Quote:
Originally Posted by Mike69 View Post

I would install a new sensor. They are cheap and some think of them as maintenance. Denso or MC
Thanks Woody, if the weather this weekend is a little warmer I will replace it, clear the codes & drive it again & see how I make out.
Mike.
__________________
2000 Ranger Extd Cab XLT, 4X4 Off Road, 4.0L, Auto, L/S 8.8 - 4.10's, PW, PL, PM, Cruise, Tilt, Bucket Seats, & Shorty Console (My DD)
Mods; Throttle cable, OHC, Bug Shield, Vent Visors, Bed Rails, Mustang dome light, Carpeted Floor Mats, radio trim panel w/dual fog light switches, 4.0L emblems, color matched Ford oval, 06 p.m., lighted visors, Step bars, 76 Cobra II hood scoop, blacked out hood, 01 f/e end swap, air box mod, grille lights, cab visor, tailgate light bar.
69 Mustang (project)
Reply With Quote
  #19  
Old 11-27-2013, 07:37 PM
Liking the Ford Ranger Forum
 
Join Date: Mar 2013
Posts: 29
Default

I have same issue. Slow response on heated o2 sensor. I replaced all just to be sure, but still getting lean codes. I think it may be a wire issue. So I'm gonna get under there and trace all wiring for o2 sensors hopefully I can find something cause it's bugging the hell out of me
Reply With Quote
  #20  
Old 11-29-2013, 02:34 PM
Another old fart
 
Join Date: Oct 2013
Posts: 3,628
Default Re: PO1151 O2 sensor code

Today I pulled the drivers side wheel & removed the soft rubber splash shield, Sprayed the threads of the O2 sensor with wd-40 & warmed the engine up, sprayed it again a couple times, & then let the engine cool a little so I would not burn my hands. Sprayed the sensor threads again & unplugged the O2 sensor & tried to remove the sensor from up top but could not get any leverage on the wrench to break it free so I jacked up the l/s front & set it on a jack stand & went under the truck & put the box end of the wrench on the sensor & smacked the wrench a couple times with a 5 lb sledge & it broke free & turned a little. Went back up top & using the open end of the wrench loosened it up enough so I caould spin the sensor out by hand. It still had the original sensor which was stamped with the Ford logo, & Bosch. I replaced it with a Bosch O2 sensor. Hooked up the code reader & cleared the code & drove it to get gas, seems ok. I will drive it again a couple more times this weekend. Hopefully the CEL doesnt come back on.
Mike.
__________________
2000 Ranger Extd Cab XLT, 4X4 Off Road, 4.0L, Auto, L/S 8.8 - 4.10's, PW, PL, PM, Cruise, Tilt, Bucket Seats, & Shorty Console (My DD)
Mods; Throttle cable, OHC, Bug Shield, Vent Visors, Bed Rails, Mustang dome light, Carpeted Floor Mats, radio trim panel w/dual fog light switches, 4.0L emblems, color matched Ford oval, 06 p.m., lighted visors, Step bars, 76 Cobra II hood scoop, blacked out hood, 01 f/e end swap, air box mod, grille lights, cab visor, tailgate light bar.
69 Mustang (project)
Reply With Quote
  #21  
Old 12-02-2013, 06:44 PM
Another old fart
 
Join Date: Oct 2013
Posts: 3,628
Default Re: PO1151 O2 sensor code

Update, Drove on Friday after replacing the l/s O2 sensor to get gas, twice on Saturday, & once on Sunday. Drove it to & from work today & so far no CEL. I am going to run it through inspection tomorrow.
__________________
2000 Ranger Extd Cab XLT, 4X4 Off Road, 4.0L, Auto, L/S 8.8 - 4.10's, PW, PL, PM, Cruise, Tilt, Bucket Seats, & Shorty Console (My DD)
Mods; Throttle cable, OHC, Bug Shield, Vent Visors, Bed Rails, Mustang dome light, Carpeted Floor Mats, radio trim panel w/dual fog light switches, 4.0L emblems, color matched Ford oval, 06 p.m., lighted visors, Step bars, 76 Cobra II hood scoop, blacked out hood, 01 f/e end swap, air box mod, grille lights, cab visor, tailgate light bar.
69 Mustang (project)
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 4.0 L o2 sensor code bburgwin01 4*4 4.0 General Tech 9 11-10-2013 03:04 AM
O2 sensor check engine code Kemaro307 4-Cylinder Tech 19 03-05-2013 05:23 AM
Code 214 / CMP Sensor ????? rjexpress 4.0 SOHC / 4.0 OHV Tech 0 08-23-2012 09:36 PM
code 44,passenger crash sensor mounting Anvil02 Electrical Tech 3 05-05-2012 07:21 PM
1151 code (Bank 2 sensor 1) ? Rj 1 4.0 SOHC / 4.0 OHV Tech 2 02-09-2010 02:02 PM



Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.