Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 11-18-2013, 04:55 PM
luttbover luttbover is offline
Learning to use the forums
 
Join Date: Nov 2013
Posts: 4
Default just did an oil change and had gas in the oil. 5 days later - more gas in the oil.

93 ford ranger 4.0. I changed the fuel pressure regulator when i did the oil change the first time. Now 5 days later, its back. what could it be? truck runs fine otherwise, no CEL or anything. i'm stumped. HELP!
Reply With Quote
  #2  
Old 11-18-2013, 05:01 PM
Saves Saves is offline
huh?
 
Join Date: Jan 2012
Posts: 510
Default Re: just did an oil change and had gas in the oil. 5 days later - more gas in the oi

piston rings.
__________________
2011 Sport 2wd || Doestch Spindles || Shackles || Rancho RS5000 || 32" BFG AT KO2 || Method Holes || MBRP SS Catback || Airaid Intake || Hurst Shifter || BiXenon D2S Retrofit || LED Fogs || Detroit Truetrac || LED Conversion || Hella Supertones || Chrome on Black Emblems || Bushwacker Bed Rails || SwingCase Toolbox || In Bed Bike Mounts
Reply With Quote
  #3  
Old 11-18-2013, 05:56 PM
luttbover luttbover is offline
Learning to use the forums
 
Join Date: Nov 2013
Posts: 4
Default Re: just did an oil change and had gas in the oil. 5 days later - more gas in the oi

but if it was rings wouldnt it be running badly?
Reply With Quote
  #4  
Old 11-18-2013, 06:08 PM
MikeyKc MikeyKc is offline
FX4 wanna beee
 
Join Date: Sep 2013
Posts: 204
Default Re: just did an oil change and had gas in the oil. 5 days later - more gas in the oi

It means you are not running a correct air to fuel mixture. In fuel injected systems it usually means your injectors are firing all the time or too long (to much gas, not burning it all off) maybe a sensor like a MAP sensor or MAF sensor.
__________________
01 xlt 4 door 4.0 4x4 auto step side -current project
02 xlt 4 door 4.0 4x4 auto -SOLD
94 xlt 2.3 auto -SOLD
87 2.9 auto 4x4 with plow -SOLD
Reply With Quote
  #5  
Old 11-18-2013, 06:21 PM
DangerRanger2000 DangerRanger2000 is offline
Twist It Back!
 
Join Date: Dec 2010
Posts: 772
Default

Quote:
Originally Posted by luttbover View Post
but if it was rings wouldnt it be running badly?
Yes an it would be smoking and you would have no compression.
__________________
2000 XLT 4x4 EXT. CAB 4.0/Auto Trans/3.73 gears/
31x10.50 BFG Rugged Terrains on MB Motoring Wheels/Pioneer Head Unit/JBL 12"/Camo Interior/'03 black and grey 60/40 seats/ green LED's Under Dash/T-Bar Crank/Windows-20% on the front, 5% on the back/Mustang Dome Light/06 Tails/
Reply With Quote
  #6  
Old 11-18-2013, 07:19 PM
SpitfireJoe SpitfireJoe is offline
2003 Edge 4.0/Auto 4X4
 
Join Date: Jun 2013
Posts: 71
Default Re: just did an oil change and had gas in the oil. 5 days later - more gas in the oi

Best guess is a fuel injection problem. I'd only be guessing if I suggested a fix. I think you're going to have to take it somewhere and let them plug it in, see if a fuel injector (or two, or three) is malfunctioning. The worry is gas could be washing the oil film off a cylinder wall (or two, or three) which could cause scoring or other wear problems and really ruin your engine.

What motor? Mileage? History of other problems related to fuel system? We probably can't help much, but more info would assist.

Keep us posted. Best of luck...
__________________
Joe Guinan - Spitfirejoe - Fremont, NE
2003 Ranger Edge Plus Extended Cab Flareside, 4.0 SOHC, Automatic, 4X4, Oxford White with Charcoal Gray interior. 32,600 miles on purchase date of 6/17/2013.
Reply With Quote
  #7  
Old 11-19-2013, 11:02 AM
luttbover luttbover is offline
Learning to use the forums
 
Join Date: Nov 2013
Posts: 4
Default Re: just did an oil change and had gas in the oil. 5 days later - more gas in the oi

Quote:
Originally Posted by SpitfireJoe View Post
Best guess is a fuel injection problem. I'd only be guessing if I suggested a fix. I think you're going to have to take it somewhere and let them plug it in, see if a fuel injector (or two, or three) is malfunctioning. The worry is gas could be washing the oil film off a cylinder wall (or two, or three) which could cause scoring or other wear problems and really ruin your engine.

What motor? Mileage? History of other problems related to fuel system? We probably can't help much, but more info would assist.

Keep us posted. Best of luck...
so i just pulled all the plugs (all badly fouled by gasoline) and compression tested it. all compression numbers were between 118 and 125. no history of fuel related malfunction. its the 4.0 V6. I'm starting to lean towards injectors, but i'm not sure if one of them or all of them are bad, and they're almost 100 bucks a piece... is there any way to test these without pulling the intake off?
Reply With Quote
  #8  
Old 11-19-2013, 11:07 AM
DangerRanger2000 DangerRanger2000 is offline
Twist It Back!
 
Join Date: Dec 2010
Posts: 772
Default

Quote:
Originally Posted by luttbover View Post

so i just pulled all the plugs (all badly fouled by gasoline) and compression tested it. all compression numbers were between 118 and 125. no history of fuel related malfunction. its the 4.0 V6. I'm starting to lean towards injectors, but i'm not sure if one of them or all of them are bad, and they're almost 100 bucks a piece... is there any way to test these without pulling the intake off?
Yes a shop will hook it up to there computer and can get live
readings on all the injectors.
__________________
2000 XLT 4x4 EXT. CAB 4.0/Auto Trans/3.73 gears/
31x10.50 BFG Rugged Terrains on MB Motoring Wheels/Pioneer Head Unit/JBL 12"/Camo Interior/'03 black and grey 60/40 seats/ green LED's Under Dash/T-Bar Crank/Windows-20% on the front, 5% on the back/Mustang Dome Light/06 Tails/
Reply With Quote
  #9  
Old 11-19-2013, 11:16 AM
cowboybilly9mile cowboybilly9mile is offline
Ford Ranger Driver
 
Join Date: Mar 2010
Posts: 4,900
Default Re: just did an oil change and had gas in the oil. 5 days later - more gas in the oi

Thoughts/questions:

* ALL plugs are carbon fouled?
* No CEL?
* If no CEL, does the CEL work (ie, come on with key on but before starting)?
* You say "truck runs fine" but really, with all this extra gas, are you SURE it's not pumping black out the tailpipe, either at startup or while driving? Is there a sotty black coating inside the tailpipe? Have you looked or had someone look for black smoke?
__________________
2004 Ranger FX4 Level II, 5R55E, Sonic Blue Pearl

Proudly JAP/RICE free since March 2000
Reply With Quote
  #10  
Old 11-19-2013, 11:36 AM
ranger024x4 ranger024x4 is offline
dumpster fire
 
Join Date: Sep 2010
Posts: 5,372
Default Re: just did an oil change and had gas in the oil. 5 days later - more gas in the oi

could be that the injectors are leaky.
__________________

2017 Ford Fiesta ST
2014 Ford Escape Titanium Ecoboost AWD
Reply With Quote
  #11  
Old 11-19-2013, 12:13 PM
cowboybilly9mile cowboybilly9mile is offline
Ford Ranger Driver
 
Join Date: Mar 2010
Posts: 4,900
Default Re: just did an oil change and had gas in the oil. 5 days later - more gas in the oi

^^^ I was thinking that too, but if that were the case he would be having starting problems since the fuel pressure would bled down with the engine off and he'd have to cycle the key a few times. Then again, that just may be the case and he hasn't talked about it (yet). Also and regardless of what happens, the odds of all injectors tanking all at once are pretty slim, more like one or maybe, maybe two. But yes, if even one is bleeding down when the engine is off and if he has several duty cycles per day, he conceiveably could be dumping fuel down into the oil.
__________________
2004 Ranger FX4 Level II, 5R55E, Sonic Blue Pearl

Proudly JAP/RICE free since March 2000
Reply With Quote
  #12  
Old 11-20-2013, 01:48 PM
luttbover luttbover is offline
Learning to use the forums
 
Join Date: Nov 2013
Posts: 4
Default Re: just did an oil change and had gas in the oil. 5 days later - more gas in the oi

just pulled the plenum, and i didnt get any fuel squirting out the fuel lines, so i figure i got a bad injector somewhere. ill probably just end up replacing them all... ill update if it fixes it.
Reply With Quote
  #13  
Old 11-20-2013, 07:04 PM
cowboybilly9mile cowboybilly9mile is offline
Ford Ranger Driver
 
Join Date: Mar 2010
Posts: 4,900
Default Re: just did an oil change and had gas in the oil. 5 days later - more gas in the oi

I want my posts back. All of them.
__________________
2004 Ranger FX4 Level II, 5R55E, Sonic Blue Pearl

Proudly JAP/RICE free since March 2000
Reply With Quote
  #14  
Old 11-20-2013, 07:20 PM
svtwin73 svtwin73 is offline
Ford Tough
 
Join Date: Dec 2010
Posts: 310
Default Re: just did an oil change and had gas in the oil. 5 days later - more gas in the oi

Can't you look in the intake for the wet runner after you pull the plenum?
__________________
1998 Ranger Supercab 4.0L, Medium Metallic XLT, auto, painted valve covers (10 HP), 30x9.5/15.

2008 Mustang GT, stroked 5.0 3v, RGR cams, R2300 S/C, suspension, Kooks LTs w/HF cats GT500 TB, Flowmaster cat-back exhaust, GT500 fuel pump setup.
Reply With Quote
Reply

Tags
ford, gas, oil, ranger

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
diesel oil in a gas engine? spoons896 4-Cylinder Tech 10 02-17-2013 07:05 PM
Strange oil consumption after oil change Big Freak 3.0 Vulcan Tech 6 04-04-2012 08:43 PM
gas in the oil? b.stew 3.0 Vulcan Tech 9 01-07-2012 07:54 AM
synthetic oil saves gas or BS?? 2010 4-Cylinder Tech 21 09-16-2011 08:35 PM
93 ranger 4.0 has gas in the oil nccatdoc 4.0 SOHC / 4.0 OHV Tech 11 05-20-2010 07:35 PM