Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 06-15-2013, 12:11 PM
99 Sport 99 Sport is offline
Learning to use the forums
 
Join Date: Oct 2010
Posts: 6
Default code po500 problem

I have a 99 sport, 4wd, automatic, with 3.0 motor...My abs lite came on and the trans wont upshift...the cel lite came on and i pulled a code of po500...it indicated something wrong with the VSS...I changed the sensor on the differential (does not have one on the trans)....problem still exists...any one know what to check next?
.99 sport
. 3.0 motor
. automatic
.4 wd
. 66 k miles
. no fuses blown

also the o/d off indicator lite on the dash is blinking...
thanks for any advice you can give me....jim...
Reply With Quote
  #2  
Old 06-15-2013, 02:12 PM
Rangerman49 Rangerman49 is offline
If it works,don't fix it!
 
Join Date: Dec 2011
Posts: 966
Default Re: code po500 problem

Quote:
Originally Posted by 99 Sport View Post
I have a 99 sport, 4wd, automatic, with 3.0 motor...My abs lite came on and the trans wont upshift...the cel lite came on and i pulled a code of po500...it indicated something wrong with the VSS...I changed the sensor on the differential (does not have one on the trans)....problem still exists...any one know what to check next?
.99 sport
. 3.0 motor
. automatic
.4 wd
. 66 k miles
. no fuses blown

also the o/d off indicator lite on the dash is blinking...
thanks for any advice you can give me....jim...
If I'm not mistaken, on a four wheel drive there's a VSS on the transfer case near the rear shaft side. The other sensor on the rearend is just for ABS...
__________________
2011 Ranger XLT 2x4,4.0 SOHC, 5 Speed Auto, 3.55 Rear. Oxford White.

Simplicity is the ultimate sophistication.

Torque it down till it breaks off, then back it off 1/4 turn.
Reply With Quote
  #3  
Old 06-15-2013, 10:01 PM
rangerlocal rangerlocal is offline
Ermahgerd Ferd Rernjurs!
 
Join Date: Aug 2012
Posts: 1,939
Default Re: code po500 problem

Yep, change the sensor. If that doesn't fix it, inspect the wires for fraying. Some people have reported broken or frayed shorted wires on the frame of the truck back there.
__________________
2000 Ranger XL, 2WD, 3.0l, 3.73 rear, 10" rear drum ABS, standard cab, long bed, A/C, 4r44e auto trans w/transgo shift kit, throttle cable mod, air box silencer mod, rear sway bar retrofit, white grill swap, CURT hitch, Westin step bars
Quote:
Originally Posted by writtenaudio View Post
Man wish i had tits, seems like its easier to get a job if you have tits.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
EGR Problem - code P0403 and P0406 ghsteo General Tech 2 03-18-2012 05:52 AM
2001 EGR code problem 2001fordranger Introduce Yourself 4 03-12-2012 01:21 PM
99 ranger code problem lmilhorn 4-Cylinder Tech 2 09-04-2011 06:58 PM
Code P0456 problem BWCRanger13 4.0 SOHC / 4.0 OHV Tech 2 03-17-2011 05:36 AM
4r44e problem shifting + tranny code lifted96 Drivetrain Tech 3 02-22-2011 12:04 PM