Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 03-26-2013, 08:35 PM
ethan1991 ethan1991 is offline
Learning to use the forums
 
Join Date: Mar 2013
Posts: 2
Default Heating issue

I have a 2000 ranger 3.0 V6 4X2 flex- fuel and I'm having an issue with heating/ cooling. Truck runs fine, never misses, always starts, air/ heat work. What the temp gauge does is set normal, randomly goes to cold, immediately jumps to hot (almost red line), then cools down to about normal. I've put 3 thermostats in and still does the same thing. It can't be the radiator bc it would gradually increase in temp and not come down for a while. It can't be water pump bc it wouldn't cool back down and that water pump only has 30k on it.

Last thing I can even think of is a cracked head. Any suggestions or comments are appreciated. Thanks.
Reply With Quote
  #2  
Old 03-26-2013, 08:45 PM
davethepear davethepear is offline
yes, I am a pear!
 
Join Date: Dec 2010
Posts: 15
Default Re: Heating issue

temp sensor?

Sent from my Nexus 7 using Tapatalk HD
__________________
2011 Ranger Sport, 4.0L, 5 speed auto...
Reply With Quote
  #3  
Old 03-26-2013, 08:55 PM
96_4x4_XLT 96_4x4_XLT is offline
Ford Ranger Driver
 
Join Date: Mar 2013
Posts: 6,189
Default Re: Heating issue

proly a sensor
__________________
95 Ranger XLT 4x2 2.3 I4 5 speed 206,000 *dead*
96 Ranger XLT 4x4 4.0 V6 5 speed 173,000 *alive*
D35 front, 8.8 rear, 3.73 gears, limited slip rear diff
Reply With Quote
  #4  
Old 03-27-2013, 04:41 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,268
Default Re: Heating issue

I agree probably the temp sensor. If the gauge is jumping all over it obviously cannot be the actual coolant changing temperature.

SFDROIDBIONICUT2

----------

You need a scanner. my $20 torque pro reads the ECT sensor.

SFDROIDBIONICUT2
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Heating problem Jgar12 General Tech 2 02-12-2013 10:46 AM
Over-Heating issue Slair 3.0 Vulcan Tech 1 07-03-2012 07:17 PM
Another over heating 2.3 Guest 4-Cylinder Tech 14 05-18-2011 10:32 PM
over heating shotgun5000 Drivetrain Tech 1 04-01-2011 06:14 AM
more heating problems jwar Interior Tech 14 09-10-2010 07:33 AM