Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 02-22-2010, 09:54 PM
XJ88 XJ88 is offline
Liking the Ford Ranger Forum
 
Join Date: Feb 2010
Posts: 27
Default Runs like new

In the last two weeks i have done some much needed maintenance and I am amazed by the difference it has made.
I changed:
Spark plugs
Plug wires
Ignition coil
Fuel pump
Fuel filter
Cleaned air filter
Thermostat
Flushed and refilled the cooling system.
New Belt
New idler pulley
and have done the ceramic break pads and other little things

This is the best it has ran since i have bought it.
In doing this, I also got my rough idle figured out and solved, along with my overheating problem as well.

Just thought I would give an update as to how this truck is doing.
__________________
02 3.0 V6 XLT
K&N
Flowmaster
Dark ass tint
Reply With Quote
  #2  
Old 02-22-2010, 10:11 PM
camodown camodown is offline
I'm kind of a big deal
 
Join Date: Nov 2009
Posts: 4,842
Default

mine is due for some new plugs and wires, hell overall tune up really
__________________
Lifted and junk

Double Lifted Rangers
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Truck runs, but cant switch to any gear Shotgun Drivetrain Tech 1 12-16-2009 04:44 PM
My 2.3 runs like a subaru? brett1989 4-Cylinder Tech 8 10-06-2009 09:35 AM
Runs for about 30 mins and cuts off Nameless891 2.9 Liter Tech 13 10-01-2009 06:45 PM
2.5 runs BAD turbo54 4-Cylinder Tech 2 09-22-2009 03:08 PM
Runs but dies tj88 3.0 Vulcan Tech 2 08-03-2009 06:42 PM