Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 02-19-2010, 05:03 PM
RangerSteve RangerSteve is offline
2000 XLT 3.0 2WD 81,000M
 
Join Date: Feb 2010
Posts: 62
Default DPFE Replacement....

So after replacing the DPFE sensor, the check engine light stays off for about 20 miles and then comes back on anyone else had this happen? Should I just get it checked again?
Reply With Quote
  #2  
Old 02-21-2010, 04:21 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

yes you should scan it again. Post the codes when you get them.
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #3  
Old 02-21-2010, 06:58 AM
jp13 jp13 is offline
Learning to use the forums
 
Join Date: Feb 2010
Posts: 8
Default

I was getting the p0401 code. Changed it and every year it happens again. My light stays out for that time.
Reply With Quote
  #4  
Old 02-21-2010, 08:38 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

Quote:
Originally Posted by jp13 View Post
I was getting the p0401 code. Changed it and every year it happens again. My light stays out for that time.
I am sorry but I dont understand this
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #5  
Old 02-21-2010, 09:19 AM
RangerSteve RangerSteve is offline
2000 XLT 3.0 2WD 81,000M
 
Join Date: Feb 2010
Posts: 62
Default

Well, thats my problem. I dont have a scanner but really want to get one. I was looking over them but didnt really understand which one I would need. I would prefer to have some type software with a cable for my laptop. W e don't have any auto zones here and i would rather just have one myself if its not too expensive. Thanks.
Reply With Quote
  #6  
Old 02-21-2010, 09:20 AM
RangerSteve RangerSteve is offline
2000 XLT 3.0 2WD 81,000M
 
Join Date: Feb 2010
Posts: 62
Default

My bad, so my point is, if you know what i would need it would awesome. Thanks.
Reply With Quote
  #7  
Old 02-21-2010, 09:25 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

if you want just a code reader. I got mine at costco for $29 they might be $35 now. I think you can get a good scanner for $200. I have heard the equus 3160 was good http://www.google.com/products/catal...515&sa=title#p
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #8  
Old 02-21-2010, 09:39 AM
RangerSteve RangerSteve is offline
2000 XLT 3.0 2WD 81,000M
 
Join Date: Feb 2010
Posts: 62
Default

Are you happy with yours? I if I can get something for just $30 bucks I may do that. Does it do what you need it to do? Whats the model?
Reply With Quote
  #9  
Old 02-21-2010, 10:09 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

I am a big fan of Costcos. for the most part whaever they sell is good. the brand is codekey. it works fine very simple.
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #10  
Old 02-21-2010, 03:45 PM
bagdranger bagdranger is offline
Ford Pickup
 
Join Date: Dec 2009
Posts: 101
Default

Try pulling off the EGR valve and get some good carb cleaner and clean it out really well. That would be another good reason for that code to come on. Other than its about the only other thing that will make that code set.
Reply With Quote
  #11  
Old 02-21-2010, 08:40 PM
RangerSteve RangerSteve is offline
2000 XLT 3.0 2WD 81,000M
 
Join Date: Feb 2010
Posts: 62
Default

Time it? What do you mean?
Reply With Quote
  #12  
Old 02-22-2010, 04:06 AM
jp13 jp13 is offline
Learning to use the forums
 
Join Date: Feb 2010
Posts: 8
Default

If there is an advanced auto near you, they will let you use their meter for free.
Reply With Quote
  #13  
Old 02-22-2010, 05:12 AM
RangerSteve RangerSteve is offline
2000 XLT 3.0 2WD 81,000M
 
Join Date: Feb 2010
Posts: 62
Default

I still have no idea what youre talking about...like time it as in ignition timing? What would a DPF EGR sensor have to do with timing?
Reply With Quote
  #14  
Old 02-22-2010, 05:52 AM
RAT Ranger RAT Ranger is offline
Ford Ranger Driver
 
Join Date: May 2009
Posts: 1,397
Question ?????

Did you replace the 2 little hoses that go to it, they are like a foot long, and some where around $3/ft.

Also when you did this, did you disconnect your battery while you did it, and let it sit disconnected for 10 mins. or so? This will clear any codes that are in the puter, so when you hook it back up and start it the puter will run a scan to see if it gets any codes.
__________________
ALL THROTTLE, NO BOTTLE!!!

Daily Driver: 98 Thunderbolt

TOY: Green 94 Pro Street
Reply With Quote
  #15  
Old 02-22-2010, 06:22 AM
RangerSteve RangerSteve is offline
2000 XLT 3.0 2WD 81,000M
 
Join Date: Feb 2010
Posts: 62
Default

I did disconnect the battery but only for about 2-3min. The first time I did it itstayed off for about 20 miles. The second time it was less than ten. I'm leaving it be for now until i get my code reader. I did not replace those hoses, could they be causing any problems?
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starter replacement!!! swat784 General Ford Ranger Discussion 2 11-15-2009 02:04 PM
Thermostat Replacement greyghost How-To Submissions 1 10-13-2009 09:22 PM
'93 Antenna Replacement? newbie Interior Tech 2 10-12-2009 12:03 PM
Replacement Parts vinster888 General Ford Ranger Discussion 1 09-22-2009 06:50 PM
engine Replacement 98son 3.0 Vulcan Tech 1 07-21-2009 03:55 AM