Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 02-11-2010, 10:22 PM
XJ88 XJ88 is offline
Liking the Ford Ranger Forum
 
Join Date: Feb 2010
Posts: 27
Default 2002 3.0 V6 problems

As some of you already know my truck has an unusual problem with heating up during the first few minutes of driving with a cold motor. an increase in RPM's usually makes the temperature guage drop down to the middle of the gauge and it runs at a perfect temp from there on. today my truck was heating up as i pulled into the driveway so i turned it off and opened my hood. it sounded like there was air in my coolant line so i am going to flush my cooling system hopefully this weekend and see if that can get the air out of my system. possibly change the thermosthat while im at it

The other problem i am having is that after a decent drive at a consant high speed, like around 55 or 65, upon coming to a stop at say a red light, my oil pressure gauge drops from the midpoint to the bottom and bounces back up. it does this until the light turns green or i give it gas to inch forward.

ANY ideas?? thanks
Reply With Quote
  #2  
Old 02-12-2010, 02:59 AM
dos0711 dos0711 is offline
Flareside Ranger Driver
 
Join Date: Feb 2010
Posts: 196
Default

Wish I could help you...sorry.
__________________
2001 Ranger XLT SuperCab 4dr Flareside 3.0 V6
Reply With Quote
  #3  
Old 02-24-2010, 10:24 AM
rangerwheelinmike rangerwheelinmike is offline
5.0 ranger!!
 
Join Date: Jan 2010
Posts: 307
Default

Quote:
Originally Posted by XJ88 View Post
As some of you already know my truck has an unusual problem with heating up during the first few minutes of driving with a cold motor. an increase in RPM's usually makes the temperature guage drop down to the middle of the gauge and it runs at a perfect temp from there on. today my truck was heating up as i pulled into the driveway so i turned it off and opened my hood. it sounded like there was air in my coolant line so i am going to flush my cooling system hopefully this weekend and see if that can get the air out of my system. possibly change the thermosthat while im at it

The other problem i am having is that after a decent drive at a consant high speed, like around 55 or 65, upon coming to a stop at say a red light, my oil pressure gauge drops from the midpoint to the bottom and bounces back up. it does this until the light turns green or i give it gas to inch forward.

ANY ideas?? thanks
mine does the same thing its a short in the wireing when u hit the brake and the brake lights come on it shorts out my needle even spun all the way arond and now its under the little peg under the low
__________________
2000 ford ranger 5.0/4r70w/np208 gt40p heads, mustang T/B and injectors, true dual flowmaster 10s no cats, 4r70w auto with trans go aod hd 2 shift kit and full manual valve body. 4x4,locked 9in rear,locked coil dana 44 front with 4.10s , 8in lift springs, 3in bl. on 34/10.5s,or 38-15-15s 8000k hids, 7in flip out dvd player, 2 kicker 12s and 2400watt amp

www.f150nation.com
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
2002 Ford Ranger 2WD, abs brake problems? Randy K General Ford Ranger Discussion 7 05-29-2011 01:13 PM
2002 xlt 2wd lift ??? PDFD147 Lifted Suspension 2 01-19-2010 06:19 PM
2002 Red B2300 regular cab/bed TwistedDreams Vehicle Snapshots 6 09-21-2009 07:58 PM
2002 chirping noise clmoe5 3.0 Vulcan Tech 2 06-17-2009 04:07 AM
2002 ranger 4wd? jgerrington Suspension Tech 1 05-05-2009 03:42 PM