Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 02-03-2010, 09:48 PM
spshane spshane is offline
Learning to use the forums
 
Join Date: Feb 2010
Posts: 3
Exclamation 91 3.0 v-6 starting issue

i just bought a 1991 ranger. its a 3 liter v-6 manual trans and i knew it had a problem when i bought it...couldn't pass for $650.

The problem is it wont start without a little brake cleaner or fuel in the intake but once you get it started and warmed up it will start fine for about an hour or two. then when its running it is extremely slow and bogs way down if you step on it. the fuel pump on the frame is new but i dont know about the one in the tank. it gets up to about 55 mph but takes about ten minutes to get there and if you give it just a little too much gas your going back to the start. i checked the fuel pressure and it is at 40 on crank and 32 on idle like it should be.

Any thoughts???
Reply With Quote
  #2  
Old 02-04-2010, 09:33 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

how are the plugs and wires. you should clean the throttle body, doe sit have good gas in it, run some fuel injecter cleaner. how is the air filter? i think you have an air bypass valve you should check and clean that. I have a question what year did they switch over to a single fuel pump in the tank?
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #3  
Old 02-04-2010, 10:11 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

how are the plugs and wires. you should clean the throttle body, doe sit have good gas in it, run some fuel injecter cleaner. how is the air filter? i think you have an air bypass valve you should check and clean that. I have a question what year did they switch over to a single fuel pump in the tank?
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #4  
Old 02-04-2010, 11:09 PM
spshane spshane is offline
Learning to use the forums
 
Join Date: Feb 2010
Posts: 3
Default

well i just replaced the plugs and wires today...also cleaned that valve thats on top of the intake and it runs better but still bogs when i floor it. it had been sitting when i bought it but i drained the gas and filled it up with chevron premium and a bottle of STP injector cleaner. i also put a new air filter in it the other day along with coolant temp sensor. but even with all this it still will not start without some brake cleaner. its also running very rich and im not sure why.

as for the fuel pumps i have no clue lol
Reply With Quote
  #5  
Old 02-04-2010, 11:47 PM
spshane spshane is offline
Learning to use the forums
 
Join Date: Feb 2010
Posts: 3
Default

another problem im having is the modis wont pull the codes??? check engine light is on but it wont find the code
Reply With Quote
  #6  
Old 02-05-2010, 03:48 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

I knw you checked the fuel pressure but I think it would be worth checkinga little further. a few thoughts. there should be a fuel pressure regulater on the fuel rail( i think) pull the vacuum line of of it and make sure there is vacuum and that there is no gas in the vacuum line. next time you start it when it is warm cycle( turn the key to the on position for a few seconds then back to off) the key on and off a few times then try and start. you should do the the fuel pressure test when the truck is warmed up.
you should check you air by pass valve (sometimes called air idle control vavle) pull it off and clean it if you can.
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
Reply

Tags
3.0, problem, ranger, starting, v-6

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Men, I need help, can't keep her starting raygun Electrical Tech 2 01-08-2010 12:59 AM
Problem starting up lil_ludadtp123 General Ford Ranger Discussion 3 11-30-2009 02:09 PM
starting problem lassemista Electrical Tech 1 10-28-2009 11:58 AM
Starting has become a problem Recon Ranger Electrical Tech 1 09-24-2009 05:47 PM
starting problems 1986 ford ranger 2.9 Liter Tech 1 06-27-2009 10:19 PM