Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 04-02-2009, 06:12 PM
bwana bwana is offline
Learning to use the forums
 
Join Date: Mar 2009
Posts: 6
Default cps blues

'99 ranger 3.0: r/r cps syncronizer using alignment tool. chilton says to set crankshaft at 10 degrees AFTER tdc. truck fired right up smoothas can be,but ck. engine light came back after the 10 mile learning trip. code 340 cps bank 1 circuit fault and 401 egr flow insufficient.also got ho2s fault but it has since cleared. is one causing the other one ? or, did chiltons bite me? (i see everyone else in the forum community specs just tdc before dropping the syncro in.) help please!!!
Reply With Quote
  #2  
Old 04-02-2009, 06:26 PM
98blownranger 98blownranger is offline
Custom KeyChain R Me
 
Join Date: Feb 2009
Posts: 718
Default

you can install the cps only one way with the tool. did you have the cam out or just replace the sensor. if just replacing the tool will aline it, if you still have problems it may be somthing else or you never have a cps problem
__________________
Quote:
Originally Posted by redrumedge View Post
98blown you should be an MD! that's the same stuff my doc asks and ur spot on man!!!
98 4.0 2wd-----supercharger fully build heads cam...all show with go......3 time world of wheels champ 5 time national winner


lots of ranger parts for sale leftovers from my 94/96
96 sitting on the frame, waiting to go lower


custom billet parts by me intake adapters and billet steps for the step sides

please sign my guestbook!!
http://breyperformancemachine.shutterfly.com/
Reply With Quote
  #3  
Old 04-02-2009, 08:52 PM
bwana bwana is offline
Learning to use the forums
 
Join Date: Mar 2009
Posts: 6
Default got a bad feelin'

this event occured after a valve job performed by a couple of buddies of mine. i've driven it for quite a while with light on.finally had time from work to address it myself. do you think they put it back together "out of time"? would'nt it run very poorly if so? it only idles a tiny bit rough with a very slight sourge at mid band range and hiway speed and still got pretty decent mpg
Reply With Quote
  #4  
Old 04-03-2009, 02:38 PM
98blownranger 98blownranger is offline
Custom KeyChain R Me
 
Join Date: Feb 2009
Posts: 718
Default

how did you do a valve job. and why the valves are ussaly good unless you drop somthing in the motor. the rocker arms are what wear. do you have the o2 SENSORS wired wrong, the left to the right and the right to the left
__________________
Quote:
Originally Posted by redrumedge View Post
98blown you should be an MD! that's the same stuff my doc asks and ur spot on man!!!
98 4.0 2wd-----supercharger fully build heads cam...all show with go......3 time world of wheels champ 5 time national winner


lots of ranger parts for sale leftovers from my 94/96
96 sitting on the frame, waiting to go lower


custom billet parts by me intake adapters and billet steps for the step sides

please sign my guestbook!!
http://breyperformancemachine.shutterfly.com/
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search