Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > Engine Tech Forum > 6-Cylinder Tech > 3.0 Vulcan Tech
Forgot Password? Join Us!


Reply
 
LinkBack Thread Tools Search this Thread

  #1  
Old 02-08-2012, 06:43 AM
Learning to use the forums
 
Join Date: Feb 2012
Posts: 13
Default mass air flow sensor problems

Alright I got a 1991 Ford ranger 3.0 I been haven a problem tryin to get it to run right I'm pretty sure its the m.a.f.s but I'm not sure......it'll run ok with it un plugged but u can only do about 45 sometimes 55 if Ur lucky but if u plug it in itll kill the truck u can keep it running by playing with the throttle with it plugged in but that's bout it. If anybody has an suggestions or tips id be thankful.
Reply With Quote
  #2  
Old 02-08-2012, 06:53 AM
Like the Forums
 
Join Date: Feb 2012
Posts: 46
Default

You could try cleaning it but I'd just buy a new one then you don't have to worry about it
__________________
2002 3.0 v6 2wd White with blue stripe
New tranny, heads, valves, wire harness, instrument cluster, CPS + sensor, free!brake pads, alternators, and starters for life! New MAF, radiator, hoses, coil pack and too much to list everything

Drive it hard, break it, and when you get to fix it you can trust it better.
Reply With Quote
  #3  
Old 02-08-2012, 06:57 AM
Learning to use the forums
 
Join Date: Feb 2012
Posts: 13
Default

I've already bought a new one did the same thang.......I hauled it to my dads shop but didn't get a chance to put a scanner on it to see what it said
Reply With Quote
  #4  
Old 02-08-2012, 11:26 AM
Certified Car Nut
 
Join Date: Feb 2010
Posts: 197
Send a message via Yahoo to 06ranger
Default

Quote:
Originally Posted by rmkuy199
I've already bought a new one did the same thang.......I hauled it to my dads shop but didn't get a chance to put a scanner on it to see what it said
I agree w the above buy a new one, but since u have already done so, check the connection, and if thats good sounds like your iac may be dirty or bad
__________________
Niche 17x8 rims, turn signal mod, painted side mirror ohc, full length explorer console, eatc, auto dim mirror, kicker components, sido exhaust, painted headlight, nightshaded tails,
Can you do the three pedal two step? I know iim can...
Reply With Quote
  #5  
Old 02-08-2012, 11:58 AM
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,680
Send a message via AIM to FireRanger
Default Re: mass air flow sensor problems

Did you by chance disconnect the battery for about 10 minutes when you put the new one in? It is unusual for the problem to be THAT bad. But I would try that before you dig deeper. It's free and takes 10 minutes. All the other solutions and troubleshooting cost significantly more.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #6  
Old 02-08-2012, 03:27 PM
Learning to use the forums
 
Join Date: Feb 2012
Posts: 13
Default

Ya i did that when I got the new one......I've checked the plug from what I can see it looks fine an nothings loose......i didnt think bout the iac ill make sure i check it too

Last edited by rmkuy199; 02-08-2012 at 03:32 PM.
Reply With Quote
  #7  
Old 02-11-2012, 10:08 PM
Like the Forums
 
Join Date: Feb 2012
Posts: 46
Default

Has to be throwing some kind of code. I'd go get it checked or sears sells a pocket reader for about $40 or $50 small and cheap now I can just google the codes
__________________
2002 3.0 v6 2wd White with blue stripe
New tranny, heads, valves, wire harness, instrument cluster, CPS + sensor, free!brake pads, alternators, and starters for life! New MAF, radiator, hoses, coil pack and too much to list everything

Drive it hard, break it, and when you get to fix it you can trust it better.
Reply With Quote
  #8  
Old 02-12-2012, 10:13 PM
Learning to use the forums
 
Join Date: Feb 2012
Posts: 13
Default Re: mass air flow sensor problems

went to my dads shop this weekin an put the scanner on it didnt give any codes my dads ganna fuck with it this week so i guess ill see if he figures out what it is
Reply With Quote
  #9  
Old 07-12-2012, 11:08 AM
94 Splash
 
Join Date: Jul 2012
Posts: 5
Default Re: mass air flow sensor problems

Ever figure out the problem? My '94 4.0 is throwing a MAF code even after i replaced it.
__________________
'94 Ranger Splash 4.0 standard cab rwd
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
How To: Clean MAF (Mass Air Flow Sensor) STL Engine/Drivetrain Guides 64 07-17-2014 06:13 AM
Mass Air Flow sensor pig tail 97rangernj 4-Cylinder Tech 3 10-15-2011 06:33 AM
Mass Air Flow Sensor wangbungal General Tech 0 03-04-2011 10:06 AM
How To: Clean MAF (Mass Air Flow Sensor) STL Engine/Drivetrain Guides 0 07-26-2010 05:05 PM
Mass air flow sensor? FordMan8109 4-Cylinder Tech 3 04-02-2010 04:33 AM



Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.