Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > Engine Tech Forum > 6-Cylinder Tech > 3.0 Vulcan Tech
Forgot Password? Join Us!


Reply
 
LinkBack Thread Tools Search this Thread

  #1  
Old 01-23-2012, 11:50 PM
Liking the Ford Ranger Forum
 
Join Date: Jan 2012
Posts: 15
Angry New coil wires plugs, still missing?

This truck is gonna break me soon I think. I've just recently changed my plugs, wires, and ignition coil. But when I put the timing light on it just see when it fires, it will fire consistantly on 3 of 6 plugs. Then the other 3 will fire consistantly but then skip out then fire more then skip out. It's causing the truck to jerk trying to keep it at 40 in 4th gear. Misses while it idles now and misses while accerating. Huge gas consumption right now. What else could it be? the timing light is proving the firing isn't right that it couldn't be a pump or injectors.
Attached Images
File Type: jpg Truck.jpg (83.0 KB, 10 views)
__________________
##Current Vehicle##
99 Ranger XLT Regular Cab, 3.0L V-6 FLEX, STOCK, 5-Speed, 2nd Owner (137,000 Miles)
---Also owned 97 Mercury Sable, 3.0L V-6, STOCK, Automatic (totaled at 267,000 miles. R.I.P) &
82' F-100 Regular Cab, 302 small block V-8, Automatic
(milage unknown)
Reply With Quote
  #2  
Old 01-23-2012, 11:55 PM
Welcome to FRF, & enjoy!

 
Join Date: Oct 2009
Posts: 4,908
Default Re: New coil wires plugs, still missing?

something is wrong with one of the things you replaced. or the ignition module in the computer is messed up. get it hooked up to IDS and have them power balance the motor
__________________
2000 Ford Ranger XLT 4x4 Offroad, 4.0L ext cab, Converted to Manual M5OD-R1HD.
_____________
33x13.50 Toyo M/T, 15x10, Body Lift, Rebuilt OHV, JBA headers, Hurst shifter, Warn VR10000-s, Class 1 bars, Belltech Shackles, Mustang GT rear disc, Level II hooks, Modded rear hitch, Custom front hitch, Level II Blue seats and black console, Explorer IRS rear cover, Extang fulltilt, Leer Cap Yakima Roof Rack, Cobra 29 with firestik stake mount, Scangauge II
Few mods
Reply With Quote
  #3  
Old 01-24-2012, 12:31 AM
Liking the Ford Ranger Forum
 
Join Date: Jan 2012
Posts: 15
Default Re: New coil wires plugs, still missing?

Alright the shop down the road said they would charge 45 buck tax included to just hook it up to some machine. they failed to mention what it was. said it was just for testing the coil on these trucks. Could it be possibly anything else? Like the time being thrown out or something before I go have this done to it?
__________________
##Current Vehicle##
99 Ranger XLT Regular Cab, 3.0L V-6 FLEX, STOCK, 5-Speed, 2nd Owner (137,000 Miles)
---Also owned 97 Mercury Sable, 3.0L V-6, STOCK, Automatic (totaled at 267,000 miles. R.I.P) &
82' F-100 Regular Cab, 302 small block V-8, Automatic
(milage unknown)
Reply With Quote
  #4  
Old 01-24-2012, 05:53 PM
Twist It Back!
 
Join Date: Dec 2010
Posts: 747
Default Re: New coil wires plugs, still missing?

More than likely something wrong with one or more of the things you replaced, could have cracked one of the plugs when putting it in, coil pack could be bad etc... are the plug wires in the right place?
__________________
2000 XLT 4x4 EXT. CAB 4.0/Auto Trans/3.73 gears/
31x10.50 BFG Rugged Terrains on MB Motoring Wheels/Pioneer Head Unit/JBL 12"/Camo Interior/'03 black and grey 60/40 seats/ green LED's Under Dash/T-Bar Crank/Windows-20% on the front, 5% on the back/Mustang Dome Light/06 Tails/
Reply With Quote
  #5  
Old 07-07-2013, 05:28 AM
Liking the Ford Ranger Forum
 
Join Date: Jan 2012
Posts: 15
Default

Long time wow. It turned out to be a horrible Egr sensor. It was rusting out
__________________
##Current Vehicle##
99 Ranger XLT Regular Cab, 3.0L V-6 FLEX, STOCK, 5-Speed, 2nd Owner (137,000 Miles)
---Also owned 97 Mercury Sable, 3.0L V-6, STOCK, Automatic (totaled at 267,000 miles. R.I.P) &
82' F-100 Regular Cab, 302 small block V-8, Automatic
(milage unknown)
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Replace Spark Plugs, Wires and Ignition Coil cpcamp08 3.0 Vulcan Tech 14 01-01-2014 06:25 PM
Engine missing every 2-3 weeks after new plugs. fmallardjr 3.0 Vulcan Tech 2 08-23-2011 07:04 PM
What plugs and wires do you recommend? zipsayain 4-Cylinder Tech 4 04-16-2011 08:34 PM
Just changed my plugs/wires. aaron_ariens 3.0 Vulcan Tech 16 12-28-2010 01:45 PM
my 92 ford ranger 4.0l doesn't have spark, I have new coil pack, plugs and wires? Ruben H 4.0 SOHC / 4.0 OHV Tech 2 07-23-2009 12:16 AM



Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.