Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 11-20-2009, 10:48 AM
sk8tened sk8tened is offline
Learning to use the forums
 
Join Date: Nov 2009
Posts: 2
Default 2000 3.0 flexfuel problems

Hello everyone i am new to this forum my name is edsson. Here's my problem hopefully you guys can help me out. My motor died on me at 150k so i did a complete rebuild and overhaul of the motor which cost about $2000. Unfortunately it almost seems worse than before i took it in and yes i will be taking it back to the shop since i do have 36k mile waranty. HOwever, these are the issues. When i accelarate above normal RPM i can hear from what i think is the valves, it sounds like a bad rattle of metal on top the left side and some on the right. Also when i shift (manual) in between shifts my motor revs up even if im not pressing on the gas, not always but occasionally. Also im having to keep putting oil in the engine but there are no leaks of any kind anywhere and there is never any smoke coming out of the tail pipe. Oh and im getting only about 17 mpg highway and street combined and when i took it in i was getting atleast 20 and i was getting about 23 when i bought it. In other words, its worse now. I use castrol GTX 20/50 as recommended by the shop which rebuilt the engine. and and im going on 6000 miles since the rebuild, should be well passed the breaking in point right? i would really appreciate some feedback from you guys and also to know if this motor is good or not, and if these are common problems.
Reply With Quote
  #2  
Old 11-23-2009, 12:06 AM
sk8tened sk8tened is offline
Learning to use the forums
 
Join Date: Nov 2009
Posts: 2
Default

alright thanks guys =/
Reply With Quote
  #3  
Old 11-23-2009, 12:34 AM
Fx4wannabe01 Fx4wannabe01 is offline
Ford Ranger Driver
 
Join Date: Sep 2009
Posts: 4,058
Default

Just type "bump" or "ttt". Don't be a dick and post what you did post. Something else that would help is breaking up your post a little bit. That's alot of words shoved together. Each issue can have it's own paragraph/bullet line to make it alot easier to read(as seen in my reply below).




Problem 1: 'chatter'. I would say it's either valves or rockers or even it's just fuel injectors. I can hear my individually 'tick' when they inject the fuel. That's totally normal.

Problem 2: 'raising RPM w/ no throttle push'. IAC valve. It controls the idle and what actually keeps the rpms up on warm up. When they stick, it causes the engine rpm to stay at the same spot where you pushed in the clutch. Change it.

Problem 3: 'oil burning'. What exactly did you spend $2000 on??? If there's oil being burned, there wasn't a re-ring job when the pistons were put back in, and/or the cylinders wern't checked for roundness/squareness/bored. So...what exactly was done to the engine when it was 'rebuilt'?

Problem 4: '17mpg when it used to get 20'. Simple: Engine break-in. Engines take time to fully seat and make good numbers.


You're past the initial break-in period and shouln't be running such a thick oil in it. 10w30 or 5w30 is what you should be running. Right now you're running diesel oil. Also, when one issue is cured, it could bring out more issues you didn't know you had. Like the IAC sensor or other sensors on the engine. Are you throwing any codes? Was there headwork done when they did the engine(whatever they actually did)?? Deck the block, check heads for square? Went through and checked all the valves and replaced the guides? etc. What exactly was done to the engine?
__________________
'01 XLT disguised as a '03 Fx4 Level II.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help me 4x4 problems ronald44 Drivetrain Tech 0 11-16-2009 06:52 PM
AC Problems ianbordas General Tech 3 09-24-2009 09:49 PM
New 1999 3.0 V6 FF with problems 6Tetons6 3.0 Vulcan Tech 2 09-22-2009 08:52 AM
91 3.0L idle problems dogboy 3.0 Vulcan Tech 0 06-02-2009 11:45 AM
2000 ford ranger? serious problems? ufc fighter x6 General Ford Ranger Discussion 2 11-26-2008 11:56 PM