Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > Engine Tech Forum > 6-Cylinder Tech > 3.0 Vulcan Tech
Forgot Password? Join Us!


Reply
 
LinkBack Thread Tools Search this Thread

  #1  
Old 08-25-2011, 07:41 AM
Liking the Ford Ranger Forum
 
Join Date: Jul 2011
Posts: 19
Default Hard Starting when the engine is cold...

Hi! everybody... Just bought a 1998 ford ranger splash 3.0 v6. The problem is that when is cold in the mornings is hard to start, It start but idle bad for a few seconds and then idle perfect and run good. Replace already sparks, spark plugs, IAC Cleaned, MAFF Cleaned, change the fuel filter already. Any Help is welcome. Thanks!!
Reply With Quote
  #2  
Old 08-25-2011, 08:57 AM
Explorer seats are in
 
Join Date: Oct 2009
Posts: 6,179
Default Re: Hard Starting when the engine is cold...

Go ahead and change your IAC valve. I had the same problem. I cleaned and cleaned it repeatedly and still the same. I finally bought one from my work (at the time was Oreilly's) and costed me 32.00.
__________________
1999 Ford Ranger 3.0xl


My Build Thread!!!
Reply With Quote
  #3  
Old 08-25-2011, 09:33 AM
Liking the Ford Ranger Forum
 
Join Date: Jul 2011
Posts: 19
Default Re: Hard Starting when the engine is cold...

Ok! I will do that, hope it work. Thanks!!
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
hard starting blockbuster 4.0 SOHC / 4.0 OHV Tech 12 12-18-2011 09:14 AM
Engine noise when starting on cold morning hmcqueary 3.0 Vulcan Tech 2 10-26-2011 06:20 AM
hard starting asanders 4-Cylinder Tech 0 08-18-2011 05:43 AM
Hard Starting Kdahl 4.0 SOHC / 4.0 OHV Tech 0 11-16-2010 08:46 PM
Intermittent hard start when cold mj1287 4.0 SOHC / 4.0 OHV Tech 5 10-29-2009 01:26 PM



Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.