Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 11-02-2009, 02:10 PM
SmokeyMcPot420 SmokeyMcPot420 is offline
Ford Tough
 
Join Date: Oct 2009
Posts: 388
Send a message via AIM to SmokeyMcPot420
Default Got codes...what do they mean?

1998 ford ranger 3.0 running rich. heres what the computer thing said:

"HO2 SII Sensor indicates rich" P1132

"HO2 SII Sensor indicates rich" P1152

"Upstream HO2S not switching"

"Fuel system at adaptive limits"

Reference F082 for information

...can someone decipher this for me?

I just replaced the 3.0 with a 1999 3.0 engine and its running rich and black smoke is blowing out.
Reply With Quote
  #2  
Old 11-02-2009, 02:35 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

P1132 P1152 Mass Air Flow Sensor
get some cleaner and clean it
__________________
2005 Edge

Reply With Quote
  #3  
Old 11-02-2009, 02:39 PM
SmokeyMcPot420 SmokeyMcPot420 is offline
Ford Tough
 
Join Date: Oct 2009
Posts: 388
Send a message via AIM to SmokeyMcPot420
Default

So if its not the computer like you told me before, after I clean it it will run good haha?
Reply With Quote
  #4  
Old 11-02-2009, 03:32 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

Try cleaning it and see what happens
Did u take it on a 10 mile drive?

If you didn't change the computer when you swapped engines there is very good chance it is the computer. Wasn't the replacement engine from a Explorer?
__________________
2005 Edge

Reply With Quote
  #5  
Old 11-02-2009, 07:29 PM
SmokeyMcPot420 SmokeyMcPot420 is offline
Ford Tough
 
Join Date: Oct 2009
Posts: 388
Send a message via AIM to SmokeyMcPot420
Default

no from a 99 ranger and no my step dads gonna take it on a 10 mile drive tommorow before cleaning the MAF sensor and see what happens.
Reply With Quote
  #6  
Old 11-03-2009, 02:30 PM
SmokeyMcPot420 SmokeyMcPot420 is offline
Ford Tough
 
Join Date: Oct 2009
Posts: 388
Send a message via AIM to SmokeyMcPot420
Default

Cleaned the MAF sensor and its not throwing codes and not running rich. Check engine light ain't on. One more problem though....it hesistates at 3000 rpm... only when going up hil or on flat, not down hill....what could that problem be?
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine codes help CHRISTIAN General Tech 5 12-24-2010 07:15 AM
Rear Axle Codes / Determine Gear Ratio STL Drivetrain Tech 2 10-29-2009 12:56 PM
Clearing airbag codes Clem General Ford Ranger Discussion 0 10-24-2009 05:30 AM
Is there an easy way to find check engine codes? lamart72 General Tech 1 08-09-2009 06:04 AM