Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 10-29-2009, 06:27 PM
SmokeyMcPot420 SmokeyMcPot420 is offline
Ford Tough
 
Join Date: Oct 2009
Posts: 388
Send a message via AIM to SmokeyMcPot420
Default 3.0 running rich

Hey so I finally got an engine for my ranger and we put it in, started it and it idles high like around the 2000-2500 RPM range. So we switched out the throttle body sensor and the fixed the idle....Now the problem is if you give it gas it smoked black like crazy and it spits and sputters at 3000 RPM. anything before or after 3000 RPM it runs fine, but still smokes. Just wondering what the problem could be. We pulled the codes and im not sure exactly what they are because there written down in the shop and im not sure but they may be "1208" or "080"...something along those lines. Does anyone know what it could be? Its a 1998 ranger with a 1999 engine in it.
Reply With Quote
  #2  
Old 10-29-2009, 06:49 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

What engine is in there now
__________________
2005 Edge

Reply With Quote
  #3  
Old 10-29-2009, 06:52 PM
SmokeyMcPot420 SmokeyMcPot420 is offline
Ford Tough
 
Join Date: Oct 2009
Posts: 388
Send a message via AIM to SmokeyMcPot420
Default

3.0 l
Reply With Quote
  #4  
Old 10-29-2009, 06:54 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

Did the numbers for the computer match if not that could be your problem
__________________
2005 Edge

Reply With Quote
  #5  
Old 10-29-2009, 06:57 PM
SmokeyMcPot420 SmokeyMcPot420 is offline
Ford Tough
 
Join Date: Oct 2009
Posts: 388
Send a message via AIM to SmokeyMcPot420
Default

How would I fix that?
Reply With Quote
  #6  
Old 10-29-2009, 06:59 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

Need the computer that was with that engine or find the vin for that engine and find the right computer
__________________
2005 Edge

Reply With Quote
  #7  
Old 10-29-2009, 07:07 PM
SmokeyMcPot420 SmokeyMcPot420 is offline
Ford Tough
 
Join Date: Oct 2009
Posts: 388
Send a message via AIM to SmokeyMcPot420
Default

I'm not saying your wrong but would running rich be the only thing that it does when its not the right computer? Also its throwing codes....I still have to figure out that they mean.
Reply With Quote
  #8  
Old 10-30-2009, 06:44 AM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

If you got the actual code it is reading I could help. Those numbers you posted don't exist

If you left the original computer in there and swapped the engine and it was programed for another computer then it wont run right. That is why it is smoking and throwing coeds
__________________
2005 Edge

Reply With Quote
  #9  
Old 10-30-2009, 03:48 PM
SmokeyMcPot420 SmokeyMcPot420 is offline
Ford Tough
 
Join Date: Oct 2009
Posts: 388
Send a message via AIM to SmokeyMcPot420
Default

Alright, I dont know the codes but I will see what the mechanic has to say.
Reply With Quote
  #10  
Old 10-30-2009, 07:38 PM
SmokeyMcPot420 SmokeyMcPot420 is offline
Ford Tough
 
Join Date: Oct 2009
Posts: 388
Send a message via AIM to SmokeyMcPot420
Default

Wait wait wait wait...Where is the computer located?
Reply With Quote
  #11  
Old 10-30-2009, 08:49 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

Under the hood passenger side on the fire wall

Vehicle may have to be driven up to ten miles after PCM replacement to allow PCM to relearn it's adaptive strategy. During this the engine may run rough

__________________
2005 Edge


Last edited by STL; 10-30-2009 at 08:53 PM.
Reply With Quote
  #12  
Old 10-30-2009, 09:46 PM
SmokeyMcPot420 SmokeyMcPot420 is offline
Ford Tough
 
Join Date: Oct 2009
Posts: 388
Send a message via AIM to SmokeyMcPot420
Default

Im not sure if that came with the engine or not, but that 10 mile thing might be the answer haha
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
running hot mb128 3.0 Vulcan Tech 0 10-09-2009 09:21 PM
High idle & running rich RandSand 4.0 SOHC / 4.0 OHV Tech 2 10-08-2009 11:18 AM
tryin to get truck running 1995psd 2.9 Liter Tech 4 07-12-2009 05:16 PM
not running right redneck_ranger_1991 2.9 Liter Tech 1 04-26-2009 11:10 PM
Running HOTT Rangerman General Ford Ranger Discussion 3 03-04-2009 06:54 PM