Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 07-24-2011, 08:46 AM
ranger0130 ranger0130 is offline
Ford Ranger Owner
 
Join Date: Jul 2011
Posts: 64
Default misfire problems 3.0 liter

I recently got a 01 ranger 3.0 liter for dirt cheap. When i bought it the dang thing wouldn't run so i ask my boss at a local automotive shop if he would help me fix it up for a cruiser. He determined that only 2 of the cylinders had good compression and that we needed to shim the exhaust valves on the cylinders with bad compression. We shimmed 4 of the exhaust valves and then come to find out 2 cylinders were misfiring. Yesterday we shimmed the last 2 exhaust valves and it does not have a constant misfire anymore. I hooked it up to the snap on scanner looking under live data and several times a minute a random cylinder will still misfire for a second then go away. At this point my boss says the gas which is a year old is causing the problem. I just thought i would ask to see if anybody else had the same problem and if so what your suggestions are. The truck has 204k mostly highway miles on it.
Reply With Quote
  #2  
Old 07-24-2011, 09:55 AM
ranger0130 ranger0130 is offline
Ford Ranger Owner
 
Join Date: Jul 2011
Posts: 64
Default Re: misfire problems 3.0 liter

oh i forgot to mention the misfiring stops when you hit the gas pedal.
Reply With Quote
  #3  
Old 07-27-2011, 05:41 AM
ranger0130 ranger0130 is offline
Ford Ranger Owner
 
Join Date: Jul 2011
Posts: 64
Default Re: misfire problems 3.0 liter

update: it has smoothed out alot after running some seafoam. Im going to clean the throttle body today and we'll see if that takes care of it all.
Reply With Quote
  #4  
Old 07-27-2011, 06:09 AM
djfllmn djfllmn is offline
ford dealer parts guy
 
Join Date: Apr 2011
Posts: 20,770
Send a message via AIM to djfllmn
Default Re: misfire problems 3.0 liter

also do you know if the cam sync was ever replaced? because if that goes then your motor is toast
__________________
2016 F150 Supercrew XLT 5.0
1968 Ford Thunderbird Tudor 429 Thunderjet V8

(Click for Project Log)

traded-2007 F150 XLT Supercab 5.4
Sold:03 Sonic Blue FX4 Steppie 4.0SOHC 5spd
ranger free since 6/15/2012

Quote:
Originally Posted by Logan03CO View Post
These threads make me feel better about myself....
Quote:
Originally Posted by guell View Post
Welcome to the internet, if this is your first visit to it I suggest you stock up on a lot of preparation h cause you gonna be butt hurt a lot
Reply With Quote
  #5  
Old 07-29-2011, 04:33 PM
ranger0130 ranger0130 is offline
Ford Ranger Owner
 
Join Date: Jul 2011
Posts: 64
Default Re: misfire problems 3.0 liter

it doesn't have a cam sync
Reply With Quote
  #6  
Old 08-05-2011, 06:20 PM
ranger0130 ranger0130 is offline
Ford Ranger Owner
 
Join Date: Jul 2011
Posts: 64
Default Re: misfire problems 3.0 liter

well, when you first start it up after a couple hours it will shake real bad then once it warms up it will still shake but not near as bad. my boss thinks its the year old gas making it run rough. Although when i hook it up to live data on the snap on scanner it only shows a misfire a couple times a minute for just a split second. Anybody have any input? I've replaced the plug wires, plugs, and coil pack.
Reply With Quote
  #7  
Old 08-27-2011, 02:30 PM
ranger0130 ranger0130 is offline
Ford Ranger Owner
 
Join Date: Jul 2011
Posts: 64
Default Re: misfire problems 3.0 liter

update: the gas is not the problem. Filled it up with brand new gas and put about 100 miles on it... still shakes at idle. Any more suggestions?
Reply With Quote
  #8  
Old 08-27-2011, 06:17 PM
webster426 webster426 is offline
Republican
 
Join Date: Mar 2011
Posts: 336
Default Re: misfire problems 3.0 liter

plugs, wires?
__________________
2000 Ranger XLT 3.0L V6

Rancho 9000XL's
Reply With Quote
  #9  
Old 08-27-2011, 07:00 PM
ranger0130 ranger0130 is offline
Ford Ranger Owner
 
Join Date: Jul 2011
Posts: 64
Default Re: misfire problems 3.0 liter

done all that... now it does it shakes while i'm on the gas..
Reply With Quote
  #10  
Old 08-27-2011, 07:24 PM
webster426 webster426 is offline
Republican
 
Join Date: Mar 2011
Posts: 336
Default Re: misfire problems 3.0 liter

fuel filter, IAC, O2 sensors, MAF?
__________________
2000 Ranger XLT 3.0L V6

Rancho 9000XL's
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
03 3.0 flex fuel cylinder 5 misfire fixed now 4 misfire error Steve o 3.0 Vulcan Tech 2 10-04-2011 06:19 PM
Need Help Misfire Problems KickAssRanger 3.0 Vulcan Tech 2 10-04-2011 05:48 PM
Craigslist / eBay Find: 3.8 liter V6 jacobxstanley Trucks 1 07-22-2011 02:06 PM
Engine Problems 99 v6 3.0 liter blnmsc05 General Ford Ranger Discussion 3 09-08-2010 02:12 PM
misfire problems scheider1980 3.0 Vulcan Tech 4 01-06-2010 05:18 PM