Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 10-23-2009, 11:27 PM
mb128 mb128 is offline
Member
 
Join Date: Oct 2009
Posts: 894
Question oil temp problem please help

i noticed my oil temp gage is jumping bad i was driving on the high way at the time. i had someone tell me its posibly the oil sending unit is bad. its a 95 xlt. does anyone know wat else it could be? this is my first truck and so far its been good to me. the oil level is good. i have no idea wat weight oil is in it
Reply With Quote
  #2  
Old 10-24-2009, 12:01 AM
blueovelboy blueovelboy is offline
GO SHARKS
 
Join Date: Aug 2009
Posts: 1,523
Default

gage might be jacked up, but would find out if its really a oil problem last thing you need is to blow up your motor due to lack of oil geting pushed threw there!
__________________
Jay's
09 XL reg cab
L4 2.3 , 40 series flowmaster , tinted windows 5% back 35% sides ,muffler removed from air box mod ,and ac on off switch mod , blinker mod, avs window vent shades
coming soon! k&n drop in/fiberglass bed cover/bed sprayed liner
Reply With Quote
  #3  
Old 10-24-2009, 12:17 AM
mb128 mb128 is offline
Member
 
Join Date: Oct 2009
Posts: 894
Default

im going down to the auto parts store tommarrow and getting the oil sending uint. its kind of scary driving it. i dont no if i can trust it. it smelt hot before i changed my oil and now this.
Reply With Quote
  #4  
Old 10-25-2009, 02:08 AM
mb128 mb128 is offline
Member
 
Join Date: Oct 2009
Posts: 894
Default

i replaced the sending unit and my gauge is still freaking out but i talked to a macanic and he told me it could be the cluster is bad my tac would also get stuck sometimes
Reply With Quote
  #5  
Old 10-25-2009, 07:48 AM
rwenzing rwenzing is offline
Some assembly required...
 
Join Date: Jun 2009
Posts: 890
Default

Quote:
Originally Posted by mb128 View Post
oil temp gage
Which is it - coolant temp or oil pressure? Which V6 do you have?
__________________
2003 FX4 Level II, Supercharged 5.0L V8, Headers, Duals
BW4406 manual transfer case, Aussie Locker, Torsen L/S, 4.10's
Bilstein 7100 rezzies, Cadillac/Mustang rear discs, Duff traction bars
Keypad Entry, Lock LEDs, ABS switch, sway bar discos
Heated seats, Explorer EATC, Trip Computer and consoles

2003 XLT 2.3L M5OD-R1 reg cab, 2011 Taurus SEL, 2016 C-MAX Energi Plug-in Hybrid
Reply With Quote
  #6  
Old 10-25-2009, 10:19 PM
mb128 mb128 is offline
Member
 
Join Date: Oct 2009
Posts: 894
Default

3.0 and pressure gauge
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
temp gauge adk General Ford Ranger Discussion 2 06-02-2011 04:13 PM
Temp Gauge Not Registering taz General Tech 9 11-26-2010 05:14 AM
Temp gauge not functioning twdavis416 Electrical Tech 2 11-23-2009 06:19 PM
coolant temp fluctuations adrenalinemotion 4.0 SOHC / 4.0 OHV Tech 4 10-13-2009 06:57 PM
Cab Air Temp jacmo General Tech 0 06-22-2009 08:14 AM