Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #16  
Old 11-18-2009, 01:47 PM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

Does the truck start now can you do a fuel pressure test? You could have a fuel pressure regulator issue I think your fpr is in the tank with the pump but i am not positive. if you buy just the pump and your regulator is bad............you could wait and see if you get a little more feedback...........
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #17  
Old 11-18-2009, 02:20 PM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default

This sounds like a fuel delivery problem. If it was getting fuel, you would smell gas from it getting flooded trying to start and not firing. I would put money on a faulty fuel pump or faulty fuel pump relay.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #18  
Old 11-19-2009, 05:34 AM
jgrasty7 jgrasty7 is offline
Liking the Ford Ranger Forum
 
Join Date: Oct 2009
Posts: 20
Default

it seems that if I cycle the key on and off several times, it will start. Does this indicate anything?
__________________
2004 Ranger XLT
Ext. Cab
Cap
100k
Reply With Quote
  #19  
Old 11-19-2009, 05:46 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

I would guess the fpr is an issue or the fuel pump and when you cycle it it is building up some presure. can you hear the pump each time you cycle it.
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #20  
Old 11-19-2009, 09:28 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default

Quote:
Originally Posted by jgrasty7 View Post
it seems that if I cycle the key on and off several times, it will start. Does this indicate anything?
It is indicating to me exactly what I thought... fuel pump or fuel pump relay. Start with the relay, its cheap and easy. Then move on the the pump.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #21  
Old 11-19-2009, 09:39 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

For $8 buy a relay and see what happens. You said you "checked the relay" Fireranger is his FPR in the tank. If you buy just the pump then you would not get a FPR,right, do you need to buy the whole setup to get the FPR. Don't you think it would be prudent to get the whole setup. Since you have to drop the tank to replace
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #22  
Old 11-19-2009, 10:11 AM
jgrasty7 jgrasty7 is offline
Liking the Ford Ranger Forum
 
Join Date: Oct 2009
Posts: 20
Default

I've never felt like I could hear the pump even when it was working fine. Today I got a fuel pressure gauge and it read 55psi in the on position and 60-65psi while it was running. I know that this isn't correct b/c it's supposed to be lower while running. I put fuel injector cleaner in the truck yesterday and since then it hasn't had any problems starting, I don't know if that's a fluke or what.
Joshua
__________________
2004 Ranger XLT
Ext. Cab
Cap
100k
Reply With Quote
  #23  
Old 11-19-2009, 10:31 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default

If fuel injection cleaner actually fixed that, I will be very impressed. I would want to know what the fuel pressure was reading while it was having a no-start episode.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #24  
Old 11-19-2009, 10:40 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

I was thinking the same thing about the cleaner and the same thing about checking the FP on a no start. Maybe even if you opened the shrader valve on a no start to see if it is almost dead......to the OP please tell me you got a new fuel pump relay
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #25  
Old 11-19-2009, 10:45 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

I was thinking the same thing about the cleaner and the same thing about checking the FP on a no start. Maybe even if you opened the shrader valve on a no start to see if it is almost dead......to the OP please tell me you got a new fuel pump relay
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #26  
Old 11-19-2009, 04:11 PM
jgrasty7 jgrasty7 is offline
Liking the Ford Ranger Forum
 
Join Date: Oct 2009
Posts: 20
Default

So all day today it started fine (10times). Yeah it seems weird to me as well. Maybe the fpr or fp were having issues b/c they were gunked up and the fuel injector cleaner helped clean them out as well? Hopefully that took care of it but I doubt it. I will post the fuel pressure on the next no-start.
Thanks for all the help.
Joshua
__________________
2004 Ranger XLT
Ext. Cab
Cap
100k
Reply With Quote
  #27  
Old 11-19-2009, 04:41 PM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

That would be great if the injecter cleaner worked and so fast. I am curious could tell me how you checked the relay did you switch it with the blower motor relay or something else and is the relay in the fuel pump spot a different one or the original thx
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #28  
Old 11-19-2009, 04:48 PM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

What fuel injector cleaner did you use? Techron? I think I saw on the other website that someone suggested you whack the area of the pump with a hammer. Did you do that and is that about when it started to work?
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #29  
Old 11-19-2009, 05:20 PM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default

Quote:
Originally Posted by modelageek View Post
I think I saw on the other website that someone suggested you whack the area of the pump with a hammer.
Its amazing what you can fix by doing that.

American components, russian components. All made in taiwan!
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #30  
Old 11-19-2009, 09:13 PM
jgrasty7 jgrasty7 is offline
Liking the Ford Ranger Forum
 
Join Date: Oct 2009
Posts: 20
Default

I swapped it out with the wiper hi/lo relay and then swapped it back so the original is in that spot now. I did try tapping on the gas tank with a mallet a couple of days ago but just after that it still had problems starting. Maybe the mallet knocked some junk loose and the injector cleaner finished the job? I really can't explain it but it's only been a day of no probs so we'll have to see. I just went out tonight after the trucks been sitting for several hours, hoping to get a no-start pressure test but it started right up. The fuel injector cleaner I put in was just the advanced auto brand. It wasn't diluted as much as it was supposed to be b/c I poured the whole bottle in and was planning on getting gas but thought I might have to take the tank off so I didn't actually get gas. So there was like a full bottle of cleaner in just a quarter tank, probably not the best thing for the truck but who knows.
__________________
2004 Ranger XLT
Ext. Cab
Cap
100k
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Random cell phone pic... Superlifted06FX4 Vehicle Snapshots 8 11-26-2009 05:29 PM
Some random pic's Ive taken.. DieHard4rd Photography 58 11-11-2009 04:18 PM
Random photography STL Photography 22 10-11-2009 08:15 PM
random question billyjo21 Off Topic 1 09-23-2009 10:55 PM
A Few Random Pics Jay FX4 Vehicle Snapshots 22 09-07-2009 08:27 PM