Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-25-2011, 09:49 PM
timothy47129 timothy47129 is offline
Ford Pickup
 
Join Date: Jan 2010
Posts: 105
Default mising only at idle desperate for a fix

I have a bad misfire only at idle and can not figure out what it is.Im at the point its going to be a trip to the dealer for a $69.00 diagnostic.Let me give ya a little history on the prob.It started about a month ago and got worse.It has new plugs,wires,coil pack,maf sensor cleaned,throttle body cleaned ,egr passage and valve cleaned,air filter changed,fuel filter replaced,fuel injectors cleaned, and a new cam sensor.Is there anything I am missing?I also have cleaned it out with sea foam every 3-4 oil changes.I have checked the vaccum and it was a steady 19" When you start it cold it misses but not too bad.But when u start it warm and back out with light throttle it runs like its missing on a few cylinders.but as soon as you give it more that light throttle it clears up and is fine.Im kinda leanin to it being the injectors.I have always ran ethonol every now and then but the last few months I have been runnin it for about 3 fill ups between tanks of regular gas.Oh it is a 1999 3.0 flex fuel.Also the pcm isnt throwing any codes.

thanks,
tim
__________________
sold years ago : Dark blue 1999 ford ranger flareside supercab Xlt 2wd flex fuel 3.0 auto all factory options except 4wd. Current mods include :explorer overhead console with temp display,exterior color matched painted interior dash trim and door panel trim, auto dark rear view mirror,euro tail lights,tonneau cover,1 high flow cat,cherry bomb pro muffler into 6" oval tip exited under the rear step.
Reply With Quote
  #2  
Old 05-26-2011, 05:39 PM
Fordzilla80 Fordzilla80 is offline
Welcome to FRF!
 
Join Date: Oct 2010
Posts: 8,952
Default Re: mising only at idle desperate for a fix

What type of plugs/wires did you use?
Reply With Quote
  #3  
Old 05-26-2011, 07:01 PM
Ray Parrott Ray Parrott is offline
Liking the Ford Ranger Forum
 
Join Date: Apr 2011
Posts: 16
Default Re: mising only at idle desperate for a fix

Could be burnt exhaust valves
__________________
I have a 1998 Ford Ranger XLT. 2.5 Litre 4 speed w/ od. I have never owned a ford truck and purchased this one at a Farm auction for 1500.00.
Reply With Quote
  #4  
Old 05-27-2011, 07:13 PM
timothy47129 timothy47129 is offline
Ford Pickup
 
Join Date: Jan 2010
Posts: 105
Default Re: mising only at idle desperate for a fix

Update,
I did a compression test today not too good but all cylinders were within 10psi of each other. The results were about 100psi dry and 130psi with oil.so I know after 165,000 miles my rings are showin some wear.but between the vacuum gauge test and compression test it kinda tells me it isnt the valves since it raised with the oil. So im kinda leanin toward may be a bad injector.After 100 miles on new plugs they still look new so the miss isnt makin it run rich.So it must be a lean miss.But only at idle?
__________________
sold years ago : Dark blue 1999 ford ranger flareside supercab Xlt 2wd flex fuel 3.0 auto all factory options except 4wd. Current mods include :explorer overhead console with temp display,exterior color matched painted interior dash trim and door panel trim, auto dark rear view mirror,euro tail lights,tonneau cover,1 high flow cat,cherry bomb pro muffler into 6" oval tip exited under the rear step.
Reply With Quote
  #5  
Old 06-02-2011, 09:13 PM
my clean XLT my clean XLT is offline
Learning to use the forums
 
Join Date: Jun 2011
Posts: 6
Default Re: mising only at idle desperate for a fix

I am very familiar with your fustration. I too have a 99 3.0 flex giving me the same problem. I went to a friends shop where he hooked up a assortment of fancy dionostic devices which indecated that there was only a problem with the driver! Every thing checked out to be optimally opperating.No codes & no problem . Were baffled but not giving up! I really like my little ranger and just want it to be happy. I am running the motorcraft firewire plugs, bosch performance wires and do routine preventative maintaince. I was hopeing that it was result of the oil companies changing the formula of the gas from winter to summer blend, not really sure if they do but I do notice a difference in my MPG's. I get a couple more miles round mid april
__________________
She's just a black extented cab/ 4 door 3.0 w/ a 5 speed auto. Nothing really extraorniary but she's all mine.(& it's all one color w/ matching tires)
Reply With Quote
  #6  
Old 06-09-2011, 09:08 AM
RallyTruck RallyTruck is offline
Ford Truck Driver
 
Join Date: Dec 2009
Posts: 83
Default Re: mising only at idle desperate for a fix

SO here is your answer to the rough idle. After years and years of dealing with this problem on my 2002 3.0, we finally discovered what and where this is coming from. My truck had this problem since the day I bought it. It has been to the dealer no less than 20x with the same response, "we don't know." They have R&R'd about every sensor, injector on the motor. An ol timer told me that Ford doesn't have the best quality control with their parts and that on that truck he is guessing that there is a cam lobe problem. Sure enough, I changed cams, and the rough idle went away. It appears that the number 5e lobe is a hair off which creates the rough idle. With this problem, it is not severe enough for the cam sensor to throw an engine code. Fortunately, it doesn't create any problems with the motor, it's just annoying as hell! You would think FORD would have been able to figure this out. My guess is they knew about it but didn't want to tear into millions of 3.0's.
Reply With Quote
  #7  
Old 06-21-2011, 09:44 AM
LWOOD02 LWOOD02 is offline
Learning to use the forums
 
Join Date: Jun 2011
Posts: 3
Default Re: mising only at idle desperate for a fix

!!

Last edited by LWOOD02; 06-23-2011 at 07:34 AM.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
in desperate need of help!!!! mclovin1872 Introduce Yourself 28 03-09-2011 03:32 PM
Please Help I am Desperate! esimmons Lifted Suspension 6 03-09-2011 12:42 PM
help help desperate IVAN General Tech 4 03-03-2011 07:00 PM
Desperate/Funny CL post BCobe Laugh Factory 3 12-10-2010 05:41 AM
Mising codec STL Music/Movies/Computers/etc. 8 05-16-2010 11:02 PM