Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-12-2011, 09:39 AM
davidsheets davidsheets is offline
Learning to use the forums
 
Join Date: Jul 2010
Posts: 8
Default 1991 Ranger, 3.0L, EFI, cranks good, but does not start

Ford Ranger XLT, Standard Cab, 2-wheel drive
Year: 1991
Engine: 3.0L, EFI
Manual transmission

The engine cranks good, but does not start. There is no fire at all.

Back story:
I had a bad alternator, which I changed a week ago or so. After replacing the alternator, everything was back to normal...engine started and ran as it always had...a little rough.

So, I decided to change the distributor cap, rotor, plug wires, plugs, and coil, since they are all so cheap. After changing everything, it started and ran exactly the same as before changing everything. FYI, the old plugs on the passenger side had the electrodes missing, lol. I replaced the wires to match the exact order of the old cap.

Anyway, after looking at the manual, I noticed the wiring of the plugs was incorrect on the passenger side, so I fixed that, and tried to restart, but the engine would not fire. It would crank fine, but no fire.

Okay, so that is how I got where I am now.

Symptoms:
1. Engine cranks, but will not start. No engine fire whatsoever.
2. I can smell a small amount of fuel odor as I continue to crank it. This makes me think the fuel system is working, and I'm just getting a build up of unburnt fuel in the engine.

Fuel pump: I can hear the pump start like normal. I don't have a fuel pressure gauge, but I did press down on the Schroeder valve with the key on, and fuel sprayed out. I may run down and get a gauge later to test it.

Spark: I tried grounding the plugs on the driver side and saw spark while cranking. I can't really tell if the spark is strong enough to ignite the fuel, but it doesn't seem like it would take much.

I have spark and fuel, so why won't 't it start?
I tried squirting a little fuel into the intake while cranking, and still no engine fire.
__________________
1991 Ford Ranger XLT
3.0 engine
manual transmission
2-wheel drive
standard cab
Reply With Quote
  #2  
Old 05-17-2011, 09:34 AM
davidsheets davidsheets is offline
Learning to use the forums
 
Join Date: Jul 2010
Posts: 8
Default Re: 1991 Ranger, 3.0L, EFI, cranks good, but does not start

Anyone have any idea?
__________________
1991 Ford Ranger XLT
3.0 engine
manual transmission
2-wheel drive
standard cab
Reply With Quote
  #3  
Old 05-17-2011, 10:06 AM
01B3000 01B3000 is offline
Needs moar chrome....
 
Join Date: Dec 2010
Posts: 1,319
Default Re: 1991 Ranger, 3.0L, EFI, cranks good, but does not start

If it originally started when it was wrong, put it back that way, maybe when you looked at it you thought the correct way was wrong
__________________
2001 Mazda B-3000 CabPlus "FX2 Off Road"| 3.0 | 5 SPD | 3 In Spindle Lift | Belltech Shackles | UltraGauge |Alpine Head / 10" Kicker Setup | Air Box Mod | Add-A-Leaf| Thrush Welded B4 Rear Wheel | Kobalt Box | Cobra 19 DX IV | Custom PA Speaker | Front/Rear Tow Receiver | 2X Aux Lights | Hideaway Strobes | Back Rack Safety Rack | Amber LED Strobes | Blue LED Strobes | 265/75/R16 General Grabber AT2's
Quote:
Originally Posted by Clinton View Post
I like little girls...........
RIP Jason
Reply With Quote
  #4  
Old 05-17-2011, 12:52 PM
davidsheets davidsheets is offline
Learning to use the forums
 
Join Date: Jul 2010
Posts: 8
Default Re: 1991 Ranger, 3.0L, EFI, cranks good, but does not start

I put the wires back the way they were originally, but still it will not fire.
__________________
1991 Ford Ranger XLT
3.0 engine
manual transmission
2-wheel drive
standard cab
Reply With Quote
  #5  
Old 05-17-2011, 09:31 PM
01B3000 01B3000 is offline
Needs moar chrome....
 
Join Date: Dec 2010
Posts: 1,319
Default Re: 1991 Ranger, 3.0L, EFI, cranks good, but does not start

Uh, check your battery, make sure it has a good charge, I know on older efi and carb'd engines that used a distributor, if the battery doesnt have a good charge, It will crank and spark all it wants, but it still wont fire, I had this problem on my 86 ram, and me and my friend had this problem on his 64 galaxie, new batteries and everything started right up
__________________
2001 Mazda B-3000 CabPlus "FX2 Off Road"| 3.0 | 5 SPD | 3 In Spindle Lift | Belltech Shackles | UltraGauge |Alpine Head / 10" Kicker Setup | Air Box Mod | Add-A-Leaf| Thrush Welded B4 Rear Wheel | Kobalt Box | Cobra 19 DX IV | Custom PA Speaker | Front/Rear Tow Receiver | 2X Aux Lights | Hideaway Strobes | Back Rack Safety Rack | Amber LED Strobes | Blue LED Strobes | 265/75/R16 General Grabber AT2's
Quote:
Originally Posted by Clinton View Post
I like little girls...........
RIP Jason
Reply With Quote
  #6  
Old 05-18-2011, 06:17 AM
davidsheets davidsheets is offline
Learning to use the forums
 
Join Date: Jul 2010
Posts: 8
Default Re: 1991 Ranger, 3.0L, EFI, cranks good, but does not start

The battery is good.

I've took the Ignition control module to AutoZone, and it tested good, so it isn't that.

I'm going to try the Pick-Up Coil.
__________________
1991 Ford Ranger XLT
3.0 engine
manual transmission
2-wheel drive
standard cab
Reply With Quote
  #7  
Old 05-24-2011, 12:59 PM
davidsheets davidsheets is offline
Learning to use the forums
 
Join Date: Jul 2010
Posts: 8
Default Re: 1991 Ranger, 3.0L, EFI, cranks good, but does not start

It was the distributor.

I replaced the distributor, and it started right up, and runs fantastic.

The stator was warn on one side really bad from were the rotor was hitting it. The stator was rubbing on one side, and missing on the other by about 100/1000 of an inch, which is way out of specification. It was due to the bearings on the distributor shaft being so warn out that the side-play was between 60-100 thousands. It is possible that the pick-up coil was also bad, but I'll never know that for sure.

Next up, figure out why the A/C isn't working.
__________________
1991 Ford Ranger XLT
3.0 engine
manual transmission
2-wheel drive
standard cab
Reply With Quote
Reply

Tags
cranks but doesn't start, engine will not fire, engine will not start

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cranks but won't start 98rangerman 4-Cylinder Tech 26 06-20-2013 10:09 AM
Cranks... But Won't Start RangerFixer 4-Cylinder Tech 23 09-28-2011 01:48 AM
95 ranger Cranks, will not start. djhawk 4.0 SOHC / 4.0 OHV Tech 0 04-22-2011 06:11 PM
1991 4x4 4.0 OHV to 5.0 30 EFI swap. What does it take? Tork 8-Cylinder Tech 3 03-10-2011 02:29 PM
I have a 94 ford ranger v6 3.0 it cranks but it wont start? mossyoakgirl6564 General Ford Ranger Discussion 2 01-09-2009 12:41 PM