Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 04-18-2011, 04:03 PM
agelwell42 agelwell42 is offline
Like the Forums
 
Join Date: Apr 2011
Posts: 37
Default losing anitfreeze

my ranger set for like five years before i got it last year. ever since i have flushed the system 2 times. its clean and all but when i put antifreeze in the over flow tank it seem to disappear. i can't find any leaks but it runs perfect. where is the antifreeze goin?
__________________
94 2wd, 3.0v6, auto tranny,3.45 open rear end,2 inch leveling kit, Jones Full Board single chamber dualed out, 05 ranger steel wheels, two kc fog lights, AAL, aftermarket tail lights


“Keep the dream alive: Hit the snooze button.”
Reply With Quote
  #2  
Old 04-18-2011, 04:13 PM
More_Cowbell More_Cowbell is offline
Chrome Dont Get You Home
 
Join Date: Dec 2009
Posts: 1,169
Default Re: losing anitfreeze

check your cap i had a little leak in mine that didnt make any visible fluid anywhere but slowly let steam escape
__________________
1990 Ranger Extended Cab
2.9L V6 5 Speed Transmission
Planning to put a 347 and a T-5 in it eventually

Quote:
Originally Posted by FireRanger View Post
It looks like someone attacked the front of the truck with a bedazzler.
Reply With Quote
  #3  
Old 04-18-2011, 05:36 PM
agelwell42 agelwell42 is offline
Like the Forums
 
Join Date: Apr 2011
Posts: 37
Default Re: losing anitfreeze

ok thanks man
__________________
94 2wd, 3.0v6, auto tranny,3.45 open rear end,2 inch leveling kit, Jones Full Board single chamber dualed out, 05 ranger steel wheels, two kc fog lights, AAL, aftermarket tail lights


“Keep the dream alive: Hit the snooze button.”
Reply With Quote
  #4  
Old 04-18-2011, 06:01 PM
Tommy2 Tommy2 is offline
Ford Pickup
 
Join Date: Feb 2011
Posts: 102
Default Re: losing anitfreeze

Yea, if the truck is running good, and it's not going in your oil - it's dripping out somewhere. Just keep a close eye under the truck and you'll eventualy spot it. Sometimes leaks aren't as easy to find as you'd suspect since leaks are often intermittent only when the motor is hot.
Reply With Quote
  #5  
Old 04-19-2011, 02:42 PM
agelwell42 agelwell42 is offline
Like the Forums
 
Join Date: Apr 2011
Posts: 37
Default Re: losing anitfreeze

yea thats what i was thinking. it could be like a rotted hose or someting. but have never seen any while just sittin so thats probably what is happening. if anyone else has any imput it would be apperciated as the ones above
__________________
94 2wd, 3.0v6, auto tranny,3.45 open rear end,2 inch leveling kit, Jones Full Board single chamber dualed out, 05 ranger steel wheels, two kc fog lights, AAL, aftermarket tail lights


“Keep the dream alive: Hit the snooze button.”
Reply With Quote
  #6  
Old 04-19-2011, 02:55 PM
01_ranger_4x4 01_ranger_4x4 is offline
OIF Veteran

 
Join Date: Feb 2010
Posts: 6,043
Default

The best way to pinpoint coolant leaks is with a coolant system pressure tester. They can be rented at most autoparts stores and are simple to use. You can also test your cap with the tested too.

[posted from my space aged wireless mobile communtication device using tapatalk]
__________________
2001 Ranger 4x4 Stepside
-RCD Suspension lift
-33x12.5 BFG KM2's on Mickey Thomson classic locks
-4:56 gears
-Auburn gear LS
-James Duff traction bars
-Headers
-Flowmaster duals
-SCT X-Cal2 and some small exterior mods

http://www.cardomain.com/ride/2321189

2005 F-150 Lariat 4x4
-LED third brake light
-Weathertech floor liners
-Edge tuner
Reply With Quote
  #7  
Old 04-19-2011, 03:06 PM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: losing anitfreeze

Lets backup a bit here. You don't fill the system through the reserve tank. On a cold engine, you take the radiator cap off and fill that to the top. Then start the engine. Once it warms up, the tstat will open and it will circulate coolant through the engine. If the system is low, you will see the level in the radiator drop. Add more coolant as it sucks it out until it stabilizes. Put the cap back on and you're good to go. The tank should then be filled up 1/2 way with coolant.

Do that and see what the coolant level does after you have it properly topped off. Then we'll see if there really is even a problem.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #8  
Old 04-20-2011, 04:29 PM
agelwell42 agelwell42 is offline
Like the Forums
 
Join Date: Apr 2011
Posts: 37
Default Re: losing anitfreeze

i did as u said fireranger and there wasn't a problem. just a da assumption. thanks for the feedback everyone
__________________
94 2wd, 3.0v6, auto tranny,3.45 open rear end,2 inch leveling kit, Jones Full Board single chamber dualed out, 05 ranger steel wheels, two kc fog lights, AAL, aftermarket tail lights


“Keep the dream alive: Hit the snooze button.”
Reply With Quote
  #9  
Old 04-20-2011, 05:11 PM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: losing anitfreeze

Excellent! I had a feeling there wouldn't actually be anything wrong, it just wasn't filled all the way to begin with. Check it again in a few days to make sure.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
O1 Losing Fuel Pressure tstevens 4.0 SOHC / 4.0 OHV Tech 4 02-26-2011 09:41 AM
Losing Power? Infamous 4-Cylinder Tech 4 01-09-2011 06:09 PM
90 Ranger Keeps Losing Charge kmiller31 General Ford Ranger Discussion 3 11-02-2010 04:45 PM
Losing my lights! davidjsouth Electrical Tech 11 07-15-2010 09:45 AM