Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 03-28-2011, 05:58 PM
sled dog sled dog is offline
FULL PULL!!!
 
Join Date: Mar 2011
Posts: 3
Default Help! My truck won't run

I'm new here. From what I've seen so far you guys are pretty sharp. Thought I might test your minds.
I have a '99 Ranger with a 3.0 Flex. It has 106K on it. It ran great except for a sligt miss. OBD said insuficiant EGR flow. I put on a new EGR valve. Code still the same. That isn't my main prob. Put on new plugs and wires and it helped the miss. It's been damp here so I thought maybe the coil pack was leaking. Here is where I screwed up. I borrowed a coil pack from my buddy. It is off a 2000 4.0 Explorer. As soon as I plugged it in the engine sounded way out of time. It bucked and kicked and I shut it off. I put my coil pack back on and it wouldn't run. After some testing I was told it needed a PCM. After some searching I found a good on at a salvage yard. I had a local Ford dealer flash and upload it. They called and sait it jumped time and wanted to charge me $1100 to put a chain and gears in. Um.. I don't think so! I got it home and tore it down in 2 hours. The chain is loose and with the slop appears to be about a 1/2 tooth or so out. There is a 1/2" deflection in the slack side of the chain. I'm installing a new on tomorrow. I don'tthink this is going to fix it. I've put new crank and cam sensors on, timed the cam sensor, turnd the cam sensor. I'm getting spark, compression, gas and air. It wants to start but just won't. If it had a distributor you could advance it a few degrees and it would be running. I even pull the plugs and clear the cylinders of gas everytime we try to start it. What am I missing? The truck ran fine before I changed the coil.
I'm about ready to burn it down!
Thanks, Kevin
__________________
1999 Ford Ranger XLT Super Cab 4X4, 3.0 Flex, 5 sp

Future mods- 31" tires

Single cylinder flatheads on alky......INSANE!
Reply With Quote
  #2  
Old 03-28-2011, 07:51 PM
wangbungal wangbungal is offline
Ford Ranger 1997 3.0 V6
 
Join Date: Jun 2010
Posts: 239
Default Re: Help! My truck won't run

wow,its too hard to trace now as you have made several attempts to fix it,im guesing with the egr you have a p0401 code insufficient flow,the egr valve is unlikely the culprit,its usually the DPFE sensor or some clogged ports on the intake, engine miss could be fuel delivery issues, spark plugs and wires, im not really sure if ignition coil could mess your pcm,the only thing i could think is make your engine run weird if you cross the wires or put the wrong coils on it,i hope the gurus on this forum could chipped in,with regards to the timing chain and timing,thats way past me, as i only share my little bit of experience
__________________
1997 Ford Ranger 3.0 V6 2WD

Nothing special lol,
Reply With Quote
  #3  
Old 03-29-2011, 03:55 PM
sled dog sled dog is offline
FULL PULL!!!
 
Join Date: Mar 2011
Posts: 3
Default Re: Help! My truck won't run

I put the chain in tonite. The parts store had the chain but not the gasket! Thats my luck. I'll have her back together tomorrow night. The wires are the first thing I checked. Both coils had the same order. There is a world of difference between my old chain and the new one. Hopefully thats it. 24 hrs from now I'll either be crusin around or lightin a match to it!
__________________
1999 Ford Ranger XLT Super Cab 4X4, 3.0 Flex, 5 sp

Future mods- 31" tires

Single cylinder flatheads on alky......INSANE!
Reply With Quote
  #4  
Old 03-30-2011, 01:25 PM
sled dog sled dog is offline
FULL PULL!!!
 
Join Date: Mar 2011
Posts: 3
Default Re: Help! My truck won't run

Buttoned everything up jumped in and hit the key. Same thing. Acts lazy on time. I give up! I'm open to suggestions.
__________________
1999 Ford Ranger XLT Super Cab 4X4, 3.0 Flex, 5 sp

Future mods- 31" tires

Single cylinder flatheads on alky......INSANE!
Reply With Quote
  #5  
Old 04-04-2011, 01:04 PM
knightmare1015 knightmare1015 is offline
Senior Member
 
Join Date: Feb 2010
Posts: 2,010
Default Re: Help! My truck won't run

Sounds like you messed the PCM up when you used a different coil pack from another engine. I think you might have to have it reflashed. Try unhooking the battery for about 10 to 15 minutes. This should reset everything but the damage may have been done.
__________________
SOLD: 2004 Ford Ranger Edge 3.0 V6 5 speed



www.knightmare1015.blogspot.com

Last edited by knightmare1015; 04-04-2011 at 01:12 PM.
Reply With Quote
  #6  
Old 04-10-2011, 10:37 AM
grumpynuts grumpynuts is offline
Learning to use the forums
 
Join Date: Apr 2011
Posts: 6
Default Re: Help! My truck won't run

Check my post in this same subcategory, Satan's truck. We seem to be having the same problems. At least you can see what I have done to rule out other things on yours...
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
what gears to run?? 678liftedford Drivetrain Tech 12 03-02-2011 02:20 PM
Won't run!!!! robbiecox6 4.0 SOHC / 4.0 OHV Tech 2 02-27-2011 09:45 AM
can i run these? Ranger Girl Wheels and Tires 21 12-11-2010 10:05 AM
what pressure to run them at 01DangerRanger Wheels and Tires 10 10-08-2010 01:43 PM
Junkyard run Clinton Off Topic 39 09-20-2010 08:42 AM