Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 03-17-2011, 01:37 PM
nailbanger138 nailbanger138 is offline
Learning to use the forums
Join Date: Mar 2011
Posts: 1
Default 96 3.0 high idle, misfire on 2 & 5

Ok, I am completely lost. The issue began with high idle (2000-2500 rpm). The CEL came on, and codes indicated IAC, and misfire 2 and 5. I treated this as two separate issues. I changed the IAC, and idle dropped for a day or so, but high idle returned with no CEL. As for the misfire issue, coil pack and wires are fine, but the plugs in 2 and 5 were extremely corroded. I changed all the plugs, and I did a compression check at the same time. All cylinders showed 150 psi, except 2 and 5. Cylinder 2 showed 140, and cylinder 5 showed 170. At this point, after new IAC, new plugs and wires, and several questionable vacuum lines, high idle remains and the misfire is noticeable, but no CEL.

Things I have tried:
I vacuum tested the egr, and it operated fine.
I sprayed vacuum lines/intake with brake cleaner-no idle change
Removing the wire harness to IAC-idle drops briefly then elevates

My next plan is to remove the intake and begin testing injectors. Any advice would be greatly appreciated.
Reply With Quote
Old 03-22-2011, 06:33 PM
wangbungal wangbungal is offline
Ford Ranger 1997 3.0 V6
Join Date: Jun 2010
Posts: 239
Default Re: 96 3.0 high idle, misfire on 2 & 5

change intake gaskets,clean maf,throttle body seafoam check your fuel injectors for continuity
1997 Ford Ranger 3.0 V6 2WD

Nothing special lol,
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
High Idle on 87 2.3. Kmartcivic 4-Cylinder Tech 0 02-13-2011 09:01 AM
89 2.9l high hydrocarbons and rough high idle dherndon99 2.9 Liter Tech 7 11-17-2010 05:50 AM
Help Needed with Rough idle/CEL/cylinder misfire Flareside 3.0 Vulcan Tech 4 09-09-2010 01:38 PM
no misfire, still rough idle!!! RangerLuc 4.0 SOHC / 4.0 OHV Tech 13 05-15-2010 04:49 PM
High idle & running rich RandSand 4.0 SOHC / 4.0 OHV Tech 2 10-08-2009 11:18 AM