Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 02-24-2011, 07:14 PM
ur2noz ur2noz is offline
Learning to use the forums
 
Join Date: Oct 2010
Posts: 4
Default 92 ranger recently starts and idles very rough but drives fine afterwards?

Recently my 92 3.0 starts but idles so low you would think its going to stall but doesn't. Once you are driving it is fine. The check engine light comes on but only for a few seconds, I can't catch it on long enough to check it. Any ideas as to what I can check?

Thanks
Adam
Reply With Quote
  #2  
Old 02-24-2011, 07:57 PM
rcajklrw rcajklrw is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 3
Default Re: 92 ranger recently starts and idles very rough but drives fine afterwards?

my 2003 ford ranger is doing the same. It happens only sometimes and its at idle. I have replaced the spark plugs, wires, coil pack, and maf sensor. nothing. I even did a compression test dry and wet to check gasket and nothing is wrong there. I am throwing a cylinder 4 misfire code.
Reply With Quote
  #3  
Old 02-24-2011, 09:18 PM
Zipzag Zipzag is offline
Collision Repair.GM Tech
 
Join Date: Jan 2011
Posts: 129
Default Re: 92 ranger recently starts and idles very rough but drives fine afterwards?

I just had a car come in with same problem .We fixed his car the week before for a small accident, didnt start to happen till after the accident ,they all say that . it wouldn't idle right.
2 of his injectors were really plugged up one of them couldn't be rebuilt . He was having misfire codes as well . the rebuild was only 60 dollars the replacement was 199.99 . and no the insurance don't cover that .

Last edited by Zipzag; 02-24-2011 at 09:35 PM.
Reply With Quote
  #4  
Old 02-24-2011, 09:24 PM
ColinS ColinS is offline
slingin' mud to the sky!
 
Join Date: Feb 2011
Posts: 1,252
Default Re: 92 ranger recently starts and idles very rough but drives fine afterwards?

clean ur iacv and seafoam the motor.

----------

also recommend with the sea foam run it in the oil and in the fuel
__________________
Colin S. AGE: 18
1994 Ford Ranger XLT 4x4 reg. cab 4.0l 5spd, 2" SL , Summit Nomads 15x8, 30x9.5x15 Trail Digger M/T's, cab lights, spray in bed liner, custom tube bumper,

1994 Ford Ranger XLT 2.3l 5spd ext. cab. the loaner truck

1987 Camaro z28 383 to much to list

https://www.facebook.com/colinshriver

http://www.fordrangerforum.com/proje...anger-4x4.html
Reply With Quote
  #5  
Old 02-25-2011, 10:49 PM
ur2noz ur2noz is offline
Learning to use the forums
 
Join Date: Oct 2010
Posts: 4
Default Re: 92 ranger recently starts and idles very rough but drives fine afterwards?

Quote:
Originally Posted by GhostZ View Post
clean ur iacv and seafoam the motor.

----------

also recommend with the sea foam run it in the oil and in the fuel


Remove the IACV and clean it with? What would you suggest a good carb/choke cleaner?

Thanks
Adam
Reply With Quote
  #6  
Old 02-25-2011, 11:41 PM
rcajklrw rcajklrw is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 3
Default Re: 92 ranger recently starts and idles very rough but drives fine afterwards?

I have already sea foamed my engine twice one in a three part step. Crankcase gas tank and vaccum line. The second time I put the whole thing in my gas tank to clean the injectors. That didn't work so I tried ceveron techcron... nothing. I think tommorow I am going to try to.replace my fourth injector. I don't know which one is the number four so if anyone knows please let me know.
Reply With Quote
  #7  
Old 02-26-2011, 12:21 PM
PMoreau PMoreau is offline
Liking the Ford Ranger Forum
 
Join Date: Feb 2011
Posts: 17
Default Re: 92 ranger recently starts and idles very rough but drives fine afterwards?

In my 93 3.0 cylinder #4 in the one closest to the front on the drivers side.
Reply With Quote
  #8  
Old 02-26-2011, 11:20 PM
rcajklrw rcajklrw is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 3
Default Re: 92 ranger recently starts and idles very rough but drives fine afterwards?

Thank you so much I'll try that tomorrow!
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
2.3, starts fine, dies right way, starts runs rough for about 15 seconds JBusch 4-Cylinder Tech 4 10-07-2011 03:00 PM
97 Ranger idles rough, requesting help. vberard 4-Cylinder Tech 7 06-14-2011 10:21 PM
Recently Bought a Ford Ranger kahlmant Introduce Yourself 11 12-21-2010 11:37 AM
Ford ranger idles rough and doesn't take off smooth anymore. Acroma 3.0 Vulcan Tech 7 05-02-2010 11:08 PM
2.9 wont rev at all. starts and idles (low) but NO rev above playaforiife 2.9 Liter Tech 5 11-18-2009 12:02 PM