Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 02-14-2011, 02:40 PM
02Edge 02Edge is offline
Ford Ranger Owner
 
Join Date: Nov 2009
Posts: 63
Default What's causing this? Gauge? Sending Unit? Oil Pump?

What do you think is the cause of this? (click on photo to play video)

Reply With Quote
  #2  
Old 02-16-2011, 10:11 AM
rangerkid53 rangerkid53 is offline
Learning to use the forums
 
Join Date: Aug 2010
Posts: 7
Default Re: What's causing this? Gauge? Sending Unit? Oil Pump?

its actually just a switch going to the gauge. it tells you if you have oil pressure or not, not the actual oil pressure. its either a bad switch or your right on the verge of having low oil pressure
Reply With Quote
  #3  
Old 02-16-2011, 10:18 AM
klinger86 klinger86 is offline
Ford Ranger Driver
 
Join Date: Jan 2011
Posts: 2,970
Default Re: What's causing this? Gauge? Sending Unit? Oil Pump?

I would say it's a bad switch my old lady's exploded does the same thing. I gotta see how much the switch is and see how much it'll cost to get fixed
Reply With Quote
  #4  
Old 02-16-2011, 10:19 AM
sgtsandman sgtsandman is offline
Tank Diver
 
Join Date: Mar 2010
Posts: 3,078
Default Re: What's causing this? Gauge? Sending Unit? Oil Pump?

Go the cheapest route first and try changing the sensor. If that doesn't work, you might be looking at an new oil pump.
__________________
Sgtsandman's Work in Progress
2011 Ranger XLT, 4X4, 4 door Super Cab. 4.0L, 5 Speed M50D-R1HD, 3.73:1, 8.8" open differential, Jason Pace cap
1999 Honda CR-V EX, RT4WD, 2.0L, 5 Speed MT, 4.56:1, open differential
Reply With Quote
  #5  
Old 02-16-2011, 11:07 AM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: What's causing this? Gauge? Sending Unit? Oil Pump?

I say distemper! It looks electrical to me so try the sensor first
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sending Unit Float jimandpam General Ford Ranger Discussion 3 09-03-2011 05:05 PM
Bad Sending Unit? zaccornell 4.0 SOHC / 4.0 OHV Tech 6 08-31-2011 06:01 AM
Torque on OP sending unit? LAK1 General Ford Ranger Discussion 7 03-28-2011 06:11 PM
Where's my Oil Pressure Sending Unit? 02Edge 3.0 Vulcan Tech 1 05-12-2010 09:23 AM
92 4.0 low oil sending unit Clem 4.0 SOHC / 4.0 OHV Tech 0 10-03-2009 08:01 AM