Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 02-11-2011, 09:55 PM
lovemud lovemud is offline
off road all the time
Join Date: Feb 2011
Posts: 593
Default need help please

ok here's the deal. i was driving down the high way and went to hit the gas and my serpentine belt started to squealing an then i got what sounds like a vacuum leak but only when i hit the gas. as soon ass soon as i let up off the gas the sound stops. at the same time when the sound is going on i loose power and cant accelerate all that much. dose any one have a clue what may be going on?
white 2000 ford ranger XLT 4x4 sport x-cab flair side 3.0 flex fuel. fog light powder rims 3" bl t-bar crank. red 98 ranger 2x4 sport 5spd
justin.evans29 skype id
Reply With Quote
Old 02-11-2011, 10:24 PM
pooleo pooleo is offline
Ban Survivor. (x2)
Join Date: Jun 2010
Posts: 6,764
Default Re: need help please

I would say the air box lid/cover has come loose, the vaccum sound is the air sucking hard and the POW the lid moves off. Check your clamps, make sure everything is were it should be.


squelling and loosing power...... I would say your alternator seized up.


But yeah, loosing power, cant excelerate a lot sounds like the air box lid popped, filter fell off the MAF and your sucking to much air accross the MAF
1999 | Ext. Cab | 4.0 | 4x4 | 4.10's
A Gladiator does not fear death. He embraces it. Caresses it. Fucks it. Each time he enters the arena, he slips his c0ck in the mouth of the beast, and prays to thrust home before the jaws snap shut. - Oenomaus
Ball Joints/Upper A-Arms How To
Replace Door pin/bushing
Repair broken dome light tabs
Reply With Quote

3.0l, engine, engine problems, engine pulley, vacuum leak

Thread Tools Search this Thread
Search this Thread:

Advanced Search