Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 01-26-2011, 03:33 PM
badasblue badasblue is offline
Learning to use the forums
 
Join Date: Jan 2011
Posts: 2
Default need help bad

i have a 2000 ford ranger with the 3.0l flexfuel v6 in it and 140xxx miles the truck has always been real reliable and haven't had any problems till now when all the sudden my check engine light came on and i let the truck idle and it seems to be running way to rich, i put new plugs, wires, o2 sensors and fuel filter on it and its doing a little better now but its still running rich the codes that are still on are codes for all 3 o2s,fuel compensation sensor, and a code that says the factory emission settings are malfunctioning i really would appreciate any help that i could get
Reply With Quote
  #2  
Old 01-26-2011, 06:30 PM
wvcat wvcat is offline
Ford Ranger Driver
 
Join Date: Jan 2010
Posts: 836
Default Re: need help bad

I've never had this problem but I read somewhere about the fuel compensation sensor connector getting corroded and causing problems, it might be worth checking.
__________________
22 and counting...
Reply With Quote
  #3  
Old 01-27-2011, 09:21 AM
badasblue badasblue is offline
Learning to use the forums
 
Join Date: Jan 2011
Posts: 2
Default Re: need help bad

i checked the connection and it was clean but i sprayed connector cleaner on it anyway and cleared the codes but after i restarted it the same codes were back
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
how bad is it......? Skylark65 General Ford Ranger Discussion 8 01-17-2011 06:35 PM
I want one of these bad.. IndianScout Off Topic 10 01-10-2011 12:12 PM
Is this bad? Scott3483 Vehicle Snapshots 7 01-05-2011 06:09 AM
Craigslist / eBay Find: Not bad at all brett20 Trucks 2 12-23-2010 11:48 AM
Need help bad 90onDubz 2.9 Liter Tech 6 12-07-2009 09:49 PM