Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 01-25-2011, 03:32 PM
MTman777 MTman777 is offline
Back in black (kinda)
 
Join Date: Jan 2011
Posts: 1,276
Default OD?

Hey guys.. got a question.. maybe one of you has some advice to point me in the right direction. I have the 3.0 with the 4R44E tranny with o/d.. question is my od doesnt work.. i cant get it to turn off. Dont know if maybe its the switch or if its something else. Any ideas? and my tranny works fine. Only has 93,000 miles on it.
__________________
00 Ford F-250...5.4L with some goodies, 4x4, Auto out of a 7.3 powerstroke w/ stage 2 TC , Crew Cab, Burnt orange, 35x12.5 MT Baja ATZ's on 20x10 Motometals, Pioneer Deck, Scanguage, Magnaflow exhaust, LED signal tow mirrors, and a Hidden hitch gooseneck

Last edited by MTman777; 01-25-2011 at 03:40 PM.
Reply With Quote
  #2  
Old 01-25-2011, 03:35 PM
EMB1230 EMB1230 is offline
On my 3rd Ranger
 
Join Date: Apr 2010
Posts: 1,398
Send a message via AIM to EMB1230 Send a message via Yahoo to EMB1230 Send a message via Skype™ to EMB1230
Default Re: OD?

Normally, O/D is on, that switch turns it OFF, hence why it says O/D OFF.
__________________
1987 2.3/TK5, 125K.
Reply With Quote
  #3  
Old 01-25-2011, 03:40 PM
MTman777 MTman777 is offline
Back in black (kinda)
 
Join Date: Jan 2011
Posts: 1,276
Default Re: OD?

my bad... duh... sorry guys.. cant get it to turn off when i want to tow and such...
__________________
00 Ford F-250...5.4L with some goodies, 4x4, Auto out of a 7.3 powerstroke w/ stage 2 TC , Crew Cab, Burnt orange, 35x12.5 MT Baja ATZ's on 20x10 Motometals, Pioneer Deck, Scanguage, Magnaflow exhaust, LED signal tow mirrors, and a Hidden hitch gooseneck
Reply With Quote
  #4  
Old 01-25-2011, 04:10 PM
EMB1230 EMB1230 is offline
On my 3rd Ranger
 
Join Date: Apr 2010
Posts: 1,398
Send a message via AIM to EMB1230 Send a message via Yahoo to EMB1230 Send a message via Skype™ to EMB1230
Default Re: OD?

Fuses?
__________________
1987 2.3/TK5, 125K.
Reply With Quote
  #5  
Old 01-25-2011, 06:37 PM
Fordzilla80 Fordzilla80 is offline
Welcome to FRF!
 
Join Date: Oct 2010
Posts: 8,952
Default Re: OD?

Does the O/D Off light come on when you hit the switch? If not, could be a fuse, or the switch, or the wiring. If the previous owner did alot of hilly driving and continuously used the switch to shut O/D Off, then the switch could be bad as the switch isn't designed for continuous use on every hill.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search