Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 12-03-2010, 03:25 PM
scoscheranger scoscheranger is offline
Learning to use the forums
Join Date: Nov 2010
Posts: 6
Default P1633 Code showing.

After many, many hour of trying to diagnose the problem to my monitors not staying ready, I finally got a code to show up, that code being P1633, which is KAM Low Voltage. Now, all fuses are fine, the battery, cables, and everything is fine. I even "jumped" power straight to the KAM power supply wire. Still nothing. So I'm wondering if there is a way around it, or do I of course, have to get a new PCM. If I do need a new PCM, where can I get a good deal? Ford dealership is $535 for the computer, $50 for install and another $100 to flash it, and thats an outrageous price.
'00 Ranger with stuff done

LC Crew
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ford Canda still showing FX4 availible..unfair! dixie_boysles General Ford Ranger Discussion 64 12-01-2010 07:43 PM
showing it's age davidjsouth Exterior Tech 12 03-07-2010 06:04 PM
Code po420 Nick 4-Cylinder Tech 7 01-04-2010 11:36 AM
code p1409 Brian863 3.0 Vulcan Tech 3 11-10-2009 12:51 PM
Showing off my rangers BILTRITE BULLIES Vehicle Snapshots 14 07-18-2009 10:41 PM