Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 11-22-2010, 09:40 AM
trytro trytro is offline
Ford Truck Driver
 
Join Date: Oct 2010
Posts: 76
Exclamation bad ground causing cpu problems?

well the title of my post pretty much explains it all. i was wondering if a bad ground could cause the cpu to act wierd. my engine is a little shotty to say the least and my dad seems to think all my problems are caused by the cpu. Also for some reason my truck always always always will die when ever its cold outside. i live in South dakota so winter is pretty impossible to escape so i need help with this problem badly. i will start my truck and i will give it about ten minutes or so then i put it in Drive and it shuts off plain and simple. then as i go down the road i take a left turn and the engine gets very very close to dying. the gauges will all go down momentarily and the lights will dim and then it acts like normal... more than one time though my truck has died oon that turn. it is really bad especially in town cause i feer i will get hit by another car if my truck dies :l
Reply With Quote
  #2  
Old 11-22-2010, 10:34 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: bad ground causing cpu problems?

No it probably has nothing at all to do with any of the computer components. Since you haven't listed any information about your truck at all, there is nothing anyone is going to be able to suggest that is accurate or targeted.

I read your other threads about this same problem. This is not a computer issue. You need to just do some actual normal maintanence on the truck and it will probably be fine. Fuel filter and plugs will be the big ones for the problem you're describing.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #3  
Old 11-22-2010, 11:10 AM
richarddhoward richarddhoward is offline
Road Trippin' King!
 
Join Date: Nov 2009
Posts: 5,010
Send a message via MSN to richarddhoward
Default Re: bad ground causing cpu problems?

Yeah, I'd agree, do some maintenance to the truck, clean the mass air flow sensor as well. If it is an electronic problem, its 99 percent not likely to have anything to do with the main computer

And an added suggestion for the forum, make a signature with the specs of your truck so we know what we are looking at.
__________________
97 Ranger - 4.0 V6 auto, 4wd, 31x10.5x15s Wild Country XTX Sport All Terrains, Warn locking hubs, Pioneer deck with iPod attachment, Snugtop Topper, K&N filter, scan gauge II, Hella 500 Lights, More parts coming, waiting for the paycheck to get bigger!

Truck built in loving memory of Norm Howard
Outcast Racing
PNW Crew!!!
Afterhours Clan!!
Quote:
Originally Posted by aaron_ariens View Post
I think Henry just shit himself
Quote:
Originally Posted by Radness View Post
Its kind of like that carnival game "Whack A Mole" but with guns! Haha
Reply With Quote
  #4  
Old 11-22-2010, 03:40 PM
trytro trytro is offline
Ford Truck Driver
 
Join Date: Oct 2010
Posts: 76
Default Re: bad ground causing cpu problems?

ok i will do that signature thing here in a bit but i already cleaned the mas and changed spark plugs, put sea foam in the gas, new gas filter the works you know but i got a 92 xlt and i am still under 100000 miles
Reply With Quote
  #5  
Old 11-22-2010, 03:43 PM
richarddhoward richarddhoward is offline
Road Trippin' King!
 
Join Date: Nov 2009
Posts: 5,010
Send a message via MSN to richarddhoward
Default Re: bad ground causing cpu problems?

Quote:
Originally Posted by trytro View Post
ok i will do that signature thing here in a bit but i already cleaned the mas and changed spark plugs, put sea foam in the gas, new gas filter the works you know but i got a 92 xlt and i am still under 100000 miles
Does it have power steering?
__________________
97 Ranger - 4.0 V6 auto, 4wd, 31x10.5x15s Wild Country XTX Sport All Terrains, Warn locking hubs, Pioneer deck with iPod attachment, Snugtop Topper, K&N filter, scan gauge II, Hella 500 Lights, More parts coming, waiting for the paycheck to get bigger!

Truck built in loving memory of Norm Howard
Outcast Racing
PNW Crew!!!
Afterhours Clan!!
Quote:
Originally Posted by aaron_ariens View Post
I think Henry just shit himself
Quote:
Originally Posted by Radness View Post
Its kind of like that carnival game "Whack A Mole" but with guns! Haha
Reply With Quote
  #6  
Old 11-22-2010, 03:44 PM
trytro trytro is offline
Ford Truck Driver
 
Join Date: Oct 2010
Posts: 76
Default Re: bad ground causing cpu problems?

yup and how do i set a signature
Reply With Quote
  #7  
Old 11-22-2010, 03:49 PM
richarddhoward richarddhoward is offline
Road Trippin' King!
 
Join Date: Nov 2009
Posts: 5,010
Send a message via MSN to richarddhoward
Default Re: bad ground causing cpu problems?

http://www.fordrangerforum.com/profi...=editsignature
__________________
97 Ranger - 4.0 V6 auto, 4wd, 31x10.5x15s Wild Country XTX Sport All Terrains, Warn locking hubs, Pioneer deck with iPod attachment, Snugtop Topper, K&N filter, scan gauge II, Hella 500 Lights, More parts coming, waiting for the paycheck to get bigger!

Truck built in loving memory of Norm Howard
Outcast Racing
PNW Crew!!!
Afterhours Clan!!
Quote:
Originally Posted by aaron_ariens View Post
I think Henry just shit himself
Quote:
Originally Posted by Radness View Post
Its kind of like that carnival game "Whack A Mole" but with guns! Haha
Reply With Quote
  #8  
Old 11-22-2010, 04:01 PM
2002 2WD Edge 2002 2WD Edge is offline
Ford Tough
 
Join Date: Mar 2010
Posts: 387
Default Re: bad ground causing cpu problems?

Quote:
Originally Posted by richarddhoward View Post
Or scroll to the top of the page..click on user CP...edit signature is in the list you will see.
__________________
JBA s.s. headers&exhaust, K&N cold air intake, Bosch Iridium Plus 4 plugs, Royal Purple in motor, 5spd & diff.,Superchips programmer, axle girdle. Also have but yet to install KYB Gas-A-Just shocks and Belltech sway bars.
Reply With Quote
  #9  
Old 11-22-2010, 04:26 PM
trytro trytro is offline
Ford Truck Driver
 
Join Date: Oct 2010
Posts: 76
Default Re: bad ground causing cpu problems?

ok i got all my info
__________________
92' v6 3.0 xlt regular cab, 12" sub, really bald tires, powersteering, manuel window, a few problems under the hood, 2wd
Reply With Quote
  #10  
Old 11-22-2010, 04:38 PM
2002 2WD Edge 2002 2WD Edge is offline
Ford Tough
 
Join Date: Mar 2010
Posts: 387
Default Re: bad ground causing cpu problems?

You may be able to have your battery and alternator checked for free. Stick with someone you know and trust if possible. Where you live you need a good battery in the winter. An alternator isn't meant to be a battery charger..rather keeping a good battery topped-up. Doing more than that is hard on it. A battery gone dead a few times and recharged will soon be junk.
__________________
JBA s.s. headers&exhaust, K&N cold air intake, Bosch Iridium Plus 4 plugs, Royal Purple in motor, 5spd & diff.,Superchips programmer, axle girdle. Also have but yet to install KYB Gas-A-Just shocks and Belltech sway bars.
Reply With Quote
  #11  
Old 11-22-2010, 04:45 PM
trytro trytro is offline
Ford Truck Driver
 
Join Date: Oct 2010
Posts: 76
Default Re: bad ground causing cpu problems?

well i bought the truck about 4 months ago and the battery looks like it is getting a lil old but befor last night it never died on me but i was hooking up a sub last night and the battery died cause i had the truck in the garage and when it is 10 degrees outside im not gunna have the door up so runnning the engine was a little out of the question
__________________
92' v6 3.0 xlt regular cab, 12" sub, really bald tires, powersteering, manuel window, a few problems under the hood, 2wd

Last edited by trytro; 11-22-2010 at 07:36 PM.
Reply With Quote
  #12  
Old 11-22-2010, 06:17 PM
mickblock mickblock is offline
Get off my lawn
 
Join Date: Apr 2010
Posts: 1,059
Default Re: bad ground causing cpu problems?

Your last post makes it seem like you think the battery died because your truck was in the garage with the door down?
__________________
08 4.0 Sport 4x4
Stock
Reply With Quote
  #13  
Old 11-22-2010, 06:19 PM
richarddhoward richarddhoward is offline
Road Trippin' King!
 
Join Date: Nov 2009
Posts: 5,010
Send a message via MSN to richarddhoward
Default Re: bad ground causing cpu problems?

Quote:
Originally Posted by mickblock View Post
Your last post makes it seem like you think the battery died because your truck was in the garage with the door down?
10 below zero...it can happen on a weak battery. Lived in Montana for two years, saw it almost every day with other peoples trucks.
__________________
97 Ranger - 4.0 V6 auto, 4wd, 31x10.5x15s Wild Country XTX Sport All Terrains, Warn locking hubs, Pioneer deck with iPod attachment, Snugtop Topper, K&N filter, scan gauge II, Hella 500 Lights, More parts coming, waiting for the paycheck to get bigger!

Truck built in loving memory of Norm Howard
Outcast Racing
PNW Crew!!!
Afterhours Clan!!
Quote:
Originally Posted by aaron_ariens View Post
I think Henry just shit himself
Quote:
Originally Posted by Radness View Post
Its kind of like that carnival game "Whack A Mole" but with guns! Haha
Reply With Quote
  #14  
Old 11-22-2010, 07:30 PM
trytro trytro is offline
Ford Truck Driver
 
Join Date: Oct 2010
Posts: 76
Default Re: bad ground causing cpu problems?

in the post from 2002 he said i should get my battery checked and i was just stating that it has never had any problems with it. the fact that i stated was that my battery did die only once on me but it was in a situation that any battery would have died lol
__________________
92' v6 3.0 xlt regular cab, 12" sub, really bald tires, powersteering, manuel window, a few problems under the hood, 2wd
Reply With Quote
  #15  
Old 11-22-2010, 07:34 PM
richarddhoward richarddhoward is offline
Road Trippin' King!
 
Join Date: Nov 2009
Posts: 5,010
Send a message via MSN to richarddhoward
Default Re: bad ground causing cpu problems?

Quote:
Originally Posted by trytro View Post
in the post from 2002 he said i should get my battery checked and i was just stating that it has never had any problems with it. the fact that i stated was that my battery did die only once on me but it was in a situation that any battery would have died lol
Have them checked, I have to agree, it very well could be a weak battery or alternator
__________________
97 Ranger - 4.0 V6 auto, 4wd, 31x10.5x15s Wild Country XTX Sport All Terrains, Warn locking hubs, Pioneer deck with iPod attachment, Snugtop Topper, K&N filter, scan gauge II, Hella 500 Lights, More parts coming, waiting for the paycheck to get bigger!

Truck built in loving memory of Norm Howard
Outcast Racing
PNW Crew!!!
Afterhours Clan!!
Quote:
Originally Posted by aaron_ariens View Post
I think Henry just shit himself
Quote:
Originally Posted by Radness View Post
Its kind of like that carnival game "Whack A Mole" but with guns! Haha
Reply With Quote
Reply

Tags
cpu, dies, ground, turning

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C Compressor causing engine bog down Kevinr6969 General Tech 10 07-22-2012 04:27 PM
Ford Ranger Truck - Bad Clutch & Starting Problems? Dingo444 Drivetrain Tech 4 02-27-2012 10:38 AM
help with wiring --- signal ground vs chassis ground.... 2010 Audio / Video 6 06-16-2011 03:59 PM
bad ground causing spu problems? trytro 3.0 Vulcan Tech 0 11-22-2010 09:39 AM
Ranger Brake Problems...Need Help Bad!! RangerJR83 General Tech 8 10-28-2010 03:43 AM