Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #16  
Old 11-22-2010, 07:43 PM
trytro trytro is offline
Ford Truck Driver
 
Join Date: Oct 2010
Posts: 76
Default Re: bad ground causing cpu problems?

kk i will look into over this weekend. i am talking to my dad and when we cleaned the mass air flow sensor he used contact cleaner not mafs cleaner is that a big deal? also is it common for a mafs to go bad?
__________________
92' v6 3.0 xlt regular cab, 12" sub, really bald tires, powersteering, manuel window, a few problems under the hood, 2wd
Reply With Quote
  #17  
Old 11-22-2010, 07:44 PM
richarddhoward richarddhoward is offline
Road Trippin' King!
 
Join Date: Nov 2009
Posts: 5,010
Send a message via MSN to richarddhoward
Default Re: bad ground causing cpu problems?

Quote:
Originally Posted by trytro View Post
kk i will look into over this weekend. i am talking to my dad and when we cleaned the mass air flow sensor he used contact cleaner not mafs cleaner is that a big deal? also is it common for a mafs to go bad?
Not uncommon, but not something that I think is causing your issue. And contact cleaner can damage them I'm told but I have no proof of it either way. That's what MAF cleaner is made for.
__________________
97 Ranger - 4.0 V6 auto, 4wd, 31x10.5x15s Wild Country XTX Sport All Terrains, Warn locking hubs, Pioneer deck with iPod attachment, Snugtop Topper, K&N filter, scan gauge II, Hella 500 Lights, More parts coming, waiting for the paycheck to get bigger!

Truck built in loving memory of Norm Howard
Outcast Racing
PNW Crew!!!
Afterhours Clan!!
Quote:
Originally Posted by aaron_ariens View Post
I think Henry just shit himself
Quote:
Originally Posted by Radness View Post
Its kind of like that carnival game "Whack A Mole" but with guns! Haha
Reply With Quote
  #18  
Old 11-22-2010, 08:01 PM
trytro trytro is offline
Ford Truck Driver
 
Join Date: Oct 2010
Posts: 76
Default Re: bad ground causing cpu problems?

lol good point i will see what i can do plus if i have to i live not to far from a huuuuggggeeee junk yard with a few rangers in stock so i might just go get one for 15 bucks to see if there is any change
__________________
92' v6 3.0 xlt regular cab, 12" sub, really bald tires, powersteering, manuel window, a few problems under the hood, 2wd
Reply With Quote
Reply

Tags
cpu, dies, ground, turning

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C Compressor causing engine bog down Kevinr6969 General Tech 10 07-22-2012 04:27 PM
Ford Ranger Truck - Bad Clutch & Starting Problems? Dingo444 Drivetrain Tech 4 02-27-2012 10:38 AM
help with wiring --- signal ground vs chassis ground.... 2010 Audio / Video 6 06-16-2011 03:59 PM
bad ground causing spu problems? trytro 3.0 Vulcan Tech 0 11-22-2010 09:39 AM
Ranger Brake Problems...Need Help Bad!! RangerJR83 General Tech 8 10-28-2010 03:43 AM