Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 10-29-2010, 01:50 PM
Fordzilla80 Fordzilla80 is offline
Welcome to FRF!
Join Date: Oct 2010
Posts: 8,854
Default More Idle Problems

Alright, so this may be something new, or it may be related to my previous problems, i'm not really sure. The truck (2003 3.0) has been idling around 600 at stoplights, which I take as okay-ish. It's lower than i'd like for it to be, but I'm not sure how to effectively bring it up. Anyways, whenever I put the truck in Park, the idle raises to 800. Then, when I go to put the truck in reverse or drive, it dunks down to 300 and almost quits. It has managed to quit about 3 times now since I solved the other problems.

When we put the new IAC on, we just swapped it on as a trouble shooter, and it ended up working. I'm gonna try cleaning it out to see if maybe that helps. Anybody got any other ideas? The throttle body has already been cleaned.
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
High Idle problems santinou 3.0 Vulcan Tech 42 07-29-2016 12:28 PM
3.0 Idle problems Fordzilla80 3.0 Vulcan Tech 61 07-20-2011 01:01 PM
weird idle problems talkington 4.0 SOHC / 4.0 OHV Tech 4 01-28-2010 12:33 PM
91 3.0L idle problems dogboy 3.0 Vulcan Tech 0 06-02-2009 11:45 AM
2.3 idle problems jamesp01 4-Cylinder Tech 0 05-28-2009 05:17 AM