Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 10-28-2010, 06:13 AM
merkchop merkchop is offline
Learning to use the forums
Join Date: Oct 2010
Posts: 11
Default 94' running rough--need suggestions.

Well, I bought my son a 94 extended cap XL (perfect for first vehicle IMO)
The truck would crank up and then instantly die, sounded like fuel problem to me. Got it towed home and started to mess with it, so here is where I am at.... The MAF was so dirty that it would not let the truck run. Cleaned it up and got it running, but went ahead and purchased a new one since it was not running right, not much difference. The truck has an exhaust leak, not bad but enough to let you know it is there.
I also changed the plugs and wires and that seemed to help a little more, but still not right (wants to bog down and rev's high at idle sometimes).
I had a similar problem on my Jeep with the cat. stopped up, so just to try it I unhooked the exhaust from just before the cat. back and it made no difference at all, besides being loud.

The truck will run and I can drive it down the road, but it seems to want to bog down and not run right, plus the idle issue I mentioned.
I still have to get the exhaust leak stopped (p. side manifold bolts were not tight and I think the d. side is the same, just haven't had time to do them yet).
So my question is...what do you think that I should check next to help get rid of the problem??
Planning on getting a gauge to test fuel pressure when I get off work this weekend, but really wonder if there is some other sensor that would cause my problem. Any suggestions and help will be greatly appreciated.
1994 Ranger XL extended cab. 3.0 auto. all stock for now. Just bought for my 16 year old son.
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
New Problems With My 94' earnbud 4-Cylinder Tech 5 05-18-2010 01:00 PM
94' 2.3 Check engine codes I need Help.. Jorge 4-Cylinder Tech 0 05-11-2010 07:19 PM
Running Rough 4.0fan 4.0 SOHC / 4.0 OHV Tech 0 02-20-2010 05:49 PM
Clutch problem, 94' 4 spd 67Bullit Drivetrain Tech 2 01-28-2010 09:22 AM
timing is off on my 94' could it be a sensor? rangerdude General Ford Ranger Discussion 1 09-11-2009 04:51 AM