Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 10-19-2010, 03:38 PM
trytro trytro is offline
Ford Truck Driver
 
Join Date: Oct 2010
Posts: 76
Thumbs down 92 high speed problem

ok so i was passing a guy on the highway today and as i gave the engine some gas it reacted like always and i began to pass him. as i passed him he sped up. i had to give it some more gas and as i almost got in front of him then my engine did somthing really wierd. it started to what i think misfire cause the engine went thrump thrump thrump and the truck shook violently. after that i passed the guy and went on my way. i pulled off the highway and went on my way down the gravel road. as i gave my truck a little gas it did the same thing but as soon as i got up to speed i let off the gass and the engine was fine. my question is what do you think could have caused this and also do you think it could be related to the fuel pump because i have been thinking it has been causeing me greif. when i say that i mean that lately i have been going 55 then letting off the gas a little and the engine will quite and sputter a lil but keeps on going.:con fused:
Reply With Quote
  #2  
Old 10-19-2010, 04:08 PM
2003fordranger1 2003fordranger1 is offline
THE PRICER!!!
 
Join Date: Jul 2010
Posts: 320
Default Re: 92 high speed problem

I had the same thing happen to me when i over filled my gas tank. i was going 70 and it sputtered for 5 seconds, let off the gas and then gave it gas and it never happened again
Reply With Quote
  #3  
Old 10-19-2010, 04:15 PM
trytro trytro is offline
Ford Truck Driver
 
Join Date: Oct 2010
Posts: 76
Default Re: 92 high speed problem

lol thats deffinitly not my problem my gas tank is at about a quarter tank right now
Reply With Quote
  #4  
Old 10-21-2010, 09:48 AM
Solo V8 4G Solo V8 4G is offline
Life is like skid marks
 
Join Date: Oct 2010
Posts: 139
Default Re: 92 high speed problem

do you hear like a pinging noise when this happens? and is it at WOT?
__________________
98 Ranger, Bagged 2600's in the front, 2500's in the rear. 3 Gal tank. DJM Upper and Lower control arms. 2 Thomas Compressors (garbage). 4 linked rear with C-notch. All (except cab) fiberglass. Custom Tribal Paint (soon to be Sunburst/burnt Orange).
Coming soon - 405HP 4.6L (SOHC), 4R70W
Reply With Quote
  #5  
Old 10-22-2010, 09:58 AM
trytro trytro is offline
Ford Truck Driver
 
Join Date: Oct 2010
Posts: 76
Default Re: 92 high speed problem

yea its pretty faint tho
Reply With Quote
  #6  
Old 10-29-2010, 09:24 AM
trytro trytro is offline
Ford Truck Driver
 
Join Date: Oct 2010
Posts: 76
Default Re: 92 high speed problem

i got the problem mostly fixed by replacing the wires and spark pulgs but i dont think that it is completly gone.... what i mean is that everytime i hit 70 or so it will still do it a little. dont get me wrong it has been helped drasticly but i still feel it... could it possible have anyhting o do with the fuel pump or one of those lines?
Reply With Quote
Reply

Tags
engine, high speed, misfire, quites

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fan Speed Control only works on High? 98Vermillion Interior Tech 34 02-03-2014 05:44 PM
Fan Speed-High Only redfish10 General Tech 10 09-16-2011 08:02 AM
4 wheeled high and low range problem mwoolley Drivetrain Tech 0 08-27-2010 12:37 AM
High Idle Problem with AC on miljeep66 4-Cylinder Tech 6 06-26-2010 02:19 PM
Interior fan works on only low & high speed velozp 4-Cylinder Tech 3 03-04-2010 05:15 AM