Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-03-2009, 04:38 PM
lazymtnlady lazymtnlady is offline
Liking the Ford Ranger Forum
 
Join Date: Aug 2009
Posts: 16
Default vacumn hose blows off

We just replaced the EGR valve on my daughters 99 ford ranger, and when we start it, the one hose the has HI above it blows off, it makes a bad noise and blows the hose right off, we just replaced the plugs and wires and now all of a sudden this happens, can anyone help me out with why this is happening and what i need to do to fix it? thank you
Reply With Quote
  #2  
Old 08-03-2009, 04:55 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

Is there anything u can see in the hose causing a blockage?
__________________
2005 Edge

Reply With Quote
  #3  
Old 08-03-2009, 04:58 PM
lazymtnlady lazymtnlady is offline
Liking the Ford Ranger Forum
 
Join Date: Aug 2009
Posts: 16
Default

not that we can see, we don't know if the cataletic converter is plugged and thats whats causing this or what, but it ran fine until we changed the plugs and wires.
Reply With Quote
  #4  
Old 08-03-2009, 05:10 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

What engine do u have.
__________________
2005 Edge

Reply With Quote
  #5  
Old 08-03-2009, 05:14 PM
lazymtnlady lazymtnlady is offline
Liking the Ford Ranger Forum
 
Join Date: Aug 2009
Posts: 16
Default

6 cylinder,, its the 3.0
Reply With Quote
  #6  
Old 08-03-2009, 05:42 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

Only thing I can think of is that the hose it clogged some how.

Is it the vacuum hose coming off the brake booster
__________________
2005 Edge

Reply With Quote
  #7  
Old 08-03-2009, 05:46 PM
lazymtnlady lazymtnlady is offline
Liking the Ford Ranger Forum
 
Join Date: Aug 2009
Posts: 16
Default

no it only comes off the EGR valve, its got 2 hoses and one hose connection is bigger than the other one, and above the smaller one is says REF and the other side has HI on it.
Reply With Quote
  #8  
Old 08-03-2009, 06:12 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

I looked through my manual and like u said before the converter is clogged.

One way to eliminate that is remove it then see what happens.
__________________
2005 Edge

Reply With Quote
  #9  
Old 08-03-2009, 06:55 PM
lazymtnlady lazymtnlady is offline
Liking the Ford Ranger Forum
 
Join Date: Aug 2009
Posts: 16
Default

thank you, i will try that and let you know..
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search