Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #16  
Old 10-11-2010, 03:25 PM
Fordzilla80 Fordzilla80 is offline
Welcome to FRF!
 
Join Date: Oct 2010
Posts: 8,952
Default Re: 3.0 Idle problems

I still need to change out my plugs and wires. I'm pretty sure it'll help me out.

Anyways, came back from the scanner, and the truck passed with flying colors. No current codes, and no pending codes. The only thing that came up was that it seemed the IAC was working too hard to control the airflow or something like that. We swapped one from another truck on, and she's staying above 500, so as long as she isn't dying then i'll be happy. I noticed today while at the shop that the belt tensioner was making a noise, and sure enough when the probe came out it was the source, so she'll be getting a new one of those here soon too.

Last edited by Fordzilla80; 11-08-2010 at 02:08 PM.
Reply With Quote
  #17  
Old 10-11-2010, 03:28 PM
DrIftKi7Vg DrIftKi7Vg is offline
Sunny Soonkyu <3
 
Join Date: Aug 2009
Posts: 4,401
Send a message via AIM to DrIftKi7Vg Send a message via MSN to DrIftKi7Vg
Default Re: 3.0 Idle problems

Nice. In the future, to save you save time and gas, I would order yourself an Ultra Gauge. Some members on here have them and they look amazing! I want to get one then again I want to get so much stuff right now for the truck before winter season hits . Take a look at it. It reads codes and pending ones, fuel gauge, speed, rpm and more. http://www.ultra-gauge.com/ultragauge/index.htm
__________________
Sunny
2002 Ford Ranger Edge Flex Fuel 2wd
LED Crazy!
Complete Pioneer Audio setup
5000k HID Projector retrofit and 3000k Fogs
Super Turbo Dynomax Exhaust
Mustang Dome Light Mod - Fog Light Mod
Achilles Desert Hawk 255/45/20 with 20'' rims

Much more!
Reply With Quote
  #18  
Old 10-11-2010, 05:20 PM
Fordzilla80 Fordzilla80 is offline
Welcome to FRF!
 
Join Date: Oct 2010
Posts: 8,952
Default Re: 3.0 Idle problems

Wow, that's pretty cool. That'll be on my list down the road for sure. Thanks man!
Reply With Quote
  #19  
Old 10-11-2010, 05:22 PM
DrIftKi7Vg DrIftKi7Vg is offline
Sunny Soonkyu <3
 
Join Date: Aug 2009
Posts: 4,401
Send a message via AIM to DrIftKi7Vg Send a message via MSN to DrIftKi7Vg
Default Re: 3.0 Idle problems

No problem.
__________________
Sunny
2002 Ford Ranger Edge Flex Fuel 2wd
LED Crazy!
Complete Pioneer Audio setup
5000k HID Projector retrofit and 3000k Fogs
Super Turbo Dynomax Exhaust
Mustang Dome Light Mod - Fog Light Mod
Achilles Desert Hawk 255/45/20 with 20'' rims

Much more!
Reply With Quote
  #20  
Old 10-12-2010, 04:42 PM
snipes040 snipes040 is offline
Buy a Ford
 
Join Date: Aug 2010
Posts: 194
Default Re: 3.0 Idle problems

hey guys I was wondering if there are any tips or hints that you could give me to make changing the spark plugs easier..? I'm planning on doing it within the next two months.

thanks a lot guys
Reply With Quote
  #21  
Old 10-12-2010, 05:44 PM
DrIftKi7Vg DrIftKi7Vg is offline
Sunny Soonkyu <3
 
Join Date: Aug 2009
Posts: 4,401
Send a message via AIM to DrIftKi7Vg Send a message via MSN to DrIftKi7Vg
Default Re: 3.0 Idle problems

There is a write up on this forum. Just use the search box and you will find it.
__________________
Sunny
2002 Ford Ranger Edge Flex Fuel 2wd
LED Crazy!
Complete Pioneer Audio setup
5000k HID Projector retrofit and 3000k Fogs
Super Turbo Dynomax Exhaust
Mustang Dome Light Mod - Fog Light Mod
Achilles Desert Hawk 255/45/20 with 20'' rims

Much more!
Reply With Quote
  #22  
Old 10-12-2010, 06:47 PM
Fordzilla80 Fordzilla80 is offline
Welcome to FRF!
 
Join Date: Oct 2010
Posts: 8,952
Default Re: 3.0 Idle problems

Agreed.

So far she's still idling fine. Hasn't died for a few days.

I've really begun to hate any automatic transmission in these Rangers.The A4LD sucks. The 4R44E sucks. And now it looks like the 5R44E sucks. My next Ranger will be a manual. My 2000 had 189,000 and I believe was in fail safe mode the whole time I had it, and now my 46,000 mile Ranger has done O/D off light about three times. She's gonna be heading to the tranny shop this week to figure out what's causing the o/d off light to go on. Every time it does, I shut the truck off, and the light does not come back on and she shifts perfectly for another 20 or so drive cycles, and then when that dang light comes on, she goes into fail safe mode again. This better be somethin cheap. It's really ridiculous that Rangers can have a TC/VSS/Valve Body/Solenoid problems so early in life.


Rant Over.

I still love the ol Ranger, but not Ford's quality standards.
Reply With Quote
  #23  
Old 10-17-2010, 12:04 PM
Fordzilla80 Fordzilla80 is offline
Welcome to FRF!
 
Join Date: Oct 2010
Posts: 8,952
Default Re: 3.0 Idle problems

Well, I really don't think this has anything to do with it, but you just never know.

The truck is still idling great, holding about 750 at every stop. Anyways, yesterday I replaced the pulley on the belt tensioner because it was making noise as if something was up with the bearings. Now, it seems like the truck is running twice as good as before.
Reply With Quote
  #24  
Old 11-05-2010, 09:09 AM
Fordzilla80 Fordzilla80 is offline
Welcome to FRF!
 
Join Date: Oct 2010
Posts: 8,952
Default Re: 3.0 Idle problems

And now the idle takes a dump again. The truck is back to it's old ways.

I thought I had it fixed too. I'll post back up when I can get it figured out again.
Reply With Quote
  #25  
Old 11-05-2010, 11:40 AM
Solo V8 4G Solo V8 4G is offline
Life is like skid marks
 
Join Date: Oct 2010
Posts: 139
Default Re: 3.0 Idle problems

On first note, I wouldnt change the plugs and wires on any vehicle with under 60k on it. Check your owners manual for suggested intervals for replacement of any maintenance item. Second, always verify a failure to the part you want to replace that way you arent just replacing parts and save money on unecessary repairs. I would do a vacuum check to all your parts, beleive it or not although the IAC may be clean it still may not be able to plunge and adjust as it should. With a voltmeter you can monitor the IAC position

1. with key on engine off, disconnect IAC connector, measure the voltage to the IAC =
voltage should be greater that 10.5volts, if not trace circuit to verify why. Must have at least 10.5 in the electrical system to get accurate readings
2. check resistance - should be between 6-13OHMS, if not in range... replace
3. check for short (only if the previous diagnosis did not help) - measure resistance from IAC case to IAC pin (plunger) if less than 10k OHMS - replace

If none of these check out to be out of the listed specs I would continue your diag to other area's of your trucks intake system. i.e. vaccum leaks, pinched hoses, or clogged airways.
__________________
98 Ranger, Bagged 2600's in the front, 2500's in the rear. 3 Gal tank. DJM Upper and Lower control arms. 2 Thomas Compressors (garbage). 4 linked rear with C-notch. All (except cab) fiberglass. Custom Tribal Paint (soon to be Sunburst/burnt Orange).
Coming soon - 405HP 4.6L (SOHC), 4R70W
Reply With Quote
  #26  
Old 11-05-2010, 12:47 PM
Fordzilla80 Fordzilla80 is offline
Welcome to FRF!
 
Join Date: Oct 2010
Posts: 8,952
Default Re: 3.0 Idle problems

Thanks for the info man. Will a vacuum gauge from Harbor Freight suffice for testing the vacuum?
Reply With Quote
  #27  
Old 11-05-2010, 01:00 PM
Solo V8 4G Solo V8 4G is offline
Life is like skid marks
 
Join Date: Oct 2010
Posts: 139
Default Re: 3.0 Idle problems

yeah, that should work just fine.
__________________
98 Ranger, Bagged 2600's in the front, 2500's in the rear. 3 Gal tank. DJM Upper and Lower control arms. 2 Thomas Compressors (garbage). 4 linked rear with C-notch. All (except cab) fiberglass. Custom Tribal Paint (soon to be Sunburst/burnt Orange).
Coming soon - 405HP 4.6L (SOHC), 4R70W
Reply With Quote
  #28  
Old 11-05-2010, 01:02 PM
Fordzilla80 Fordzilla80 is offline
Welcome to FRF!
 
Join Date: Oct 2010
Posts: 8,952
Default Re: 3.0 Idle problems

Alright sweet. I need to dig through my multi meters and find one that works.

Thanks again! I'll post back what I find.
Reply With Quote
  #29  
Old 11-05-2010, 01:10 PM
Solo V8 4G Solo V8 4G is offline
Life is like skid marks
 
Join Date: Oct 2010
Posts: 139
Default Re: 3.0 Idle problems

No problem bro, yeah let us know....
__________________
98 Ranger, Bagged 2600's in the front, 2500's in the rear. 3 Gal tank. DJM Upper and Lower control arms. 2 Thomas Compressors (garbage). 4 linked rear with C-notch. All (except cab) fiberglass. Custom Tribal Paint (soon to be Sunburst/burnt Orange).
Coming soon - 405HP 4.6L (SOHC), 4R70W
Reply With Quote
  #30  
Old 11-05-2010, 01:38 PM
01DangerRanger 01DangerRanger is offline
Custrom User Title Here
 
Join Date: Apr 2010
Posts: 4,104
Default Re: 3.0 Idle problems

u better make it out to the meet with all these problems
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
High Idle problems santinou 3.0 Vulcan Tech 42 07-29-2016 12:28 PM
weird idle problems talkington 4.0 SOHC / 4.0 OHV Tech 4 01-28-2010 01:33 PM
1987 2.0 idle problems 1987ranger 4-Cylinder Tech 2 12-14-2009 11:26 AM
91 3.0L idle problems dogboy 3.0 Vulcan Tech 0 06-02-2009 11:45 AM
2.3 idle problems jamesp01 4-Cylinder Tech 0 05-28-2009 05:17 AM