Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 07-05-2009, 06:39 PM
Red98 Red98 is offline
Learning to use the forums
Join Date: Jul 2009
Posts: 4
Default Radiator/coolant question

This is my first post to the FRF

I believe I'm losing engine coolant somehow, because I had it flushed and exchanged a few days ago, and the reservoir is empty.

Long story short, I bought some coolant to add and see if I could find the leak. I didn't see markings on the reservoir for "Hot Full/Cold Full" so I added it directly into the radiator I did run the vehicle for about 20 mins after adding, and everything seemed to be okay...

Is this bad? I found an owners manual online that advises against this, but doesn't say why.

*Truck in question is a 98 Ranger XLT 4x4, 3.0 6 with 89,500 on it.

Last edited by Red98; 07-05-2009 at 09:05 PM. Reason: a little rephrasing
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Why is my radiator coolant.... FreestylinDirtbiker 3.0 Vulcan Tech 11 04-07-2014 04:30 AM
Leaking coolant, not sure how to fix. Jereme109 General Ford Ranger Discussion 3 05-03-2009 11:08 PM
what is the tank called on a ford ranger where you fill the coolant? Trace O General Ford Ranger Discussion 1 01-25-2009 06:57 PM