Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 10-09-2018, 08:52 AM
allyncooper allyncooper is offline
Ford Truck Driver
 
Join Date: Aug 2010
Posts: 79
Default Low idle on startup

1998 3.0 manual with 190xxx mi.

On startup low idle to the point it cuts out at times. Normal would be going to 1500 rpm for a while then dropping to about 750 which was what it used to do. Funny thing is sometimes it works normally, but lately about 90% of time it just stays at low idle. Cold weather now so more of a problem. No codes.

Cleaned the MAF and IAC awhile ago. Seemed OK after that but then the problem started. My thought is to replace the IAC but I just don't want to start throwing parts at the problem which may or not fix it.

Any thoughts on what might be the problem? TIA
__________________
1998 4wd XLT 3.0 5 speed
8.8 4.10 LS axle with disk brakes/ 4.10 front diff
constant front halfshafts
31.5 x 15 Khumo tires
Odyssey start battery / 125 amp deep cycle batery
Dometic 1.3 cf refrigerator
Reply With Quote
  #2  
Old 10-09-2018, 10:18 AM
Dirtman Dirtman is offline
Ford Truck Driver
 
Join Date: Jul 2018
Posts: 81
Default Re: Low idle on startup

Simple test for the IAC. Start the truck cold and unplug the IAC valve. If the RPMs don't drop further or imedietley stall then the IAC is most likely stuck in the closed position.

This test can diagnose a vac leak as well but you would have higher idle with a vac leak. And unplugging the IAC would still keep a high idle speed.
Reply With Quote
  #3  
Old 10-09-2018, 01:44 PM
allyncooper allyncooper is offline
Ford Truck Driver
 
Join Date: Aug 2010
Posts: 79
Default Re: Low idle on startup

Thanks for the tip. Be a couple days until I can check it out. Let you know.
__________________
1998 4wd XLT 3.0 5 speed
8.8 4.10 LS axle with disk brakes/ 4.10 front diff
constant front halfshafts
31.5 x 15 Khumo tires
Odyssey start battery / 125 amp deep cycle batery
Dometic 1.3 cf refrigerator
Reply With Quote
  #4  
Old 10-09-2018, 03:49 PM
Dirtman Dirtman is offline
Ford Truck Driver
 
Join Date: Jul 2018
Posts: 81
Default Re: Low idle on startup

You can also unbolt the IAC and keep it plugged in, have someone turn the ignition on and watch the valve. It should open all the way up. Again if it doesn't its stuck closed. Just another way to verify the same problem without "throwing parts at it". IAC valves are simple solenoids that don't electronically fail as often as they just get clogged or stuck.

btw, love your avatar.

Last edited by Dirtman; 10-09-2018 at 03:52 PM.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
'04 SOHC ticking on startup, idle, and under load Toasty95 4.0 SOHC / 4.0 OHV Tech 12 03-17-2016 05:18 PM
Rough idle on startup daveo869 4.0 SOHC / 4.0 OHV Tech 12 09-09-2014 12:19 AM
99 3.0L - Rough IDLE at startup then clears within a minute justinftw 3.0 Vulcan Tech 7 10-27-2012 07:21 PM
'94 Temporary rough idle/bog at startup KSteng 4.0 SOHC / 4.0 OHV Tech 2 08-29-2012 01:03 PM
Strange idle at startup smitty General Ford Ranger Discussion 8 09-18-2009 02:25 PM