Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 07-14-2018, 01:02 PM
Bobb Bobb is offline
Ranger Newbie as of 8/'11
 
Join Date: Apr 2011
Posts: 9
Default Very Bad Bucking V6!

Hello Everyone!

Here's the issue with my 2000 Ranger XLT w/3.0 V6.....~143,000 MILES

Engine runs like a well-oiled sewing machine under 3500RPM, but when truck is stationary in neutral, revving the engine above 3500 - 4000 RPM causes violent engine shaking and bucking....really bad. It's as if one of the cylinder banks just quits, causing bad physical imbalance. I'm sure the same thing is happening when cruising and I try to rev it over 4K, but the shaking is dampened then because the vehicle is in gear and moving.

CE light came on months ago, but that was/is intermittent. It did throw some codes I can't remember, but I believe they were "P0xxx" codes relating to 02 sensors. Unfortunately, the battery died recently, and when installing a new one, the codes got cleared. Once everything resets itself after some drive cycles, I'll use the analyzer and read codes again (it shows "pending" codes now).

Anyway.......

One thing I have notice right now is that when this problem is happening, the voltages on ALL the 02 sensors drop to 0, returning to "normal" reading when engine goes back to idle. I thought that is quite strange. If just one O2 sensor did that, I wouldn't be surprised...but all three?

I've search the forum for threads that contained anything like this, but none appear to describe exactly what I am experiencing.

So....any ideas? THANKS!!!!!
__________________
Bobb
Coatesville, PA (Suburban Philadelphia)

2000 Ford Ranger XLT: Stepside Bed, Xtra Cab, 3-liter w/Auto, Tremor Audio Package - Chrome Yellow/Gray
Reply With Quote
  #2  
Old 07-15-2018, 09:40 AM
Bobb Bobb is offline
Ranger Newbie as of 8/'11
 
Join Date: Apr 2011
Posts: 9
Default UPDATE - Re: Very Bad Bucking V6!

Hello Again. I just took another OBD-II scan and found a pending code "P0153" which is O2 sensor slow response. I figured that a faulty O2 sensor or associated wiring is at fault, maybe even with more than one sensor. I'll be doing the typical searches for vacuum leaks, wire/connector issues, etc.

Standing by for any input anyone can offer. There are a number of threads discussing such issues, but I've seen none that describe the violent bucking over 4,000 RPM that I've been experiencing.

Thanks for any input you can share.
__________________
Bobb
Coatesville, PA (Suburban Philadelphia)

2000 Ford Ranger XLT: Stepside Bed, Xtra Cab, 3-liter w/Auto, Tremor Audio Package - Chrome Yellow/Gray
Reply With Quote
  #3  
Old 07-15-2018, 10:09 AM
Ugxibowden Ugxibowden is offline
Ford Ranger Owner
 
Join Date: Jun 2017
Posts: 51
Default Re: Very Bad Bucking V6!

When in park or neutral Iím pretty sure there is a rev limiter on these vehicle as mine also does this.


Sent from my iPhone using Tapatalk

----------

Quote:
Originally Posted by Ugxibowden View Post
When in park or neutral Iím pretty sure there is a rev limiter on these vehicle as mine also does this.


Sent from my iPhone using Tapatalk


Also my truck would buck and jerk while accelerating hard anywhere from 45mph upwards until I let off the gas then slowly accelerated to speed.

The problem there was a camshaft synchroniser starting to go bad, they usually go out between 80k-100k miles.
Once I had that replaced my truck no longer bucks or jerks under acceleration


Sent from my iPhone using Tapatalk
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
96 Bucking Billraft 4-Cylinder Tech 2 11-18-2014 09:27 PM
what do you guys mean by bucking... 2010 4-Cylinder Tech 7 01-28-2014 10:51 AM
Bucking and jerking brownb2 Introduce Yourself 4 05-07-2013 01:40 PM
Bucking/Jerking Dropsy 4.0 SOHC / 4.0 OHV Tech 8 11-30-2012 06:06 PM
Bucking? 2k2edge 3.0 Vulcan Tech 0 02-28-2012 06:14 AM